Sign in with
Sign up | Sign in
Your question

nVidia drivers for Windows 7 x64

Last response: in Graphics & Displays
Share
September 1, 2009 4:28:12 AM

Yo, just installed Windows 7 x64 RTM, now I'm just installing the drivers for the 9500GT -- proof I have it working and installed on XP
  1. http://z0r.us/images/gpu.gif



Firstly I put the CD that came with the hardware in, I tried it and it said "setup not supported [only 32-bit]", so I then went to the nVidia website and did an auto-scan, came back with a verison "186.81_notebook_win7_winvista_64bit_international_whql", I downloaded and tried to install, same error as before, I did a manual search and entered;

  1. [b]DOWNLOAD DRIVERS:[/b]
  2. Product type: [b]GeForce[/b]
  3. Product Series: [b]GeForce 9 Series[/b]
  4. Operating System: [b]Windows 7 64-biit[/b]
  5. Language: [b]English (US)[/b]


Downloaded it but no it didn't work once again, same error.

Now as a last resort I shall now spawn on you technology savvy guys/girls to help me out with the problem at hand, here is the "190.62_desktop_win7_winvista_64bit_english_whql" that is supposed to work on my PC -- even says it supports the 9500GT but I keep getting the same error message.
  1. http://www.nvidia.com/object/win7_winvista_64bit_190.62_whql.html


and this is the error I recieve each time



I have also tried running it in different compatiablity modes such as with Windows Vista SP1, Windows XP (SP1) etc.

I've also tried doing it via Windows Update yet it still doesn't work.
a c 273 U Graphics card
a b $ Windows 7
a b \ Driver
September 1, 2009 1:56:15 PM

Uninstall all graphic drivers and go back to the default W7 driver, then go into the system32 folder and delete all the nvidia driver files and reboot this may cause W7 to have a bit of a spaz when it restarts as it looks for a driver, just let it do it's thing and once it's settled re install the latest driver. I have done this with XP and Vista64 pre SP2 but not with W7 so I can't guarantee it'll work.
m
0
l
a b U Graphics card
September 1, 2009 3:09:46 PM

On a recent install of a 9600GSO on a system using windows7 64bit i ended up having to use Vista 64bit drivers. Like mousemonkey says, clean out all your old drivers first.
m
0
l
September 2, 2009 4:45:06 AM

Tried it, unsuccesful it seems so far.
Also tried changing the primary video card settings via the BIOS
[PCI]
[PCI-E]
[VGA]
Another unsuccesful attempt to fix the problem, win7 just doesn't detect the 9500, and it goes with the VGA
m
0
l
!