Sign in with
Sign up | Sign in
Your question

X1950 Pro Crossfire power requirement

Last response: in Components
Share
November 6, 2009 9:23:07 PM

I have right now two Radeon X1950 Pro video cards, a Crossfire connector, and a 6 pin PCI-E power adapter.

Here's my power supply: http://www.zumaxpower.com/products/zu500w.htm

500W with 20A on two 12V rails. I know ATI says to have 550W with 38 amps. Before I try anything, I just want to make sure that my computer isn't going to explode. I'm not 100% sure on how two 12V compares to just one. I've heard a bunch of times that you just add the amps together, which I guess puts me at 40A. This is a completely free performance upgrade for me (the other card and little cables are leftover from my brother's old computer), so saying "buy a 5870!" will make me :fou:  . Do you think this will work fine?

Here are my other things if you need them:

Abit IL9 Pro
Intel Core 2 Duo E6400
2GB DDR2 RAM (2x1GB)
WD Caviar Black 1TB SATA
Asus Xonar DX
Edimax Wifi card
DVDRW drive
1 120MM LED case fan
1 80MM LED case fan
November 6, 2009 10:03:59 PM

There in only ONE way to find out...
It could go either way, only way to find out is to try. You might have problems after gaming for a bit (heat or power issues)
You're gonna need to use the Y adapter for one of the cards then, correct?
November 6, 2009 10:12:50 PM

doormatderek said:
There in only ONE way to find out...
It could go either way, only way to find out is to try. You might have problems after gaming for a bit (heat or power issues)
You're gonna need to use the Y adapter for one of the cards then, correct?

I'm really only worried about some crazy situation where my PSU blows up and takes everything else with it. If it just doesn't run well, then I haven't lost anything except a bit of time. I could always press the TURBO BUTTON to increase fan speed to MAXIMUM!!! And yes the adapter is for one of the cards.
Related resources
November 6, 2009 10:31:52 PM

All I can tell you is I've had a psu 'blow' up on me....
and that x1900 series card is 4 generations old....
You have to at least try it, but if you start getting lockups, or random reboots.... its GAME OVER
November 7, 2009 2:50:04 AM

I just went ahead and tried it. No explosions so far. My computer doesn't seem to detect the second video card and it doesn't detect the sound card (it's also PCI-E) when both video cards are plugged in.

Edit: I just checked the manual and apparently it's supposed to disable the x1 slot when the second x16 slot is in use. Ridiculous...
a c 144 ) Power supply
November 7, 2009 6:08:32 AM

Comments in no particular order:

You have a mediocre power supply of old design. The first indication is the relatively heavy 5 volt max (46 amps). Anything over 20 amps is wasted. In a modern PSU, the 12 volt outputs do all the heavy lifting.

The next is the max output ratings of the rest of the PSU. For example, the label say two rails, each with a maximum of twenty amps. That does not mean you can pull a total of 480 watts out of a 500 watt PSU. The third indication is the single PCI-e connector in a 500 watt power supply.

Compare this to the Antec 500 watt Earthwatts PSU:
http://www.newegg.com/Product/Product.aspx?Item=N82E168...

Now the good news:
The reason why this should work for you in spite of the PSU is that a pair of X1950's by themselves only need a bit less than 10 amps. The ATI recommendations are for a complete "typical" system. Manufacturers all most always overestimate the necessary power consumption.

The sound card? Sorry. All I can do is commiserate.
November 7, 2009 6:53:26 AM

Once I found out that my sound card wasn't going to work no matter what I just gave up. I'm thinking about selling the 1950s and buying something like a 4770 or 4850 or waiting for the 5000 series cards to get a bit cheaper.
!