Sign in with
Sign up | Sign in
Your question

Can't copy a lrage (5GB) file to a USB flash drive

Last response: in Storage
Share
May 28, 2011 12:36:09 PM

Hello Everybody:

I have a pretty large file (As mentioned in the title - 5GB).
I want to to transfer this file to a flash drive, and the error that appears says, that the file is to large for the drive itself.

Some important details:

*) Windows Vista

*) Two 8GB flash drives were tested and with both, the error appeared. (In general, with other files these flash drives work)

*) The file to be transferred is a video file.

*) The drives are completely empty, and were even formatted.

*) This problem occurs with several files at about the same size.

Any help will be appreciated.

Thank you.
May 28, 2011 6:52:28 PM

If the external drive is formatted as FAT32, the maximum file size is 4.3GB, so unless the drives are formatted as NTFS volumes, this is most likely your problem.
m
0
l
a c 415 G Storage
May 28, 2011 7:12:03 PM

^+1

If you reformat your flash drive as NTFS you should be able to copy the file to it.
m
0
l
Related resources
May 28, 2011 10:53:00 PM

That's right... Now that you mention it, I do remember reading about it somewhere...

Formatting the drive as NTFS causes another problem, which is, and correct me if I'm wrong, a DVD not being able to read from the drive (Formatted as NTFS).

If I'm right, and the DVD is really not able to read from the NTFS drive, what can I do?

Thank you.
m
0
l
a c 415 G Storage
May 28, 2011 11:48:55 PM

The standard DVD file format has a VIDEO_TS folder and uses .VOB files which are broken up into 1GB chunks to avoid the 4GB size limitation. I'm pretty sure that if you export your video in this format and burn it to a FAT flash drive then the DVD player would be able to read it.
m
0
l
July 4, 2011 10:04:28 AM

davel_68 said:
If the external drive is formatted as FAT32, the maximum file size is 4.3GB, so unless the drives are formatted as NTFS volumes, this is most likely your problem.



Problem solved for me mate.. Thanks a lot.. :)  :hello: 
m
0
l
March 20, 2012 9:39:20 AM

First try to format as ntfs file system.If you have enough space in usb drive but can't copy to this follow the steps


1.Open a new note pad file.

2.Copy this

cd\
reg add “HKLM\System\CurrentControlSet\Control\StorageDevicePolicies” /t Reg_dword /v

WriteProtect /f /d 0

3.save it as DISABLEWP.BAT

4.Then copy it to start up folder.

When you insert a pendrive it remove write protection.If it becomes.Or simply use any software which fix this kind of problem.You may try LONG PATH Tool.It will help you.Thanks
m
0
l
March 28, 2013 7:33:17 AM

Had the same issue. Changed the file system from FAT to NTFS and it worked fine.
To convert FAT to NTFS, right click the drive name of pendrive -> select Format -> File system type select NTFS.
If NTFS is not available (only FAT is available), then Right click at pen drive -> Click Properties -> Select Hardware tab & click properties -> Goto Policies Tab -> Select Optimise for Performance. Now you should have NTFS in Format menu.
Hope this helps
m
0
l
June 9, 2013 12:47:01 AM

Thank you For the Solution!!!
m
0
l
August 10, 2013 10:14:50 AM

Thank you so much. I was getting so frustrated with this and you solved it for me!!!

sminlal said:
^+1

If you reformat your flash drive as NTFS you should be able to copy the file to it.


m
0
l
August 10, 2013 10:15:50 AM

Thanks so much for your help. I was getting so frustrated with this and you solved it for me!! Yay!
m
0
l
September 9, 2013 4:55:52 AM

Use command CONVERT <drive>: /FS:NTFS on windows command prompt
m
0
l
October 12, 2013 3:35:04 AM

sminlal said:
^+1

If you reformat your flash drive as NTFS you should be able to copy the file to it.


m
0
l
November 3, 2013 1:07:35 AM

premjo said:
Use command CONVERT <drive>: /FS:NTFS on windows command prompt


Thanks for this!
I've solved my 4GB limit on FAT32 as easy as pie.
no need format my flash drive, so keeping the data in it...

Cheers!:bounce: 
m
0
l
December 23, 2013 7:25:05 PM

gnawsguz said:
premjo said:
Use command CONVERT <drive>: /FS:NTFS on windows command prompt


Thanks for this!
I've solved my 4GB limit on FAT32 as easy as pie.
no need format my flash drive, so keeping the data in it...

Cheers!:bounce: 


Help .. i really need some advice here , cause i'm not a pro in using computare programs or include use command prompt, some body if you can help me please guide me with ur step slowly and detail as you can.

so this is my problem:

* I've film 4,96 GB

* My Flash disk only 8 GB

* I want to play my film on my Tv that has the usb socket ..

*1st Plan - i know some body will tell me " format ur Flash disk to NTFS then copy ur film, Finish " ok that's help , and work , but when i put it on my tv , it cant read my Flash disk . Then the problem come .. that i must still use the Fat32 setting but .. my film must go into it T.T

*2nd Plan - I've some good idea before .. that i'll split my film then i put in my flash disk , then i will join them in my flash disk .. ohh its very brilliant. But !!!! when i realize some little tiny fatal problem ,when i just realize after i copy the splitted film intoo fd .. My splitted film in my fd total size same as the film .. 4,96 GB , and if i join the splitted in the fd wow it will work 99% but i realize the film that has been joined will have 4,96 GB too ... O.O omg !!! 10GB !!! and my Fd 8gb T.T if my fd 16GB i guess my plan will work.. huft ( 2nd mission FAILED ! with splitting the file. (impossible) ).

*3nd Plan (compare with 1st plan) - when i was very frustated , i search in googe how to Change my Flash disk from NTFS that i've put my 4,96GB film to FAT32 .. W i t h o u t l o o s i n g A n y D a t a . .. OMG !! and prof. Google find it for me T_T im very thankfull to prof google >.< it show me some application that can convert NTFS partition to Fat32 without erase file inside it.

Then i start the operation of 3rd Plan .. i'm very happy at that time,.... when i going to convert my Flash disk from NTFS to Fat 32 with that app . it says .. " you cant convert because the file inside your disk is too Large T.T OMG !!!!!!!!!!!!!!!!!!!!!! " f**K YOU!!! im very frustated again.. ( 3nd mission FAILED ! with 3rd party app to convert ).

* so what should i do now :'(  .... then i come to this forum and look at the bottom comment when my face is very frustated .. i look that someone type this ..shiny word for me .

Use command CONVERT <drive>: /FS:NTFS on windows command prompt[/quotemsg]

Thanks for this!
I've solved my 4GB limit on FAT32 as easy as pie.
no need format my flash drive, so keeping the data in it...

Cheers!:bounce: 

.. what?? that's surprise me .. but i've no idea how to use that command T.T .. those advice is not STRONG! isn't detail for some newbie.. Somebody help :(  how to use that command . to change my 8GB Flash disk that have a 4,96GB flm inside it with setting NTFS to Fat32 and i dont wanna disturb my file T.T .. are this command "CONVERT <drive>: /FS:NTFS" really command that i need? or what ? then can you help me some body ,show me the right step on the Command Promt in windows 7. to convert my fd from NTFS to FAT32 correctly. pleaseee. :'( 
m
0
l
January 3, 2014 5:51:21 PM

defaaja: Go to Windows Start icon --> All Programs --> Accessories --> Command Prompt

Once in Command Prompt, cut and paste or type: CONVERT <drive>: /FS:NTFS

Where it says <drive> you put which drive your USB stick is under. For example, if in the F drive you would type: CONVERT F: /FS:NTFS

Worked great for me, no need to reformat and delete files already on the USB stick.
m
0
l
January 26, 2014 6:26:35 PM

For any mac users having this issue change the format to the exFAT format and change the allocation unit size to the 8,192 bytes and it should work. Had this same issue the only other problem is I had to use my desktop to reformat the usb cause I did not know how to do it on my macbook.
m
0
l
February 25, 2014 2:17:21 AM

Long path tool can helpful on this situation. Thanks
m
0
l
May 31, 2014 11:44:57 PM

Jaimoen said:
davel_68 said:
If the external drive is formatted as FAT32, the maximum file size is 4.3GB, so unless the drives are formatted as NTFS volumes, this is most likely your problem.



Problem solved for me mate.. Thanks a lot.. :)  :hello: 


m
0
l
May 31, 2014 11:46:48 PM

fuck YEAH I\its work = NTFS
m
0
l
!