Sign in with
Sign up | Sign in
Your question

Vertex 3 will not boot after new motherboard

Last response: in Storage
Share
May 28, 2011 1:40:29 PM

Hello,

I have just purcahse a new motherboard (Gigabyte GA-X58-UD3R) and I already had a Vertex 3 SSD with windows 7 installed. I have just attached the cables to the SSD on my new motherboard and changed the settings in the BIOS to ACHI.
I have tried to boot and it just says DISK BOOT FAILURE.
I have another SSD with windows 7 on and it loads fine. Does anyone know whats wrong or what the solution is?

Thanks
a b V Motherboard
a b $ Windows 7
a c 104 G Storage
May 28, 2011 2:32:11 PM

Hi there,

Couple of things to review.

Usually if you incorrectly set the PCH SATA Control Mode in the BIOS to ACHI, and the System Drive was initially set to IDE or RAID, you get a BSOD on booting. You have to make a change in the registry first if it was set to IDE initially on this SSD on another MB. Was this set as ACHI or IDE on the older system?

The other thing is you have 2 other HDD listed as being connected on your system. Make sure this new SDD is listed in the Advanced BIOS settings as Hard Disk Boot Priority as the first drive, so it is recognized as the "system" drive.

Also sometimes if the SMART hard drive monitoring is enabled, folks have seen the [Disk Boot Failure]. In the BIOS, make sure the SMART reporting choice in the Advanced BIOS settings page is disabled, at initially.
May 28, 2011 2:46:04 PM

The vertex 3 was installed as ACHI on the old motherboard. I have not installed both SSD's at the same time as I know it will just go ahead and boot from the old SSD. I'm not sure whats going on. I'm assuming that the new SSD must not have a certain driver installed for my new motherboard.
SMART is disabled and the Vertex 3 is set as the first boot priority as it is the only device attached to the motherboard.

Thanks
Related resources
a b V Motherboard
a b $ Windows 7
a c 104 G Storage
May 28, 2011 3:43:02 PM

Hi again,
One other thing that crossed my memory.
The fact that when you connect this new SSD as the primary and only drive, and it coughs up [Boot Disc Failure] means it is not recognized as the boot disk.

When you install Win-7 on a single clean drive, no other drive attached, it places that 100MB System Primary partition first on the Drive, then your Win-7 installation. It puts the BCD, Boot Manager files and Bitlocker if used, on this partition and looks for it at boot, even with a non EFI BIOS.

If you install Win-7 as a clean install but have another HDD connected on the system, as a backup or non system HDD, Windows many times will place that 100MB partition on the other disc, with more room. Then at StartUp, it looks for that System Partition to boot, an boots up to the desktop.

Could it have been installed on this SSD with a secondard drive in place, and now Win-7 can't find the BCD & Boot Manager? IF possible, place the older WD HDD that you listed as a second drive, and see if it will boot.

I just purchased a Vertex 3 120 GB also (after a 6 week wait), and am excited to get it into a new system also.
September 30, 2011 3:52:31 AM

@cthomas:

I was having the same problem with boot disk failure messages. I disabled SMART and problem solved.
!