Sign in with
Sign up | Sign in
Your question

Windows 7 adds unknown network on reboot

Last response: in Networking
Share
October 7, 2009 2:07:47 AM


I installed Windows 7 Enterprise yesterday - a legal MSDN Volume Subscription version. I installed it with a Home Network connection. After installing updates and a re-boot, it lost internet connectivity. I found that when it reboots, in the Network and Sharing Center it shows two networks - Home and a Public unknown network connection (the one with the "bench icon"). If I go to change adapter settings and disable the Local connection - then enable it again - the unknown public connection is gone, Home connection is fine and I have internet connection. So I installed the next batch of updates. Cool... but...

When I restart, the problem starts all over again - with the Home connection and the Public unknown connection - and no internet connection. So I have to disable and enable the local network to get it working again every time I restart my machine.

Any help with suggestions or ideas on how to fix this would be greatly appreciated. (I really really don't want to start over with a re-format...)

Thank you,

Nick

More about : windows adds unknown network reboot

October 14, 2009 12:57:57 PM

Having the same problem! Just want to elevate and let you know I too am having the same problem with Windows 7 adding a public network causing the loss of internet connectivity!
m
0
l
November 3, 2009 10:16:31 AM

I fixed this problem, although I'm not sure how i did it! I can go through the steps you might be able to side step a few...I decided to make my home network a 'work' one to see if that would make a difference. The next time I rebooted it didn't recognise I had a home or a work network, just an unknown network. No internet connection at all now...going from bad to worse. Next I made the unknown network part of a homegroup I had previously made for the home network. It asked me whether I wanted to enable file and print sharing when I did this, I said yes...even though this could potentially exposing my pc to the internet. The internet connection came back, i disabled all my doc/vid/pic etc sharing options for the homegroup for good measure...the next time I rebooted the home network reappeared and unknown network was nowhere to be found...internet all good. So maybe try:

1. adding your current unknown network to a homegroup.
2. reboot.

m
0
l
February 7, 2010 5:25:52 PM

Hi,

I had the same problem but fixed it by completely UNINSTALLing my network - DISABLE isn't enough. UNINSTALL then reboot. Worked straight away.
I am running WINDOWS 7 on a P-4 P4P800SE (old but reliable).

Good luck !
m
0
l
!