Sign in with
Sign up | Sign in
Your question

[HELP] - Sapphire PI-AM3RS785G won't boot

Last response: in Motherboards
Share
February 4, 2010 10:06:43 PM

Hello,
I just built a new PC with the following components:

- Kingston ValueRam 2 Gb ddr3 1066 Mhz CL7
- Case ARTIC Middle Tower ATX with 500W power supply
- Seagate Barracuda 7200.12 500 Gb Sata 300 Buffer 16 Mb 7200 Rpm
- DVD Double Layer LabelFlash Sata burner
- Motherboard PI-AM3RS785G socket AM3 chipset AMD 785G MATX
- AMD Athlon II X2 245 2,9 Ghz Socket AM3

The problem is, the system won't boot. Blank screen, no error codes or beeps, NOTHING! Only the fans and drives are starting, but the pc won't even reach the BIOS.

I tried everything I could think of: swap the RAM module from one slot to the other; disconnect any component except for the motherboard, CPU and RAM; clear CMOS; remove and reinstall the battery; test another, surely working PSU; test a different video connection (vga and dvi); test a surely working video card (an Ati HD3870, properly powered with its PCIE connector); remove the motherboard from the case to avoid any electrical issue.

Until now, everything failed.

The only thing that COULD be a problem is the fact that the motherboard features an 8 pin 12V connector, and I only have PSUs with 4 pins connectors. BUT, as the MB manual itself states, it should work regardless of that.

What do you think it could be:

- an incompatible / dead RAM module (I have only one 2Gb module and the motherboard only features two slots)?
- Dead CPU?
- Dead motherboard?
- Insufficient power (but as I said before, I tried my 530W PSU that's working flawlessly with a fairly heavier configuration...)


I'm humbly asking for any kind of help :( 

Thank you.
!