Sign in with
Sign up | Sign in
Your question

Continuing Struggle SATA

Last response: in Storage
Share
June 1, 2011 1:22:34 PM

Hi Guys, I'm still having a lot of problems with windows and drive recognition. I can't seem to get xp to see my two SATA WD backups. Not sure what I can do about it, wondered if anyone would know? Have a look at the images below!!!







It's an MSI KN8 Neo4 with the Nforce 4 chipset! They show up in plug and play but nowhere else. I had these drives running before so they should be good to go.




a c 104 G Storage
June 1, 2011 2:29:30 PM

Hi Paul,

That's a tough one!

For completeness, check in the BIOS to see if they are being recognized by the BIOS as Disk 6 or whatever. Right now they are not recognized by the OS at all.

Are these drives SATA drives connected directly to SATA ports on your MB? And do you have the AHCI enabled so they can be unplugged and plugged in again to see if the OS gets the message?

I guess you could in the Device Manager, open the context menu of the Disk Drives, and clic on "check for hardware changes" to see if XP finds them.
Otherwise, in high tech terms, it's a real conundrum
June 1, 2011 4:05:46 PM

Hi Thanks for the reply. Yes they are attached directly to the motherboard on the SATA ports. They show in the NVIDIA Raid utility on post as free unraided disks but not in the initial bios post. Both the SiImage and NVIDIA raid on the board have their own posts after the main bios.

I've tried "check for hardware changes" and it makes no difference. I've tried uninstalling the drivers and then reinstalling them but to no avail. I've also tried the last set of Nforce drivers and it failed. I'm not sure but I think I read somewhere AHCI support was not directly available from the bios with the Nforce4 chipset and it was done through the software side. Either way I'm totally stumped and perhaps the hardest thing to understand is that it worked before. The only problem is I did it years ago and I can't remember how or what I did. The hardware configuration has not been changed apart from my unplugging of the drives in question to protect the stored data from being accidentally erased. Since then I have installed windows with the drives plugged in and unplugged but its made no difference. Do you think maybe a default setting is triggered in the Bios if I unplugged the drives?
Related resources
a c 104 G Storage
June 1, 2011 5:34:07 PM

HI Paul,

Don't know -
The only thing logically is why would 2 SATA drives go bad at the same time??? That would be pretty rare. making one think a system config setting changed. Might plug them into a differen t"Enabled" SATA controller on the board and see what happens. Are you running Win-7?

The only other thing that came up was unless you have the AHCI enabled, you can't just unplug these SATA drives with the computer running or you could corrupt the data.

How are these SATA's listed in the BIOS? Do they come up as part of the RAID array, or as Basic Disks with MBR partitioning? I'm not certain but the SCSI icons in the "Safely Remove" dialog box make me wonder if they are recognized as a RAID disk rather than Basic drives.

BTW, very nice graphic presentation to present your problem. Worth at least a thousand words.
June 1, 2011 5:58:54 PM

Hi, I've only ever unplugged/plugged the drives when the system was turned off or when I've right clicked and "safely remove hardware" from the dialog box. I've seen what can happen to usb sticks if you don't treat them properly.

The only other raid contoller I have is the SiImage one which has my two raided (mode 0) OS system disks attached. There are two other ports I don't use for the array. I'm not sure but would it be safe/possible to run two additional disks from same controller unraided or will it corrupt my data?

I might take some photos of my Bios setup first, post them here and see if you can spot anything I've overlooked.

To add a little history, I've had to redo my system after a virus infection which dissabled my antivirus and blocked me from visiting microsoft for updates. I couldn't get rid of it any other way. All very frustrating!
a c 104 G Storage
June 1, 2011 7:02:31 PM

Hi Paul,

Don't think I'd hook them up on the RAID controller. Keep them separate.
If you could take a picture of your BIOS with CMOS settings showing how the HDDs are configured, and the Integrated Peripheral that might help someone spot a problem with the configuration and why the SATA drives aren't being recognized properly.
June 1, 2011 9:28:10 PM

Hi John, take a look at this lot and se what you think. I think its ok but I'm no bios expert.









June 1, 2011 9:45:07 PM

Sorry one of the images above is repeated I meant

a c 104 G Storage
June 1, 2011 10:14:45 PM

Hi Paul,

Hopefully a couple other fellows will take a look at your very complete information, and see if they have any other recommendations.

To me it looks correct. The two WD SATA drives are certainly ID'd in the BIOS correctly.
Just double check the WD drives are on port SATA_3 and SATA_4.

Do you by chance have one of the multipurpose Drive converter devices, that you can plug an IDE or SATA drive into one side and you get a USB output to connect to a USB port? Worth a try if you have one. The other thing is if you have another any size SATA laying around that was not previously connect to this computer, try it on a SATA port and see if it is recognized by Win-XP. That would rule in or out whether it is a drive problem or a controller or system config setting.
June 2, 2011 10:03:53 AM

Yes I have a multipurpose Drive converter so hopefully I can still reach my data. I remember this motherboard being problematic when it comes to other hardware. For instance it doesn’t like memory chips other than those found in the test report, use anything else and you get BSODS all over the place.

Not sure what you mean by on ports SATA_3 and SATA_4. I have 8 ports on this mobo. 4 of them are controlled by Silicon Image chip and the other 4 controlled by an Nvidia chip. My OS is on ports 1 and 2 on the Silicon Image raid 0 and the two drives not recognized are on ports 1 and 2 on the Nvidia chip. I keep them on totally separate controllers to avoid conflicts and bottle necking. The two raid utility screens you see are separate from the Bios and you have to enter these separately after the Bios post. These two utilities have their own posts after the main post by the bios. One thing I did notice, the silicon image raid utility posts the two raided drives during start up however the Nvidia one searches for a raid array (which it doesn’t find, because there isn't one!) and continues to boot without posting the to drives I can't access. I must admit I didn't notice this before and am still wondering if it is normal when the drives aren’t raided.
June 2, 2011 1:37:57 PM

On the 2nd to last picture, disable RAID. That should make the SATA ports "passthru" to the system as opposed to being processed through the RAID controller.

Otherwise, in the 2nd to last picture create a RAID volume (1 or 0) and then a single virtual disk should be presented to the OS.
a c 104 G Storage
June 2, 2011 2:22:41 PM

Hi Paul,
On the BIOS screen that says SATA Configuration, it show 4 SATA ports on your MB. SATA3 and SATA4 are disable for RAID, so they should work for Basic drives. Check your manual and it should show indicate which are 3 & 4. Might try the drives in those SATA ports to see if they work.

Always good to have other folks look over your data because they may just find the "bug" in our logic.
June 6, 2011 11:55:29 AM

Thanks nocheese for you suggestions. The second to last image is the set up for my raided system drive which is working in raid 0. I did think of creating an array with the other two drives but as it stands I can't because I will wipe my backup data.

Hi John

SATA 3/4 correspond to the two free ports on the SiImage. I wasn’t aware you could have raided disks and non raided ones on the same controller, but now I know! It’s worth a try.

I have also found in the manual a program called NVRAIDMAN. I think it suggests in order to use these drives under windows you need to run the app to set them up. I now have a 64gb usb pen so I think I will try the multipurpose drive converter and remove the data from one of the drives before I experiment. It will take some time so I will post when completed.

You can download the manual from here:

http://www.msi.com/product/mb/K8N-Neo4-FX--PCB-1-0-.htm...
June 6, 2011 9:40:45 PM

Ok I've now tried my idea but again it didn't work. I think the hardware has gone bad and I have decided to ditch the mobo for another one from ASUS. I guess we all learn form our mistakes and I can tell you NEVER BUY A MOTHERBOARD FROM MSI they are crap!!!!

!