Sign in with
Sign up | Sign in
Your question
Closed

Crummy performance Crossfire 4870

Last response: in Graphics & Displays
Share
September 5, 2009 6:30:09 PM

Hi all,

First, my set-up:

Corsair cmpsu 750W
4gb g.skill ddr3 1333
AMD Phenom IIx4 955 BE
2 x HD4870 1gb (they are both sapphire)
Gigabyte UD5P mobo
32-bit Windows 7
Antec 300 case with 4 intake fans and one exhaust (140mm)
7,200 RPM HDD

Okay, so my crossfire sucks. Hardcore. I get almost no performance increase in the games that support it, and it slows down almost everything else. My cards stay at about 50-60C at all times. As an example, crysis/crysis warhead gets zilch from it, DoW2 slows down (lots of graphical glitches). Any game older than 2 years gets really shifty graphics. Heck, I even overclocked my 2 graphic cards to 790mhz/1000mhz and I'm not seeing any improvement!

I HAD wanted to run the 3Dmark vantage test (I bought it because I'm getting into this overclocking thing), but user acc control got in the way of the first test. (I'll post the results if people are interested, when I get the full test completed). But right off the bat, after two trial runs with xfire enabled and disabled, I notice the disabled is getting WAY better quality than with crossfire enabled. It's not only the fps that goes up, but there are far less graphical glitches.

I've about had it up to here with crossfire...it has not improved performance on anything, and seems to cause more trouble than it's worth (times like these I miss Nvidia). Is it something I'm doing? Because I HIGHLY doubt my set-up is to blame, save maybe for a bit of additional ram (plus I'm going to up myself to 64-bit w7 + velociraptor hdd in october).

So, in short, my plea: can somebody please help me get something out of my crossfire? Is it something I'm doing wrong? Is the hardware messed up/not good enough? Is there anything I can do/download to optimize/maximize crossfire performance at all times?

Thank you in advance!
September 5, 2009 10:46:13 PM

If you are getting glitches and artifacts when using CF, your second card may be having problems. Have you tried using your second card alone to see if you still get artifacts?
Score
0
September 5, 2009 11:43:43 PM

First, make sure you have the latest drivers installed.
Then check in the CCC (Catalyst Control Center) and make sure both that CrossFire is enabled and Catalyst A.I. is enabled to at least 'Standard'.
Set all the other 3d settings to use application settings.
Now run it through 3d Mark and compare it to the scores when CrossFire is disabled.
Score
0
November 23, 2010 9:24:26 AM

This topic has been closed by Mousemonkey
Score
0
!