Sign in with
Sign up | Sign in
Your question

GA-P55-UD3R - Error loading operating system

Last response: in Motherboards
Share
February 6, 2010 9:13:33 PM

Setup:
Gigabyte P55-UD3R (BIOS updated to F5)
2x2GB Corsair XMS DDR3 1600MHz
Intel i5-750 (stock HSF)
Sapphire X1600XT (I know...I'm on a budget, so it's being reused)
Antec SmartPower 500W
160GB Seagate SATA HDD (7200.12? also from old build)
120GB Western Digital SATA HDD (scavenged from a netbook)
LG DVD-RW drive - PATA
(Logitech wireless trackball and keyboard, cheapie speakers, LG 20" monitor, old-as-all-get-out 17" Gateway monitor, cheapie case)


Old processor (a socket 939 Athlon X2-64) fried, so I decided to upgrade the basics. After going through problems with a couple of LGA775 motherboards, I decided I just wanted a beastly base setup anyways and bought up to this. The video card, PSU and storage devices are still-healthy parts from the old setup, as I can't afford to replace everything.

Things that might be of interest
- The Seagate HDD has a working (and legitimate) WinXP Pro installation, leftover from the old setup. On the LGA775 boards, the installation worked fine after getting Microsoft to confirm it and installing updated drivers.
- PSU cables + Motherboard: The PSU has a 2x12 plug, as well as a 2x2 12V plug. It seems that Gigabyte expects either of the following setups: a 2x10 plug and a 2x2 12V plug; OR a 2x12 plug and a 2x4 12V plug. I currently have the 2x12 and 2x2 plugs connected to the motherboard, with the 2x2 connected to pins 1, 2, 7 and 8.
- PSU: I do plan to replace the PSU soon, definitely before upgrading video card. I was going to, then my bank decided buying things on NewEgg was suspicious activity and wouldn't clear the charges until today. *sigh*


Now that I have the computer built up, it POSTs normally, clears the screen, prints, "Loading operating system..." and, after a few seconds, prints, "Error loading operating system." I tried disconnecting the second hard drive, as it wasn't entirely necessary, but it had no effect. I tried putting the XP Pro install CD in and booting to that (thinking I could use it to repair the install), chose the CD-ROM drive from the boot options and received the same error. I flashed the BIOS with the latest update from Gigabyte's site and tried the same things - unplug the second hard drive, XP Pro install disc - and had no more success. I think the time it took display, "Error loading operating system," might have increased by a second or two, but that's all that changed.

If you all can help me get this up and running properly, I'll brew my next beer in your honor.
February 6, 2010 9:30:30 PM

ok two things...

the old amd system has a different hardware application layer than intels...

HAL as it is other wise known talks directly to the motherboard so even if you did get this to boot you would get a BSOD ( blue screen of death ) and the machine would constantly reboot.

Secondly IDE on new motherboards is emulated as apposed to a true ide chip is a subsidy of the sata controller ( a sata to ide converter if you like ) and it is likely that you old system is using the hard disk as a different format from the old ( raid configuration on a single drive for example) did you have to put in a floppy to install windows by pressing f6 when you installed windows on it.

I personally would go and get a new 500gb or a 1tb ( the price different is neglegable ) a Western Digital Black with 32mb cache is recommended, and setup a fresh copy of Windows... Get an OEM disk from friend and install it with the same code on the side of the machine.This would be the only good way to move forward, i know a budget is tight but you can lower the spec of a hard disk but its the only way to move on.
m
0
l
February 6, 2010 11:51:26 PM

The HAL may be different between chips and chipsets, but that did not stop the installation from functioning after swapping it from the AMD (an ASUS A8R-MVP) to an Intel LGA775 (an ASUS P5QPL-AM). As I said, Windows needed a few new drivers and re-activation, but otherwise worked as normal - no BSOD. The only thing that moved me away from the LGA775 platform was that I had to RMA two of those motherboards due to defects (networking on the first, sound on the second).

With regards to native IDE support vs emulated IDE support, what exactly is the issue? The hard drives are both SATA. The DVD drive is IDE. At best, this means the SATA controller (as it functions as both SATA and IDE controllers) has some kind of issue and that I ought to RMA it because of that. If you think that's the case, please let me know.

Edit: May have solved it. By installing a hard drive with a working Windows XP Home installation from a non-working netbook. Feels hack-ish like crazy.
m
0
l
Related resources
February 7, 2010 6:13:48 PM

lol, its the way the hard disk controller loads up windows. depends how good the sata to ide processor is made on the motherboard and how compatible it is with certain hard disk drives...
m
0
l
a c 177 V Motherboard
February 8, 2010 12:00:08 AM

The hardware abstraction layer is different for most MOBOs, and often, a drive installed on one won't boot at all on another - if you are lucky enough to get one that does boot, a 'repair' install will usually take care of the differences...

I see this all the time, and I just don't get it... Why are people so hesitant to do 'fresh' installs of their OS? My workstation (of necessity) runs like, nine OSs, and I do a 'fresh' install of my main OS (which is now seven ult64) at least every second month (along with over a hundred-twenty programs, drivers, and registry 'tweaks'/MC 'patches'), just to get the latest drivers without 'registry accumulation', and because, since the last time, I've learned stuff that makes it worthwhile (like, you wanna install VisualStudio '08 before the '10 beta, or - no workee!); you just keep your OS on one partition (or, a bunch of partitions :sol:  ), and all your data on another - doing a reinstall is no bigger deal than taking a spoon full of some nasty tasting medicine! :lol: 
m
0
l
!