Sign in with
Sign up | Sign in
Your question

USB 2.0 Problem with Windows 7

Last response: in Motherboards
Share
February 7, 2010 2:18:51 AM

Hey, I just installed Windows 7 OEM version and noticed a problem right off the bat, and am continuing to have the same problem. First off, I could not get past the very first installation screen. It would hang every time and no matter what I tried it would not install. This was resolved by going into the BIOS and changing the USB to 1.1, instead of 1.1 OR 2.0. I noticed my keyboard and mouse would both turn off during that first installation screen, so that's why I decided to try turning off USB 2.0. So, installation completed fine and it works, but when I go back into the BIOS and turn back on USB 1.1 OR 2.0 it won't load Windows 7 at all, it hangs on the loading screen and keyboard/mouse are off. I installed the latest gigabyte drivers from their website and I still can't get it to work with usb 2.0 enabled. Anyone have ideas?

I'm using a Gigabyte GA-M750SLI-DS4 motherboard.

More about : usb problem windows

February 7, 2010 2:23:28 AM

Oh and it's the Windows 7 64 bit OEM version.
m
0
l
a c 135 V Motherboard
February 7, 2010 5:34:08 AM

Hello and welcome to the forums :) 
Have you tried updating your BIOS ?
m
0
l
Related resources
February 7, 2010 7:09:06 AM

Yes. Also updated chipset drivers etc.
m
0
l
a c 135 V Motherboard
February 7, 2010 8:31:47 AM

Have you tried different OS's ?
m
0
l
February 7, 2010 8:40:03 AM

Yes everything is fine using Win XP. Only an issue with Win 7.
m
0
l
a c 177 V Motherboard
February 7, 2010 1:26:43 PM

Do you have anything beyond a kbd & rodent plugged into the USBs? GB MOBOs are notoriously 'finicky' when it comes to USB devices - some, simply and plainly, won't work; they tend to come in 'spates', as new devices are released and numbers of people find 'no workee'! Last batch was some WD external HDDs, both 1T & 1.5T models; I have found two brands of pen-drive incompatible (SanDisk Cruzer 2G, & OCZ Diesel 4G), previous to the WDs, it was a particular mfg's (and I hadn't, at that point, see enough of the problem to be astute enough to note the details) external DVD writer (that one was 'fixed' by a later firmware patch)...

The second pointer is to go into your BIOS, on the "Integrated Peripherals" page, and disable "Legacy USB storage detect" (also shown as "USB Storage function" in later BIOS - different name, same functionality and problem), which is, in most BIOS, enabled by default. This item allows the BIOS to access USB 'drive-organized' devices (pen-drives, external HDDs, etc.) before the OS' USB drivers are loaded; there are only three times you need this enabled: first, if you're flashing your BIOS from a file stored on a pen-drive; second, if you want to store/restore CMOS parameters put on a pen-drive; and third, if you want to actually boot from a pen-drive - and you only want to enable it when you want to do one of these things on your next boot... This setting can cause various oddball problems, culminating in the dreaded 'GB boot-loop'!
m
0
l
February 7, 2010 9:19:45 PM

I did try disabling USB Storage Detection with no change..Yes I only have a usb mouse and kb. I've only been able to find one other person on the seven forums with this same exact problem, and he's using a different motherboard, so I'm not sure if I should buy a new motherboard or not. I probably will, but first I want to try using a thumb drive and seeing if it's working at 1.1 or 2.0.
m
0
l
a c 177 V Motherboard
February 7, 2010 10:35:54 PM

That's strange, all right... I'm pretty sure it can't be KBD or mouse, as in nearly a year of responding, fairly faithfully to questions here, and more than thirty individual USB incidents, I've never seen a USB problem that could be verifiably traced to either one. Just out of curiosity, have you tried getting a variety (assuming availability) of chipset drivers directly from AMD, and 'going back' a rev or two? Puts me in mind of a problem that happened kind of soon after seven's RTM; a 'native' driver upgrade disabled two particular RealTek RTL lan chips, and worked fine with all the others... Seems to me I've heard, twice now, of seven lan driver problems with AMD chipsets, that seem to come from the fact that the chip is somehow attached 'subsidiary' to the chipset, instead of the normal PCIe bus attachment, so there really is no lan chip driver - either the chipset detects and installs it - or it doesn't... I'm wondering if this might also be the case with the AMD USB connect - maybe something (or a current driver problem) is 'interfering', somehow, with the detect/install?
m
0
l
!