Sign in with
Sign up | Sign in
Your question

Bad 1394 controller question

Last response: in Components
Share
November 10, 2009 3:56:59 PM

HP Pavilion dv6605us Laptop

I've recently been doing some extensive troubleshooting on my laptop involving the fact that Windows XP refuses start the driver for my internal 1394 Firewire controller.

In the device manager property page for this controller it says "The device cannot start (Code 10)"

When I click on the resources tab of the page I get "Resource settings: This device isn't using any resources because it has a problem."

It used to be listed in the device manager as IEEE 1394 Net Adapter, but now it is showing up as OHCI Compliant IEEE 1394 Host Controller and has a yellow ! mark on it as if the driver for it isn't installed.

So, the first thing I tried was uninstalling the driver, and then reinstalling it; rebooted the laptop, and the problem still persists. After that, I tried flashing my BIOS to a newer version (it was quite a few revisions out of date anyway, so I figured it couldn't hurt). No luck upon rebooting. The controller still shows up as non functioning. Tried disabling the hardware through device manager, then re-enabling it after rebooting it and still no luck.

Getting desperate by now, I reformatted my hard drive, did a clean installation of Windows XP, and reinstalled all my drivers. Every thing worked great, except the IEEE Controller is still exhibiting the same problem as before the OS reinstall. This led me to believe there is some kind of hardware problem, so I contacted HP tech support, and basically repeated everything that I did on my own in the way of troubleshooting (much to my dismay and protesting to the tech that I've done this already) and 3 hours later he concludes that the Firewire controller is bad and wants me to send it in for $400 worth of repair.

I have no use for the Firewire port so what I would like to know is, will simply having a bad firewire controller on my motherboard cause my board to eventually die out, or am I safe to use my laptop indefinitely? It doesn't seem to affect my system in any other way (at least when using Windows. I dual boot Windows and Linux... Linux shows some bizarre eth behavior since the controller died). I really don't have $400 to repair it and I definitely don't have the money for a new laptop so someone please, give me some good news lol.

As far as what is happening in Linux: Normally the first ethernet controller in a system shows up as eth0 for the interface name. And it should stay as eth0 unless you were to add a new NIC in. But every time I start my system up, it adds 1 to that name. I would get eth0, eth1, eth2, eth3, so on and so forth. By the time I finished troubleshooting and rebooting multiple times my first night of troubleshooting, Linux had managed to name eth up to eth12 @_@; This wasn't happening before my 1394 controller supposedly bit the dust. This wouldn't be much of a problem to me, except I require a static IP address settings for Linux for server reasons, and every time Linux changes the eth name, it forgets the settings and reverts to DHCP.

Any further assistance or tips on this would be greatly appreciated!

EDIT: Also, I'm not quite sure why it just suddenly decided to die, I've never used it. The only hardware change I've made to the system recently is I added in a new stick of RAM to it. Memtest seems to say that the ram in my system is functioning perfectly with no errors. Yes I made sure the RAM was compatible with my system in memory size, speed, timings etc.
November 23, 2009 4:37:15 AM

Wait a minute, why do you have to pay $400? Your laptop is out of warranty?

In any case, do you really need the 1394 controller? Why not just disable it so that it won't screw around with your Linux?
m
0
l
November 23, 2009 6:55:39 PM

r_manic said:
Wait a minute, why do you have to pay $400? Your laptop is out of warranty?

In any case, do you really need the 1394 controller? Why not just disable it so that it won't screw around with your Linux?



Yeah, it's out of warranty. I've had it for a couple of years. I don't need the 1394 controller, but its death seems to be screwing around with forcedeth in Linux, causing forcedeth to constantly generate new MAC addresses for my ethernet controller, which keeps making the system add new entries in udev because it thinks that there is a new NIC on every reboot (at least according to the researching I've done on the situation). I can't figure out how to disable the 1394 controller under Linux; been searching all over the net for ideas on how to do this too, but no luck. Any ideas for me on how to do this? I would greatly appreciate it!
m
0
l
Related resources
December 14, 2009 4:45:15 AM

I can only suggest, based on my limited knowledge of your system, to try and disabling it within your laptop's BIOS. Or if you're feeling a bit adventurous, you can also try opening up your laptop and physically disconnect the port from the laptop mobo. Sorry I couldn't be of more help!
m
0
l
December 14, 2009 2:01:00 PM

Hmm that is a thought. I've looked all in the BIOS for a way to disable this, but unfortunately it's a very bare bones BIOS and has only a few options such as boot order and a few power settings. Thanks for responding!
m
0
l
December 18, 2009 4:23:03 AM

Any chance with physically disconnecting the 1394 port from the mobo? :) 
m
0
l
December 25, 2009 7:57:26 AM

r_manic said:
Any chance with physically disconnecting the 1394 port from the mobo? :) 


No, unfortunately lol. I took a look at a picture of my laptop's motherboard that I found online (rather than disassemble it) and I dont see a means of disconnecting it =/ Was worth a look at though :) 
m
0
l
!