Sign in with
Sign up | Sign in
Your question

(SOLVED!) 1.5 TB WD Caviar Black & RAID 1 slow down

Last response: in Storage
Share
June 4, 2011 12:26:56 AM

I recently bought two WD Caviar Black hard drives to use in a RAID 1 Mirroring array. The array builds in the RAID BIOS or with the Intel Rapid Storage software in the Windows environment. The "drive" - array is also recognized in Admin Tools - Computer Management - Storage - Disk Management and formats NTFS no problem. Setting up using GUID partitioning either one large partition, 2 or 3 partitions works fine and the IRS (now there's an acronym good for a chuckle) software initializes the array no problem.
After all this is said and done, the system is all primed and ready to go, things start to slow down. First it is a tiny hitch, then it becomes words being typed, but show up 15 seconds later, then it's web pages hanging, email downloading from the server and/or opening taking a few birthdays, then it becomes MS Word taking a few forevers to open or operate and finally we finish with an eventual and complete system freeze.

There are no errors displayed. Diagnostics have been run on the drives as well as surface scans. Nada! It may be important to note in all this, that not a single digit of information has been written to these drives yet by me. Just the array building process, formatting and initialization. Somehow this new array causes the entire system to slow down until it freezes up.

I have tried two BIOS flashes, downloading and installing the latest storage/raid drivers and swapping out cables, one at a time with no luck in finding the cause. Deleting the array and letting the drives "sit." (as it were), returns system performance back to light speed every time.

ASUS doesn't seem to know why. Western Digitial doesn't seem to know why. I surely don't know why. Does anyone have any idea why?

Windows 7 - 64bit
Samsung 470 128GB SSD
WD Velociraptor 150GB x2 RAID 0
WD Caviar Black 1.5TB...uh RAID...nothing
ASUS P8P67 PRO (board rev 1.01) Sandybridge fix rev 3 (board came straight from ASUS)
16 GB G.Skill DDR3
Core i5 Quad 2500K
Noctua NH-D14 (140 MM fans)
Samsung DVDRW
Lian Li PC-A70F Tower
PCP&C 750 Watt PS
Sapphire Radeon HD 6870 w/ARCTIC COOLING Accelero TWIN TURBO
Windows and all drivers up to date.
a c 104 G Storage
June 4, 2011 5:47:16 PM

Hi there,

First of all, congrats on your very nice computer, must be a fun one to work with.

Couple of things, any time you have large drives like that, they are going to take several hours each to format, without using your computer for anything else in the interim. They won't take 10 times your velociraptor formatting time, but a long while.

I assuming you are using these for backUp, the 2 150GB WD Velociraptors for system and boot partitions.

Did you try setting these two HDD's up as Dynamic Drives, but using MBR volume formatting instead of GPT formatting? You are still within the 2.2TB size limitation even if you use the whole drive. Would think even with the UEFI BIOS system on the new ASUS board, you shold be able to try that.

Other thing is you might just partition off a small area, say 50GB, to experiment, until you get a feel for the RAID 1 characteristics. If you do that, you can't just extend the size out, you have to redo the partition size. In theory, the Morrored drive should not take very much of a speed hit once they are working and you are mainly writing to the drives.

Let us know what you find.
m
0
l
June 4, 2011 8:52:48 PM

Thank you, though system information wasn't meant as a boast. I made a post several years ago when I had a problem and didn't list everything and got burned for not giving all the system details. But yes, this computer is a blast. I am most happy with the Lian Li case. It is very easy to say this was the most fun I have ever had building a computer system just because of the case, let alone the rest of the parts. If the wife ever tells me to move out, I can just move into the case! :D 

I did not set them up as dynamic and did not use MBR as the two drives together take it above the 2.2 TB limit. However, in a Mirrored array , both drives are seen as one 1.5 TB drive so I believe my initial thoughts were flawed.

I will indeed give this a go and post what happens.

Thank you.

m
0
l
Related resources
June 6, 2011 3:15:53 PM

I tried your suggestions and ended up with the exact same problem. I am allowing the array to fully format and for the Intel Rapid ( <== that's a laugh) Storage software to fully initialize the array before doing anything with the computer. It does take a long time, about 6 hrs for both processes.

At this point I am not sure if it is the drives, motherboard controller, software or the SATA ports. Though I have been reading around the web about Caviar Black and any type of RAID not being best of friends. I have used WD drives for a long time and they are my favorite, but if this is indeed a WD issue (there may be nothing wrong with the drives themselves, but rather a controller or firmware type incompatibility), I will be HIGHLY disappointed.
m
0
l
a c 104 G Storage
June 6, 2011 7:39:17 PM

Hi there,

It's not your WD Black drives. They are great.

It has to be in how the new UEFI BIOS is set up, and how these drives are attached. You have the SSD on your boot partition, the smaller RAID volume which I assume works OK, and the new RAID volume. The BIOS setups for RAID controllers can be very tricky, and even choosing AHCI for a RAID controller rather than RAID, may be causing the problem. As you know, you have to set up the SATA drives for each of the controllers.

The P67 Intel RAID configuration for the PCH chip SATA ports is different than say the Marvel SATA IDE, AHCI, RAID configuration. And if they aren't configured properly, they won't work properly.

Setting up the SATA drives for the different controller chips is confusing, and the config settings in the new "windows like" GPT BIOS, makes it even more obscure. Could be one single setting choice has been overlooked. Or maybe you're adjusting the setting on one RAID controller, but the data cords are plugged in the other controller - I'd spend more time with the manual until each step in the RAID setup system is clear.

m
0
l
June 8, 2011 9:55:01 AM

Quote:
What are the exact model numbers of your WD Black drives? They are known to behave quite erratically in RAID environments...

WD seems to have fixed it with the new FAEX drives though (WD1002FAEX etc.); but if you have older drives than these, then I'm pretty sure they are the culprit.

More info here -> http://www.tomshardware.co.uk/forum/255120-14-western-d...


I had read similiar, but these drives are FAEX models.
m
0
l
June 9, 2011 4:46:47 PM

The problem is solved.

Even though I updated the Intel Rapid Storage Drivers, following the instructions to the letter, they did not "take" in the Operating System. I found this after looking at every driver item by item in the Device Manager.

I downloaded the zipped driver package again, unzipped it to my desktop, plugged in a NTFS formatted USB Flash drive, used ASmakedisk found in the unzipped files to make a driver install disk, went back to the Device manager, Storage Controllers, Inter Rapid Storage...etc., Update Driver and pointed the OS to the flash driver. Done!
Restarted the computer and all is well. Problem fixed and everything is as it should be again.

Thank you all for your information and suggestions.
m
0
l
!