Can't overclock i5 2500k past 4.4GHz

Hi there,

So I have managed to get a stable overclock of 4.4GHz @ 1.4v
PLL Overvoltage: disabled
Intel Speedstep Technology: Enabled
Turbo Boost Power Limit: 250/200
Additional Turbo Voltage: Auto
Spread Spectrum: disabled
core current limit: 200

Voltage control:
Power saving mode: disabled
CPU Core Voltage: 1.400v
CPU Load-Line Calibration: Level 5
DRAM Voltage: 1.529v
PCH Voltage: 1.059v
CPU PLL Voltage: 1.832v
VTT Voltage: 1.047v
VCCSA Voltage: 0.925v

I had a little issue where 2 of my cores would run full load but the other 2 were idle, so I had to increase the voltage to fix it. It seems no matter what I try to do I can't get the computer to boot at 4.5GHz. The motherboard shows a error code '70' on it which apparently means South Bridge DXE initialization is started.

My aim was to reach 4.5GHz but that doesn't seem possible at the moment.

Specs:
i5 2500k
RAM: G.Skill Ripjaws DDR3-1333 CL8-8-8-24 (8GB)
MB: ASRock gen3 extreme3

Is there something I'm doing wrong/I have missed or is it just a crap CPU/motherboard?
8 answers Last reply
More about overclock 2500k past 4ghz
  1. Honestly, high overclocks are very component dependent. Some chips just can't go above a certain threshold. When you overclocked your processor did you apply your multiplier as "all cores adjustable in OS"? The best way to ensure that all cores ramp up is to manually adjust each cores to the specified multiplier (this, however, will prevent you from making adjustments outside of the bios screen).
  2. Your CPU voltage is way too high. I would keep it <1.325 or you're gonna fry your chip.
  3. under 1.325? thats a touch cautious
  4. Enable pll overvoltage, spread spectrum auto, llc level 1. Don't know if it'll help but that's the most recommended settings for asrock. 1.4v is not too high, and is said to be the max safe voltage. Tom's uses 1.35. What program are you using for temps?
  5. you have a bad board. i had the exact problem with an asrock board. i couldnt get a stable overclock without pumping huge volts to it and even then it would still freeze under light loads but not heavy loads. rma'ed the board got a new board and problem solved.

    but you need to turn turbo off and see if that helps.
    volts should be
    45x 1.325v
    46x 1.355v
    47x 1.385v
    48x 1.415v
  6. correction. try what k1114 said. i didnt notice pll and llc being wrong settings. if still no luck id try to rma it.

    i have the same board but with an i7 and i can run 4.6 @ 1.32volts and 4.7 @1.34 and 5 @ 1.46 so either those settings are holding you back(after resetting my overclock profiles i once forgot to turn on pll overvoltage and it made my system completely unstable) or the boards bad cause thats what my first mobo did.
  7. just a heads up from a thread above you...

    I couldnt boot at 4.6 or 4.7

    same board as you.

    You could try booting at a few multipliers higher than 4.5 and see if that works...
  8. Settings for one person may not work for another. It could also just be your multiplier wall although somewhat low, you may be unlucky. I know this is an old thread but just for anyone reading since coma bumped it.
Ask a new question

Read More

Intel Overclocking CPUs