Sign in with
Sign up | Sign in
Your question

disable write behind caching using registry key?

Last response: in Windows XP
Share
Anonymous
July 27, 2004 6:51:08 PM

Archived from groups: microsoft.public.windowsxp.configuration_manage,microsoft.public.windowsxp.hardware,microsoft.public.windowsxp.help_and_support,microsoft.public.windowsxp.perform_maintain (More info?)

Hello,

First of all, sorry about the cross-post but I don't know which group
is most appropriate:

m.p.windowsxp.configuration_manage: it's something I need to configure
m.p.windowsxp.hardware: it is hardware-related
m.p.windowsxp.help_and_support: I deed help (obviously)
m.p.windowsxp.perform_maintain: it's a performance issue

Since a week or so, I frequently get an error message about a failed
write behind caching. This is usually when disk activity is very (even
extremely) high. In the event log there is event id 50.
I *have* found a solution on the Microsoft Support site. The only
problem is implementing it. Microsoft advises to disable the write
behind caching on the hard disk. I have found the screen where this
setting should be changed, however I cannot change it because it is
grayed out.
So I wonder if there is a registry key that I can add or change that
has the same effect.

Some background info:
OS: XP Pro SP1, language = Dutch
Drive C: dual Seagate Barracuda V 120GB on Promise SATA controller in
RAID 0 (striping)
I think everyone who knows a bit about RAID, will agree that write
behind caching is actually not a very good idea on a striped disk.

I don't think other configuration info is relevant at the moment, but
feel free to ask if you need to know more.

--
Amedee Van Gasse
Bottom-quoter
Anonymous
July 28, 2004 5:17:18 AM

Archived from groups: microsoft.public.windowsxp.configuration_manage,microsoft.public.windowsxp.hardware,microsoft.public.windowsxp.help_and_support,microsoft.public.windowsxp.perform_maintain (More info?)

Further followups will go to news:microsoft.public.windowsxp.hardware,
because the problem *is* hardware-related.

Amedee Van Gasse wrote:

*snip*

> Since a week or so, I frequently get an error message about a failed
> write behind caching. This is usually when disk activity is very (even
> extremely) high. In the event log there is event id 50.
> I have found a solution on the Microsoft Support site. The only
> problem is implementing it. Microsoft advises to disable the write
> behind caching on the hard disk. I have found the screen where this
> setting should be changed, however I cannot change it because it is
> grayed out.
> So I wonder if there is a registry key that I can add or change that
> has the same effect.
>
> Some background info:
> OS: XP Pro SP1, language = Dutch
> Drive C: dual Seagate Barracuda V 120GB on Promise SATA controller in
> RAID 0 (striping)
> I think everyone who knows a bit about RAID, will agree that write
> behind caching is actually not a very good idea on a striped disk.
>
> I don't think other configuration info is relevant at the moment, but
> feel free to ask if you need to know more.

Meanwhile I have made some more research. I'll post it here in case
someone is interested.

It seems that the above configuration info is indeed enough.
There is a "bug" (how else to call it?) in Windows XP that write behind
caching cannot be disabled on ATA 100 devices /and/ on certain Promise
controllers that emulate a SCSI controller. And what do you think?
Indeed, a Promise SATA controller is recognised as a SCSI controller in
Windows. Bummer. :-(

This "bug" is *not* fixed in SP1. Is there anyone here with a little
more inside info in Microsoft who knows if there is going to be a
solution in SP2 or in some hotfix?

--
Amedee Van Gasse
Anonymous
July 28, 2004 10:46:12 PM

Archived from groups: microsoft.public.windowsxp.hardware (More info?)

On Wed, 28 Jul 2004 01:17:18 -0700, "Amedee Van Gasse"
<nzrqrr@nzrqrr.or> wrote:

>Further followups will go to news:microsoft.public.windowsxp.hardware,
>because the problem *is* hardware-related.
>
>Amedee Van Gasse wrote:
>
>*snip*
>
>> Since a week or so, I frequently get an error message about a failed
>> write behind caching. This is usually when disk activity is very (even
>> extremely) high. In the event log there is event id 50.
>> I have found a solution on the Microsoft Support site. The only
>> problem is implementing it. Microsoft advises to disable the write
>> behind caching on the hard disk. I have found the screen where this
>> setting should be changed, however I cannot change it because it is
>> grayed out.
>> So I wonder if there is a registry key that I can add or change that
>> has the same effect.
>>
>> Some background info:
>> OS: XP Pro SP1, language = Dutch
>> Drive C: dual Seagate Barracuda V 120GB on Promise SATA controller in
>> RAID 0 (striping)
>> I think everyone who knows a bit about RAID, will agree that write
>> behind caching is actually not a very good idea on a striped disk.
>>
>> I don't think other configuration info is relevant at the moment, but
>> feel free to ask if you need to know more.
>
>Meanwhile I have made some more research. I'll post it here in case
>someone is interested.
>
>It seems that the above configuration info is indeed enough.
>There is a "bug" (how else to call it?) in Windows XP that write behind
>caching cannot be disabled on ATA 100 devices /and/ on certain Promise
>controllers that emulate a SCSI controller. And what do you think?
>Indeed, a Promise SATA controller is recognised as a SCSI controller in
>Windows. Bummer. :-(
>
>This "bug" is *not* fixed in SP1. Is there anyone here with a little
>more inside info in Microsoft who knows if there is going to be a
>solution in SP2 or in some hotfix?
You're correct. I believe this feature is implemented thru the
driver. If you do have a third party card and it runs on a
non-microsoft driver, contact the vendor for more info.

Dave
!