Sign in with
Sign up | Sign in
Your question

Sapphire 4870 - Red LED D1601, won't display at all

Last response: in Graphics & Displays
Share
September 11, 2009 7:19:23 PM

So I just invested in an i5 and a Vapor-X Sapphire 1G 4870. Just got the parts today and it now sits before me with the D1601 LED lit up which seems to indicate that the card is too hot. Both cables are soundly in their respective connections, I've tried both PCIe slots and I should have plenty of power. This box doesn't even have windows on it yet, and it won't display anything on boot.

I've seen people having this problem elsewhere but only after using the PC for a while.

Do y'all think it's dead? Or is there some quick fix I've overlooked?

Any help will be greatly appreciated.
September 11, 2009 7:35:06 PM

If D1601 comes on as soon as you try to boot it sounds like a bad card, if it takes afew seconds, perhaps the HSF is loose, if so check the mounting screws are tight.
Obviously, be careful what you do to correct the problem, too much tinkering could invalidate the warranty.
m
0
l
September 12, 2009 2:26:12 AM

Update:

So I dumped the 4870 into my roommate's computer and it worked fine. Putting his old 8600gtx into my new MSI P55-DG65 motherboard produced no display. So, I'm leaning towards the motherboard being the issue. Now I'm paranoid that I'm not putting the thing together correctly.
m
0
l
!