Sign in with
Sign up | Sign in
Your question
Solved

Intel SSD-510 not available in Win7 setup in IDE, AHCI, or RAID mode

Last response: in Storage
Share
June 11, 2011 10:36:15 PM

I'm building a new system on a Gigabyte H67 with Core i5 2400. System POSTs fine, and passed a night of Memtest, but I am not able to install Windows because the drive never appears in setup. I have tried all modes: IDE, AHCI, and RAID with their respective drivers. Also tried different cables and ports across both 3Gbps and 6Gbps controllers. Edit: I just now tried it on a PCI-e controller, with the same results.

The drive is working when plugged into a different computer with windows already installed, showing up in explorer, and I tested it with Hdtune which showed no problems. However, when I tried to run setup on it while connected to this computer, it was still not available as a location to install, even though it was in the list of drives when browsing to install a controller driver in setup.

Am I missing something? Does this SSD require some special driver or procedure to install an OS on it?

Or is there possibly a hardware problem?

I have run out of ideas, so please give any you have..
a c 154 G Storage
June 12, 2011 3:14:46 AM

I have a 510, and windows-7 installed normally.
All the necessary drivers are included, nothing special is required.

Here are a couple of possibilities:

1) Is the firmware on the 510 up to date?
Intel has a utility called SSD toolbox which should let you check things out.

2) Since the 510 worked on another system, perhaps your motherboard needs a bios update.


If you are doing a clean install, set the sata mode to AHCI, not IDE or raid if you want windows to pass through the trim command.

If all else fails, contact Intel support; they are the real experts.

Best solution

a c 351 G Storage
June 12, 2011 2:08:54 PM
Share

^ good points.
(1) While you are in the Intel Toolbox, perform a Secure Erease (May have a diff label - Wipe disk or clear disk.
(2) Disconnect all other HDDs before installing Win 7.
(3) Sewlect AHCI in bios (recomended). However if Raid is selected it should work and With the RST drivers later than ver 9.6 (curently up to 10.x) The win 7 trim command will work as long as the SSD is NOT a member of a Raid(x) array.
(4) Select Custom Install. Verify NO partitions (Secure erease should delete). However, if any partitions are shown, delete them befor proceding with the Windows Install.

And as geofelt stated - if this fails - contact Intel.
Related resources
June 12, 2011 2:43:07 PM

Thanks guys. AHCI was my first choice, I was just trying the others in an effort to find something that worked. I will run the SSD toolbox on my other machine to check firmware etc.
June 12, 2011 6:38:20 PM

It is working!

The firmware was up to date, so it must have been the secure erase that did it.

Props to RetiredChief, thanks for the help
June 21, 2011 1:28:28 AM

Best answer selected by nrn9520.
!