Sign-in / Sign-up
Your question

Data from my old xp drive to new computer-no admin permission

Tags:
  • Hard Drives
  • Computer
  • Windows XP
  • Storage
Last response: in Storage
June 14, 2011 4:30:05 AM

I took the hard drive out of my old computer (XP) when the motherboard died. installed the old PATA drive in an enclosure to convert to an external. The drive is recognized, can open it and get to user files in documents and settings. However, if I try to copy, or open my folder, it says I do not have permission to access.

I even setup the same administrative name on my other computer (Vista 64 bit), but get same message.

I have a lot of old family pictures, and documents I do not want to loose. Anyone have suggestions?

More about : data drive computer admin permission

a c 427 G Storage
June 14, 2011 12:31:01 PM

You may need to take ownership of the drive. Look into cacls.exe or try this (XP):

1. right click on the drive that you want to take ownership of (in my computer) and choose properties
2. click on the 'security' tab
3. click the 'advanced' button
4. click the 'Owner' tab
5. under 'change owner to:' select your username
6. check the 'replace owner on subcontainers and objects'
7. click Apply (may take some time)
8. click on the 'Permissions' tab
9. click the 'add' button
10. type 'everyone' for all users to be able to access the drive. Type your user name just for yourself. OK it.
11. click the 'full control' checkbox under 'allow.' OK it.
12. check the 'replace permission entries on all child objects...' checkbox
13. OK it (result may take some time)
14. OK the last window

I haven't done this in a while, so if I left out any steps, someone jump in please.
June 14, 2011 7:19:36 PM

Thank you Hawkeye. I will give it a try.

Sorry about the duplicate, new to the forum and saw the tab "ask the community", thought I had to hit that button after typing the original. :) 

Thanks again.
Related resources
April 5, 2014 9:16:17 AM

Thanks Hawkeye22!
I know this was posted a few years ago and I also know it's regarding XP procedures but I have to say thank you! I have Windows 7 and I've always had some kind of problem with the steps to gain full permissions following the steps I found in Windows HELP and/or websites all over.

But I followed your steps and applied a little 'common sense' to adjust for the difference in Windows versions and it worked! "Easy-Peezy"! I just cloned my 256GB SSD O/S drive to a new, faster, 500GB SSD. The clone went smooth but it seems that I always find a few programs that tend to want a new privilege/permissions named and won't open until they get one.

In the past, I've done work-arounds, re-installs, and even did the security permissions, (admin Privies), using the 'steps' I read on line. But it was always precarious and I'd succeed but never knowing for sure if I screwed something else up, (long story but trust me, it wasn't a quick & simple, cut & dry operation).

But not here, not today, and not when I used your touch and go steps. It worked, I knew it worked after I did it, and I'm 99% sure that I didn't lose any functionality anywhere else. So Thanks, again, Rich
May 26, 2014 2:19:38 AM

Hawkeye you the man!
June 13, 2014 7:55:25 AM

Thank you so much Hawkeye22! Worked perfectly!!
October 24, 2014 2:30:40 PM

Try sharing the drive in Win 8 to solve ownership issues.

[Open File Explorer...Right-Click desired folder...Choose Properties...Choose Sharing Tab...click Share]

I just ran into the same problem copying data from the "Users" folder on a laptop hard drive. The response from Win8 was "You do not have permission" with the option to continue. But pressing the continue button seemed to result in no action. Other folders didn't show this problem. Also the folder has 500 GB but was showing in properties as less than 1GB. Rather than taking ownership, which sometimes takes a long time, I chose to share the drive, which was relatively fast [a couple of minutes]. The system then allowed me to start copying.

You may want to remove the share before you disconnect the old drive, if you won't be using it again.
December 29, 2014 7:07:29 PM

I had this problem where I couldnt find the security tab, so for anyone else who can't find it, you have to start xp in safe mode
February 5, 2015 10:12:58 AM

Hawkeye22 said:
You may need to take ownership of the drive. Look into cacls.exe or try this (XP):

1. right click on the drive that you want to take ownership of (in my computer) and choose properties
2. click on the 'security' tab
3. click the 'advanced' button
4. click the 'Owner' tab
5. under 'change owner to:' select your username
6. check the 'replace owner on subcontainers and objects'
7. click Apply (may take some time)
8. click on the 'Permissions' tab
9. click the 'add' button
10. type 'everyone' for all users to be able to access the drive. Type your user name just for yourself. OK it.
11. click the 'full control' checkbox under 'allow.' OK it.
12. check the 'replace permission entries on all child objects...' checkbox
13. OK it (result may take some time)
14. OK the last window

I haven't done this in a while, so if I left out any steps, someone jump in please.


Ok say I follow the above advice and change the permissions of my old hard drive then copy the data to my new computer... But then get my old PC working again.

Can put the old HDD back in the old computer and will be have the correct permissions?
Will I need to sort the permissions again on the old computer?
Or will it not work because I have already changed the permissions and you arent allowed to keep changing them/ revert back?