Sign in with
Sign up | Sign in
Your question
Solved

SATA HD not recognized in BIOS

Last response: in Storage
Share
June 15, 2011 3:05:20 PM

Here's the deal... recently had a perfectly working computer running SuSE 11.3 and noticed SMART giving some warnings about the HD (I've seen particular warnings before and they never amounted to anything). I went ahead and pulled the HD, mounted it on another machine and ran a BadBlocks test. Everything came back perfect, like so many times before with other similar HD issues. I went ahead and popped the same HD back into its computer into the same slot with the same cables, checked all connections, and turned it on.

The BIOS will not recognize it for the life of me. To rule out an HD issue, I popped another HD (a working one...) in and the BIOS still doesn't recognize it. I went into the BIOS to make sure nothing had 'changed'. SATA controllers are on... etc. but still nothing. It just won't recognize a SATA drive.

Not much particulars in hardware I can give ATM but I'm not sure it would even make a difference. The bottom line is, working computer ---> pulled HD & ran test which came back OKAY ---> reinserted HD exactly the same but BIOS will now not recognize it ---> tried a known HD into computer and BIOS won't recognize as well (ruling out HD issue)

Any ideas? Maybe the MoBo just went bad. BIOS picks up the CD-ROM drive over the IDE channel quite fine.

Flappy

More about : sata recognized bios

a b G Storage
June 15, 2011 5:00:42 PM

So the SMART errors could be caused by communication errors with the hard drive.
Start by replacing the data cable and verify the drive is spinning up. IF its an system, make sure the drive setting in bios are correct (ata,achi,autodetect...)
m
0
l
June 15, 2011 5:25:14 PM

Thanks for the reply. I've tried 4 different SATA cables and I tried every single SATA plug on the motherboard (should have been recognized in some HD slot right..?) and I tried the various power cables. I did feel the drive spin up. Also the other HD I ran through there spun up. I went into BIOS and made sure both SATA controllers were enabled (even tried disabling one in case of conflict issues) with still no luck. Not sure what else to do. The HD mounts on other systems fine and BadBlocks did not return one error at all.
m
0
l
Related resources

Best solution

a b G Storage
June 15, 2011 5:29:48 PM

Well, you could try a reset of your bios just to eliminate anything odd. After that, you've done all the right steps.

New cables, power, new SATA slots on motherboard, new hard drive, [bios reset]. After that the motherboard is a goner.

To same some time and trouble, you might want to pick up a PCI SATA controller and continue as normal on your PC. Should be about $30 or so.
Share
June 15, 2011 5:36:23 PM

Thanks again. I just wanted to make sure I wan't missing anything. Its a compute workstation for high-end quantum computations (albeit a bit old). The only thing I didn't do was reset the CMOS only because my boss is very particular about BIOS settings and didn't want to 'reset' anything that he may have customized. I'll run it by him when he's available and post back here. Right now he's finalizing a manuscript for a submit deadline that is today so he hasn't been much help to me :-P.
m
0
l
a b G Storage
June 15, 2011 6:40:52 PM

quantum computations (albeit a bit old): don't you mean a bit strange - bada bing!
m
0
l
June 15, 2011 6:46:02 PM

Zing! I meant the workstation is a bit old. Though a lot of QC methods made back in the 70s and 80s are still implemented as a fundamental building block for newer methods of approximating the Schrodinger equation!
m
0
l
a c 348 G Storage
June 15, 2011 10:11:12 PM

So the HDD suddenly does not work in this machine, AND you have tried a different HDD in same machine with no success also. This suggests the problem is NOT the HDD, but some component of the machine.

Next quick test: take the suspect HDD and connect it in another machine. You do NOT need to boot and run from it - in fact, you probably could not. But if you can access its data when installed in another machine, you have confirmed that the HDD is NOT the problem. If that's the case, the items to check for / replace / try another one in the original machine are:
SATA data cable
SATA power connector
SATA port on the mobo
m
0
l
June 16, 2011 7:06:05 PM

Okay I ended up re-seating all RAM chips and cards inside the machine. Sometimes this can be a magical way to fix hardware issues. Unfortunately it didn't solve anything this time around. I then reset the CMOS directly from the MoBo, rebooted, and still nothing. The BIOS was already up to date. Anyhow, once I find a SATA controller lying around I'll go that route but I think it is safe to say that this MoBo is shot (which is unfortunate because its a Tyan Dual Opteron MoBo).

A big thanks to CompTIA_rep for the helpful insight and conversation.
m
0
l
June 16, 2011 7:06:16 PM

Best answer selected by mr_flappypants.
m
0
l
June 20, 2011 4:25:37 PM

I know this thread is marked [SOLVED] but I wanted to add something interesting that could potentially be helpful for others.

We recently determined that the motherboard was the piece of hardware that was causing the issue (to sum it up... the MoBo was bad). I went ahead and installed an old SCSI controller card and SCSI drive that was lying around. The BIOS picked it up no problem. Went ahead and loaded up an Open SuSE 11.3 disk to do a full install. (The SATA drive is still hooked up to the MoBo at this point but not recognized by the BIOS). Upon entering the SuSE installation process, the SATA drive SHOWS UP in the 'create partitions' part of the install (the computer can see it!). This suggests the MoBo is working properly. I'm running an install on that drive right now. I will update this thread later.
m
0
l
a b G Storage
June 20, 2011 6:44:32 PM

If the BIOS does not see the drive but it is seen in the OS, then either the configuration is bad, trouble with understanding the settings (user error)... but its hard to tell from the internet. :) 

I'm glad you got to this point! Its interesting that some drive information is being passed to the OS level, and I wonder if you can boot to it once its formatted and boot enabled.
m
0
l
June 20, 2011 8:04:24 PM

So this is the oddest thing... the installation completed fine. Upon reboot, it booted from the CD (whoops) and booted up just fine that way. So I took the CD out, went into the BIOS, and checked to see if I could put the SATA into the boot order. Well its still not listed... not recognized by the BIOS. So okay, exit that and boot anyway. So no CD to boot from, no other drive to boot from... and whaddya know? It booted from the SATA hard drive... and loaded up SuSE 11.3 just like it should. Why in the heck does it not show up in the BIOS is beyond me. What sort of witchery is this??
m
0
l
a b G Storage
June 20, 2011 10:09:36 PM

Good fortune?

However, I would strongly advice storing critical data on the drive. If it is a whichery thing, and there are communication issues, then it could potential corrupt the data on the drive and you wouldn't know it until you opened the file.
m
0
l
June 21, 2011 12:19:01 PM

Easy enough. Its just a desktop-turned-compute-node so nothing of vital importance is stored on it (except when jobs are running). Scripts automatically transfer the data to a main head server for storage and backup when the jobs complete.

My boss can't figure out why its working at all. He said that something on the motherboard shorted out a few years back when a girl tried to force a SATA plug into the area where the 4 pins are located on a SATA drive (or something along these lines). She managed to get it in there (how none of us know) but when she turned on the computer, apparently some sparks flew. Anyhow, he says he's surprised the dang thing even turns on at all.
m
0
l
!