Sign in with
Sign up | Sign in
Your question

SSD will not boot in ahci mode

Tags:
  • SSD
  • SATA
  • Storage
Last response: in Storage
Share
June 16, 2011 3:16:50 AM

Hi all. I hope someone here can help me with this problem. I am trying to install 64gb Kingston V100 ssd in my build for OS and the only way it will let me install the OS (Windows 7 64 bit) is if SATA is in IDE mode. In AHCI mode it says "Windows cannot be installed to this disk." Further details states "Ensure the disk's controller is enabled in the BIOS." I have tried numerous steps (below) after reading solutions online:

- made sure ssd was connected to sata 0 or sata 1 port
-changed sata cables
-unplugged all other sata devices including cd rom and other hd's and tried to install OS with flash drive
-installed rst drivers during preinstallation
-installed OS in IDE mode and then enabled AHCI through regedit, still OS doesn't boot in AHCI

The last procedure seemed to be what worked for most people but that didn't work for me either. Since I had a second kingston ssd I bought for my laptop I even tried using that and its the same situation.
My motherboard is an EVGA e758 3 sli board.

I don't know what to do anymore. I was told that the ssd will perform best in AHCI so thats why I don't want it in IDE mode even though that seems to be the only way it will work.

If anyone can help I would appreciate it. Thanks.

More about : ssd boot ahci mode

June 16, 2011 9:35:29 AM

goto BIOS and set it to compatibility mode. i got this with my toshiba hdd after installing a new retail copy of windows 7. but the first windows 7 i had on this laptop was running in ahci mode and had no problems. now it compatibility mode cause itl crash during startup.
m
0
l
Related resources
June 16, 2011 6:08:04 PM

Hi, I had actually looked thru those forums. That second thread was one where the guy had the exact issue. Its not solved. He's got the ssd hooked up to the jmicron controller now and he thinks its sata 0 and that evga mislabeled it or something.
m
0
l
!