Sign in with
Sign up | Sign in
Your question
Solved

I7 Showing only 2 cores and 4 threads

Last response: in Motherboards
Share
February 14, 2010 7:34:58 PM

Ok so I ran cpu-z and its reporting 2 cores and 4 threads. I have a core i7 920 and know it should be 4 cores and 8 threads.
I have a dell 435mt and updated to the most recent bios. Now that i've updated the bios - i can't get into it for some reason to turn off stepping. I've changed in my boot.ini to 4 as the "number of processors". I am stumped as to why its still showing 2 cores in cpu-z.

Using the latest bios version 1.1.4 from the dell site for my Studio XPS 435mt.

A friend of mine did a home build with the same cpu - disabled stepping when he noticed the same issue - and now his reports 4 cores and 8 threads.

I know someone can help me with this here... please help.

CPU-Z report file

More about : showing cores threads

a b à CPUs
a b V Motherboard
February 14, 2010 9:06:37 PM

Change you boot.ini, set the number of processors to 8.
m
0
l
February 14, 2010 9:46:04 PM

it only goes up to 4...
m
0
l
Related resources

Best solution

a b à CPUs
a b V Motherboard
February 14, 2010 10:12:51 PM

Using msconfig, go to the boot > advanced settings and uncheck the number of processors.
Share
February 15, 2010 2:46:11 AM

Sorry I posted here because I know dell typicallly uses foxconn... in any case... i'm now readying the 4 cores and 8 threads.
m
0
l
February 15, 2010 2:46:28 AM

Best answer selected by Mercil355.
m
0
l
February 15, 2010 3:29:01 AM

Alternate Resolution --> Enabling all the cores from BIOS :) 
m
0
l
March 12, 2011 7:34:15 PM

win7 64 bit. upgraded from core 2 duo to core 2 quad. it showed 2 cores working only in windows. device manager showed 4 cores, bios showed 4 cores. went to start, search programs, typed msconfig, open and general tab shows startup selection. make it normal startup. this worked for me. now shows all four cores.
m
0
l
!