Solved

I7 Showing only 2 cores and 4 threads

Ok so I ran cpu-z and its reporting 2 cores and 4 threads. I have a core i7 920 and know it should be 4 cores and 8 threads.
I have a dell 435mt and updated to the most recent bios. Now that i've updated the bios - i can't get into it for some reason to turn off stepping. I've changed in my boot.ini to 4 as the "number of processors". I am stumped as to why its still showing 2 cores in cpu-z.

Using the latest bios version 1.1.4 from the dell site for my Studio XPS 435mt.

A friend of mine did a home build with the same cpu - disabled stepping when he noticed the same issue - and now his reports 4 cores and 8 threads.

I know someone can help me with this here... please help.

CPU-Z report file
Reply to mercil355
8 answers Last reply Best Answer
More about showing cores threads
  1. Change you boot.ini, set the number of processors to 8.
    Reply to ekoostik
  2. it only goes up to 4...
    Reply to mercil355
  3. Best answer
    Using msconfig, go to the boot > advanced settings and uncheck the number of processors.
    Reply to lothdk
  4. Sorry I posted here because I know dell typicallly uses foxconn... in any case... i'm now readying the 4 cores and 8 threads.
    Reply to mercil355
  5. Best answer selected by Mercil355.
    Reply to mercil355
  6. Alternate Resolution --> Enabling all the cores from BIOS :)
    Reply to v-2samrc
  7. win7 64 bit. upgraded from core 2 duo to core 2 quad. it showed 2 cores working only in windows. device manager showed 4 cores, bios showed 4 cores. went to start, search programs, typed msconfig, open and general tab shows startup selection. make it normal startup. this worked for me. now shows all four cores.
    Reply to colester2
  8. I can confirm colester2 is a genius, only answer that worked for me. Thanks colester2.
    Reply to jhsparky
Ask a new question Answer

Read More

Foxconn BIOS Intel i7 CPUs Motherboards