Sign in with
Sign up | Sign in
Your question
Solved

USB>SATA controller problems. 2.5" drives

Last response: in Storage
Share
June 16, 2011 11:48:04 AM

Hello, I am having a strange problem..hoping I could get some help!

I have an original style 250GB WD Passport and I also have a 120GB WD drive from an older Dell laptop

120GB laptop drive failed so I bought a 320GB WD blue.

My plan was to put the 250GB drive from my Passport into the laptop and use the Passport enclosure with the new 320GB drive.

I was able to open the Passport and use the 250GB in the laptop. Everything seems fine so far with it

However, I'm having trouble with the 320GB and the Passport enclosure. I am receiving many error messages when using it on Mac. For example, I am getting a message that says "Mac OS X can't repair the disk. ... Back up and reformat". I get error messages when Verifying and Repairing Disk in Disk Utility. There are problems mounting the disk when I put a NTFS partition on it. I also receive "input/output" and "can't allocate memory" errors when trying to restore a dmg to the drive.

I was successful in restoring the same dmg to another external multiple times so I don't think there is anything wrong with the image.

Then I bought a Vantec 2.5" external enclosure and plugged in the 320GB into it. Tried restoring the dmg and worked perfectly on first try. No NTFS or other problems either.

Initially I thought the 320GB drive might have been bad, but now I guess this is not the case? Maybe the USB>SATA controller from the Passport became damaged when opening the case?

I put the failed 120GB drive into the Passport. I was able to restore the dmg on my first attempt and there do not seem to be NTFS mounting problems as well. So maybe there is nothing wrong with the Passport controller?

Anyway, I was wondering if anyone has an idea why the 320GB had so many problems with the Passport controller but worked fine using the Vantec controller. And why the 120GB works with the Passport controller when the 320GB had so many issues.

Thanks!

Best solution

a c 415 G Storage
June 16, 2011 3:25:51 PM

So let me get this straight - you bought a bare 320GB drive and tried to use it in a WD enclosure that previously held a 250GB drive?

It may be that the controller in the WD enclosure doesn't support drives that are larger than a certain number of sectors. To have a limit somewhere between 250GB and 320GB seems like a bit of an odd size for that kind of issue, but it would explain the symptoms.
Share
a b G Storage
June 16, 2011 5:03:29 PM

Have you tried reformatting the 320GB drive?
m
0
l
Related resources
a c 415 G Storage
June 16, 2011 5:12:06 PM

^+1

Good point - there's a chance that the WD controller is fiddling with the LBN numbers as they're passed to the drive, along the lines of the "XP" jumper on the 4K-sector drives. Re-partitioning and re-formatting the drive would solve that problem.
m
0
l
June 16, 2011 6:16:17 PM

Yes I put the 320Gb in the 250gb enclosure. I've reformatted and repartitioned multiple times and I still had the same problems.
m
0
l
a b G Storage
June 16, 2011 6:38:22 PM

Then the only conclusion I can make is the enclosure doesn't support the drive.
m
0
l
June 17, 2011 8:43:43 AM

Thanks, I was thinking this too but it seemed strange for the WD enclosure to have a size limit since I'm pretty sure there were drives larger than 250GB when I bought it.
m
0
l
June 17, 2011 8:44:05 AM

Best answer selected by henrygale.
m
0
l
!