Sign in with
Sign up | Sign in
Your question
Solved

How to set SSD as primary hard drive?

Last response: in Storage
Share
June 16, 2011 8:38:19 PM

Hello~
I just recently install a SSD to my system but I when I tried to format my harddrive it still said primary. Do I need to have my SSD as primary if I want to put my OS on it? In order to make the SSD primary do I do that in bios or was I suppose to put the cable I used my harddrive previously to make it primary?
*The M4 is the SSD in the picture

a b G Storage
June 16, 2011 9:35:56 PM

You need to set your motherboard to run the SSD under AHCI not IDE or you wont be able to run TRIM and you will lose bandwidth from the SSD as IDE is limited to 133 MHZ tops. All you need to do after that is to make sure the SSD is set to the first position in the boot order. From the look of the supplied picture the SSD is been seen by the OS as the System drive. The HDD you have in there is saying Primary as it is sitting on a "Primary" controller which is confusing the issue a little. The fact that the SSD is showing up on controller 0 means it is connected to the right controller. It could however be set up on another controller as long as the boot order in the BIOS is correct.
m
0
l
a b G Storage
June 16, 2011 9:39:32 PM

Set the bios to boot CD/DVD first and then set the SSD to boot second and it should be primary
m
0
l
Related resources
June 16, 2011 9:53:31 PM

My system is booting on and off not I must off broken something
m
0
l
a b G Storage
June 16, 2011 9:55:30 PM

There may be a setting in your BIOS called Hard Drive Boot Priority or similar. You need to make sure the SSD is set to number one on that. Then there is likely another Boot Order option that will allow you to position the DVD Drive as the first boot device. You will need to set the DVD to the first boot device if the PC already has an installed OS. If it doesn't it will go to the DVD drive if it cant find a HDD or SSD to boot from.
m
0
l
June 16, 2011 9:57:10 PM

My CDROM is first boot device second is hard drive next is floppy. SSD does not show as a option for me.
m
1
l
June 16, 2011 10:01:23 PM

I just found the hard disk boot priority..its shows M4 as first and my other harddrive as secondary which does not make sense since windows shows it as primary.
m
0
l
a b G Storage
June 16, 2011 10:02:56 PM

It is unlikely anything is broken. Set your controller to AHCI or ACPI if that is what your BIOS supports. Set the SSD to number one in the Hard Disk Drive Priority if your BIOS supports that. Then go to the separate Boot Order Option and make the DVD Drive number one there. Reboot and follow the instructions in the OS set up. It is OK to disconnect your HDD before you install and reconnect later. Just make sure if you do that the reconnected HDD does not knock the SSD to number two in the Hard Disk Drive Priority settings or the PC wont boot as it wont look to the SSD for the OS.
m
0
l
June 16, 2011 10:03:18 PM

also not sure hot to set the controller to AHCI or ACPI.
m
0
l
a b G Storage
June 16, 2011 10:08:02 PM

Hashio said:
I just found the hard disk boot priority..its shows M4 as first and my other harddrive as secondary which does not make sense since windows shows it as primary.http://www.ffxivcore.com/gallery/1304243539/med_gallery_3171_214_140766.jpg


Excellent we are making progress. Once you set the BIOS to ACHI or ACPI then the Primary question is no longer an issue. The term Primary is related to the old IDE way of doing things. You had Primary and Secondary or it was sometimes called Master and Slave. You don't want to run that SSD under the IDE standard! Also the BIOS is not going to call the SSD a SSD it will call it a HDD as this is what the SSD presents itself as to the BIOS. If the M4 is set to 1 in the Hard Drive Priority settings and the Controller is set to ACHI or ACPI you are good to go. Install and enjoy.
m
0
l
June 16, 2011 10:09:01 PM

is there where you set the achi or acpi? sorry if I am confusing this.
m
0
l
a b G Storage
June 16, 2011 10:19:39 PM

Ok if you have a IDE DVD leave the GSATA 6_7 IDE controller enabled. If you have SATA DVD Drive then you may be able to set the controller to ACHI mode there. Now further down you see GSATA 6_7 IDE Ctrl Mode and GSATA 8_9 IDE Ctrl Mode. Set both of those to what I believe will be ACHI. It could be ACPI but I think it will be ACHI. Once this is done then save the settings and boot her up.
m
0
l
June 16, 2011 10:26:50 PM

Wamphryi said:
Ok if you have a IDE DVD leave the GSATA 6_7 IDE controller enabled. If you have SATA DVD Drive then you may be able to set the controller to ACHI mode there. Now further down you see GSATA 6_7 IDE Ctrl Mode and GSATA 8_9 IDE Ctrl Mode. Set both of those to what I believe will be ACHI. It could be ACPI but I think it will be ACHI. Once this is done then save the settings and boot her up.



Alright set them both. Going to boot up and see what it says
m
0
l
a b G Storage
June 16, 2011 10:28:51 PM

Actually if the DVD is IDE it will be on to a separate controller. So that should not be an issue.
m
0
l
June 16, 2011 10:35:56 PM

Still shows up same in my last picture. my hard drive is still primary
m
0
l
a b G Storage
June 16, 2011 10:46:16 PM

That does not matter. The settings for install are correct and should be good to go. The SSD is showing up as "System" which means it is the boot drive and ready to act as such.
m
0
l
June 16, 2011 10:46:58 PM

My regular hard drive - is it okay if I leave it as ACHI if it was primay( I am about to give up soon and just leave the SSD alone)
m
0
l
June 16, 2011 10:49:50 PM

Wamphryi said:
That does not matter. The settings for install are correct and should be good to go. The SSD is showing up as "System" which means it is the boot drive and ready to act as such.



The system you are talking about is disk 1 patrion 1 system reserved is not my SSD its Disk 0 unallocated space.
m
0
l
a b G Storage
June 16, 2011 10:52:36 PM

Your regular HDD will be fine. It is not the system drive and will be read by the OS after install. Install to the SSD. Your settings are what they should be. One thing though if your HDD has an OS installed on it then that will be an issue. If it does back up all the data on it to another drive. Reformat the HDD and put the data you backed up back on it and away you go.
m
0
l
a b G Storage
June 16, 2011 10:54:59 PM

Disk 0 is your SSD. It is presenting as Disk 0 as it is connected to Controller 0. The Controller goes 0 1 2 etc not 1 2 etc.
m
0
l
a b G Storage
June 16, 2011 10:56:54 PM

Win 7 always installs that 100 MB Partition which then is treated as a separate drive. It has installed it on the SSD. Wait back up and halt everything. Now that I have looked at the picture again I see that either Win 7 has tried to install to the HDD or the HDD already has Win 7 installed. You cant have any OS installed on the HDD.
m
0
l
June 16, 2011 11:01:12 PM

Just double checking so I do not screw anything up . Install it on my SSD even though it does not say primary? I already reformat my harddrive no OS on it now.



m
0
l

Best solution

a b G Storage
June 16, 2011 11:03:47 PM

Here is what you can do. Back up all the Data you want to another HDD. Unplug the HDD completely. This will leave only the SSD. Install the OS to the SSD. Then reformat your original HDD and put the data (not programs) back on it. The reason why the HDD is saying Primary is because it has a Primary Partition on it. It is not a Primary HDD it is the partition displaying itself. Does that make sense? If you have just the SSD in there it will do the same thing. It will have the "System" partition and the Primary Partition.

Ok if the HDD has not data on it delete the system partition and the primary partition on the HDD. This will leave it un allocated. When you install to the SSD it will then say System and Primary. If you want the HDD to not have a system partition unplug it before install.
Share
June 16, 2011 11:10:29 PM

I think I am starting to understand (thank you for the patiences) So delete the system and the primary HDD then install OS on SSD (disk 0)
m
0
l
a b G Storage
June 16, 2011 11:29:37 PM

Correct. The System and Primary "Partitions" are on the HDD. Delete them. Then to make sure you dont have to have a system partition on the HDD unplug it until you have finished installing to the SSD. Then reconnect the HDD and Initialize the HDD in Disk Manager and Win 7 will see it. Then format the HDD and it will be good to go. When you plug the HDD back in make sure the SSD stays as number 1 in the Hard Drive Priority Settings.
m
0
l
June 16, 2011 11:32:35 PM

Best answer selected by Hashio.
m
0
l
June 16, 2011 11:33:39 PM

Alright I will delete them and install it on my SSD. I will not unplug the HDD even though I should but I am too tired to open up my case again. Hopefully this will not cause a problem
m
0
l
a b G Storage
June 16, 2011 11:37:29 PM

It wont cause a problem it will just likely mean you will see BOTH the SSD and the HDD present with System and Primary Partitions. This will not effect your system negatively as you do not have Partition Based encryption on either drive.
m
0
l
June 16, 2011 11:52:06 PM

Urgrent: My hard ddrive does how up in windows 7 when I booted up?
m
0
l
June 17, 2011 12:00:55 AM

It just shows my SSd as my C drive
m
0
l
a b G Storage
June 17, 2011 12:20:37 AM

As I said go to Disk Manager. Right Click on My Computer. Click Manage. Select Disk Management. It will likely ask if you want to initialize the HDD. IF not find the HDD and Initialize it. If it is Initialized already then right click on the HDD and format it. You should then see it in My Computer all set to go.
m
0
l
June 17, 2011 12:49:45 AM

Ah got it. Everything is pretty much back to normal. My computer is acting weird though. Like the time when I first build it it boots akwardly. (7 repeat boots unintill i am log into windows 7) Maybe my drivers for my motherboard was wipe as well?
m
0
l
a b G Storage
June 17, 2011 1:26:12 AM

During Setup Win 7 can repeatedly boot as is it installed. If its requiring multiple boots after installation then that could be a hardware issue. That aside make sure you install Win 7 Service Pack 1 and all the updates off Windows Update. Make sure you have the latest drivers for everything in your system. If it is still acting up post the issue to a new thread to get a wide range of suggestions.
m
0
l
June 17, 2011 1:27:55 AM

Alright, thanks again. I think I should solve it since I had the same issue a long time ago.
m
0
l
!