Sign in with
Sign up | Sign in
Your question

Bios Rom Checksum Error - SYSTEM HALTED

Last response: in Components
Share
November 19, 2009 5:34:37 PM

Hi everyone,

Last week the PSU in my PC went, I have today installed a new one. The system is now displaying the following...

Award BootBlock BIOS v1.0
Copyright (c), 2000, Award software, inc.

BIOS ROM checksum error

Detecting floppy drive A media


... I have already done some background reading. First thing to note is the floppy drive is not being recognised at all. I have so far tried 2 floppy drives and neither worked. Therefore i have been unable to attempt a flash of the bios...

I have replaced the CMOS battery and the same message occurs. I am not given the chance to get into the bios to change any settings eg change my boot from floppy to cd drive etc.

Before i spend any more money on this just wondering the following...
Is this message only displayed on bios error? would a new bios chip fix this? I can get one for about a tenner on ebay :) 
Is it common when a PSU goes to take bios with it? I have had a few PSU go in my time and never had this problem.

The board itself doesnt seem to have any burn marks etc. The only thing i havent checked so far is the RAM. Any more ideas?

Look forward to your replies

Dave

More about : bios rom checksum error system halted

November 19, 2009 10:01:44 PM

What kind of mobo are you talking about? I'd be worried about this nickel and diming trying to figure out whats wrong with an older board thats not recoverable anyway. It could just be the bios, or it could run deeper.
!