Sign in with
Sign up | Sign in
Your question

I7 860 -- Problem with speed step/turbo boost?

Last response: in CPUs
Share
November 21, 2009 1:29:16 PM

I am a proud owner of a i7 860, running at stock speed (so I thought until yesterday). Until now I was satisfied with the performance of the system, especially as my new HD5870 just arrived. ;) 

Yesterday I checked the core frequency and found out that it never runs at the frequency it is supposed to. It should reach 2.8GHz without turbo boost, and >3GHz if turbo boost is active. Sadly, I can never see higher speeds than 2GHz, even under full load.

All energy settings of Windows are set to high performance.
a b à CPUs
November 21, 2009 1:32:20 PM

NJoe said:
I am a proud owner of a i7 860, running at stock speed (so I thought until yesterday). Until now I was satisfied with the performance of the system, especially as my new HD5870 just arrived. ;) 

Yesterday I checked the core frequency and found out that it never runs at the frequency it is supposed to. It should reach 2.8GHz without turbo boost, and >3GHz if turbo boost is active. Sadly, I can never see higher speeds than 2GHz, even under full load.

All energy settings of Windows are set to high performance.


Sounds like you need to go into bios and turn off speed step. that should restore your GHz back to stock.
November 21, 2009 4:25:54 PM

I forgot -- here is a picture of Argus Monitor showing the problem:



The multipliers never go above 15

I thought it might be a problem with overheating, but the temperatures seem to be good.



warmon6 said:
Sounds like you need to go into bios and turn off speed step. that should restore your GHz back to stock.


I just updated to the newest BIOS a few days ago and did load the 'optimized defaults' afterwards. This should be OK, but I will go and check the BIOS settings next time I can reboot.
Related resources
November 21, 2009 4:37:01 PM

Is the energy saving mode on?
November 21, 2009 4:47:32 PM

@peanutpc: I use Win7 and set the power options to 'Balanced', but I also tried 'High Performance' and it did not make a difference.
a b à CPUs
November 21, 2009 4:51:49 PM

NJoe said:
I forgot -- here is a picture of Argus Monitor showing the problem:

http://www.abload.de/img/argus_monitor_core_fre6meh.png

The multipliers never go above 15 http://www.abload.de/img/argus_monitor_core_mulewvl.png

I thought it might be a problem with overheating, but the temperatures seem to be good.

http://www.abload.de/img/argus_monitor_core_tem0k7s.png



I just updated to the newest BIOS a few days ago and did load the 'optimized defaults' afterwards. This should be OK, but I will go and check the BIOS settings next time I can reboot.


Yea, the temps are fine. if your hitting above 60C should should be worried and if there above 70C then you have a problem.

For the speed issue i think it is speed step that is causing this problem. Apparently the cpu thinks that it's not being stressed enough to run at stock speed. The only program i know that will force any cpu to run at stock or higher is Prime95.

I suggest running prime95 on a "Torture test" to see if it will go above 2GHz.
November 21, 2009 4:58:54 PM

I was running prime95 at the time I took the screenshots. ;)  Only one instance though, still it should be sufficient to have the CPU increase its speed at least to the stock speed (but I would also expect to see turbo mode to be activated).
a b à CPUs
November 21, 2009 5:07:09 PM

NJoe said:
I was running prime95 at the time I took the screenshots. ;)  Only one instance though, still it should be sufficient to have the CPU increase its speed at least to the stock speed (but I would also expect to see turbo mode to be activated).


Sorry about that. :sweat:  Didn't know you already used prime95.

As you said it should of went to stock speeds and then some under prime95. The first thing i can guess is speed step in bios is preventing full use of it speed. If that doesn't work then i would say either 1 of these 2 thing:

A. something underclocked the cpu and needs to be clock back up to normal speeds.
B. the cpu went bad (although this is unlikely due to if it was bad then it should not be working.)
November 21, 2009 5:13:47 PM

OK, thanks for your suggestions. I will check the BIOS settings upon next reboot (the system is working now and I cannot do a reboot for the next few hours).

I will report back if I have checked the BIOS.
a b à CPUs
November 21, 2009 5:15:51 PM

ok. glad to help as much as i could.
November 25, 2009 1:31:23 PM

Ok, I got it working -- it was indeed a option in the BIOS that was set up incorrectly (even though I had loaded the optimized results after updating the BIOS).

There was an option to set the CPU multiplier and this was set to 15. I changed it to the correct value (21) and now it is woking properly.

Here is how it looks like in Argus Monitor now, when the system is under full load (I am running y-cruncher in 'stress test' mode):



Today I updated to BIOS F5 for my Gigabyte GA P55M UD2 and after loading the optimized defaults the multiplier setting has the correct value.

Thanks again for your help!
a b à CPUs
November 25, 2009 5:51:54 PM

Glad to of helped.
Anonymous
a b à CPUs
December 5, 2009 1:12:03 PM

NJoe said:
Ok, I got it working -- it was indeed a option in the BIOS that was set up incorrectly (even though I had loaded the optimized results after updating the BIOS).

There was an option to set the CPU multiplier and this was set to 15. I changed it to the correct value (21) and now it is woking properly.

Here is how it looks like in Argus Monitor now, when the system is under full load (I am running y-cruncher in 'stress test' mode):

http://www.abload.de/img/argus_monitor_workingfwb8.png

Today I updated to BIOS F5 for my Gigabyte GA P55M UD2 and after loading the optimized defaults the multiplier setting has the correct value.

Thanks again for your help!


NJoe, Can you publish the results when loading a single CPU with Turbo Boost enabled? It should go to much higher frequencies and I wondered whether these are realistic on the UD2 mobo.
December 15, 2009 2:38:36 PM

Sorry for the very late reply -- I did not check back after my problem was solved.


Now everything is working fine and I will post a screenshot. System Core0 is under 100% load, all other cores are (almost) idle.

This is how it looks in Argus Monitor:



If ALL cores are idle, the Multipliers drop to 9, but as soon as one core has work to do all other cores are showing multipliers of at least 15 (the image is not static, but this is hard to capture with just one screenshot ;)  )
!