Sign in with
Sign up | Sign in
Your question

Graphics card power connection problem please help

Last response: in Graphics & Displays
Share
September 21, 2009 10:24:29 PM

I have an old ati all in wonder 9800 card. A few days ago, suddenly it started to show vertical lines with colours in the monitor.

After a lot of tests I think I have found where is the problem.

The problem is that the power connector on the card board looses contact with the power supply connector.



Is there any way to be replaced or fixed?
a c 113 U Graphics card
September 22, 2009 12:46:56 AM

Floppy power connector, You may be able to harvest one from a old floppy drive or even try to re-solder that one(if its loosing contact there, if its on the psu end, you can find a molex to fdd connector on the net or check for another one of those, most psu's had 2 of those)

http://www.newegg.com/Product/Product.aspx?Item=N82E168...

The card should not be able to boot(should display a message about not connecting the power cable and to look at the getting started page for info, and your pc speaker should beep at you) at all without that connected. So if it boots, your card may be on its way out.
a c 173 U Graphics card
September 22, 2009 1:29:06 AM

I had that problem it drove me nuts and even switched psu out which helped for a few months till late spring then summer. I have my doubts about the molex to floppy but it might work. Try to position the power cable to ware it exerts force against the card but again band aid. Got tired and bought a 7800gs till I got tired of the board being slower than dirt and sold it all off. Not happy parting with either card but needed the money.
!