ATI 4670 artifacting problem

I have an ATI SAPPHIRE 100255HDMI Radeon HD 4670 and am having major artifacting/Tearing issues. Currently Crysis/Crysis Warhead are unplayable, I can look at the ground and sky and the textures look fine however when I try to play the textures seem to not load. Two worlds exhibits the same issue as well as The Witcher and Mirrors Edge (see attached link)


http://www.flickr.com/photos/42792752@N06/3943825587/in/photostream/

I have no problems with Fallout 3, Quake Wars, UT3, Bioshock, Batman Arkham, or any of my kids Lego games so I don't think the card has crapped out on me. I have toyed with v-sync and triple buffering, my monitor is an Acer 22" LCD


Any ideas what is causing this? I have th latest ATI cat driver installed (9.9) running on a custom built Pent. Core 2 Duo 1.86 GHZ, 4 MB RAM.

Thanks

Here's more detail from dxdiag.

------------------
System Information
------------------

Time of this report: 9/21/2009, 23:46:16
Machine name: PAINKEEP
Operating System: Windows XP Home Edition (5.1, Build 2600) Service Pack 3 (2600.xpsp_sp3_gdr.090206-1234)
Language: English (Regional Setting: English)
System Manufacturer: Gigabyte Technology Co., Ltd.
System Model: 965P-DS3
BIOS: Award Modular BIOS v6.00PG
Processor: Intel(R) Core(TM)2 CPU 6320 @ 1.86GHz (2 CPUs)
Memory: 3582MB RAM
Page File: 723MB used, 5689MB available
Windows Dir: C:\WINDOWS
DirectX Version: DirectX 9.0c (4.09.0000.0904)
DX Setup Parameters: Not found
DxDiag Version: 5.03.2600.5512 32bit Unicode
---------------
Display Devices
---------------
Card name: ATI Radeon HD 4600 Series
Manufacturer: ATI Technologies Inc.
Chip type: ATI Radeon Graphics Processor (0x9490)
DAC type: Internal DAC(400MHz)
Device Key: Enum\PCI\VEN_1002&DEV_9490&SUBSYS_E100174B&REV_00
Display Memory: 512.0 MB
Current Mode: 1440 x 900 (32 bit) (60Hz)
Monitor: Plug and Play Monitor
Monitor Max Res: 1600,1200
Driver Name: ati2dvag.dll
Driver Version: 6.14.0010.6999 (English)
DDI Version: 9 (or higher)
Driver Attributes: Final Retail
Driver Date/Size: 8/13/2009 22:27:20, 345600 bytes
WHQL Logo'd: Yes
WHQL Date Stamp: n/a
VDD: n/a
Mini VDD: ati2mtag.sys
Mini VDD Date: 8/14/2009 00:27:00, 4485632 bytes
Device Identifier: {D7B71EE2-D7D0-11CF-AC6F-0AC1A1C2CB35}
Vendor ID: 0x1002
Device ID: 0x9490
SubSys ID: 0xE100174B
Revision ID: 0x0000
Revision ID: 0x0000
Video Accel: ModeMPEG2_C ModeMPEG2_D
4 answers Last reply
More about 4670 artifacting problem
  1. uninstall 9.9 and try using older driver. but don't forget to use driver sweeper to clean any left over
  2. It does it under 9.8 but I haven't tried any of the older 8.xx drivers yet. Will try tonight when I get outta work.
  3. Well, no luck with the older driver swap out. Tried cat 8.11, 9.5, 9.7 and still have the same issue. Increased the fan speed downclocked the core speed of the GPU and still having the same issue.

    Any ideas??
  4. i can only think that that your card might be damaged. can you try your card on another pc to play the games you're having trouble with? see if similar problem happens
Ask a new question

Read More

Radeon ATI Graphics