Sign in with
Sign up | Sign in
Your question

HD 4850 Blackscreen Fix?

Last response: in Graphics & Displays
Share
September 23, 2009 1:19:35 AM

Has anyone come up with a fix for the blackscreen at login with the 4800 series cards?

I am losing my F'ing mind!! I have tried xp pro x32 , Vista Ultimate x32, and now Windows 7 x64 all clean installs and drivers, latest BIOS etc.. still nothing!!!

AMD Phenom X4 9850BE
4 GB Corsair Dominator 6800
3 Seagate SATA HDD 600 GB total
Asus M3A32 MVP Deluxe Mobo
2x HIS Radeon HD 4850 DDR3 512MB(was attempting in crossfire mode but with blackscreen problem......)
850w PSU
both cards have own independent power 6 pin power cable.
Monitor is Westinghouse LCM-22W2

My issue started while running Vista Ultimate x32 when I updated the drivers to CCC 9.6 from the original set that came with my cards. The problem I was having with them was I could not get CrossfireX running properly so I thought new drivers so wiped all old drivers ran driver sweep etc.. installed new drivers and bang blackscreen if I start in safe mode it works, so I did a clean install of XP pro and same thing with new drivers, so switched to 7 Ultimate x64 and same f'ing thing. Every install was a clean formatted HDD.
I have tried DVI, HDMI, RGB only thing I haven't tried is S-Video.

Please help!!!

More about : 4850 blackscreen fix

a b \ Driver
September 23, 2009 1:30:13 AM

Have you tried the old drivers again just to see if you can get that working? Do you have another monitor (or even TV with S-Video) you could try? Edit: Also, does HIS have any drivers specifically for your card on their website?
m
0
l
September 23, 2009 1:32:49 AM

Yeah tried the original drivers with XP and they work (sort of) but without crossfire(causes system to lock up) and I have tried running it on my Sony HD tv with same results.

Problem is I do not know if the drivers on the CD will work with Windows 7 or not.

HIS does have the drivers on their site but I get the same result.
m
0
l
Related resources
October 4, 2009 4:48:34 AM

Solved my problem and all it was for me was my own stupidity I forgot to plug in one of my card (D'oh!!). Doubt it will solve anyone elses problem but you never know.
m
0
l
a b \ Driver
October 4, 2009 4:55:52 AM

Well, its still good to close out the thread, so Thanks for posting back. And it may help someone, as we all make those mistakes now and then (I know I do a lot).
m
0
l
November 7, 2009 7:17:32 AM

ANSWER!

Scince this is the first google hit on 4850 and blackscreen windows 7 I put it out here:

I have a ASUS 4850 (all cables attached :lol: ) However win7 64bit does give a black screen after blank install.

WHY?
Win7 assumes my TV out is primary monitor.

SOLUTION
install windows with your tv connected (no monitors!)
after install win7 install latest radeon drivers
restart
connected monitors should now be recognized

BEWARE
problem solving (a feature of win7 when things get messy :pt1cable:  ) could lead to renewing (reinstall old) win7 drivers. Ironicly fixing your pc can give black screens.

SLEEP function
Hypothetically: because of this problem when windows goes to deep sleep it unloads the video drivers. Than when the computer awakes I get blue screens :fou:  and have to restart


some work for the microsoft guys i think it will be fixed within the next ten years :kaola: 
m
0
l
November 14, 2009 5:20:14 PM

EXT64 said:
Well, its still good to close out the thread, so Thanks for posting back. And it may help someone, as we all make those mistakes now and then (I know I do a lot).

Yesh sometimes it is always the simplest thing ya now?

m
0
l
!