Sign in with
Sign up | Sign in
Your question

SSD caching problem with Z68 mobo

Last response: in Storage
Share
June 28, 2011 12:45:55 AM

Hi,

I'm having an issue with SSD cachine (aka Intel Smart Response) with my Z68 chipset mobo. Specifically, once I built my system (specs listed below) I enabled SSD caching through the Intel Rapid Storage Technology software (not by hitting CTRL-I during system boot). Everything was working great for a couple of weeks. Then, I decided to disable the caching so I could try to see if there was any perceived difference in system performance. After disabling the caching and rebooting, my system would not boot up. I had to throw in the Windows 7 DVD and do a Repair in order to get my system up. Now, if I go into Intel Rapid Storage Technology, it still thinks that I have SSd caching enabled, but tells me the accelerated volume is not available and therefore caching is not functioning properly. It gives an option to disassociate the SSD drive from the accelerated volume, but taking that option causes an error message saying that the operation can't be performed. Also, when the system is booting up and Intel RST shows the status of my drivers, it lists the SSD drive as "Disabled" and won't allow me to do anything with it. I have tried removing the SSD drive and rebooting, reinstalling Intel RST, and flashing my mobo BIOS, but nothing seems to allow me to get the system into a state were it doesn't think that SSD drive is already in use as a caching disk for an unavailable volume. Can anyone suggest a fix for this? I'd prefer to avoid a re-install of my OS if at all possible. Any ideas? Here's my system:

Mobo: ASUS P8Z68-V Pro, BIOS version 0501
CPU: i7-2600K
RAM: G. Skill Ripjaw PC-12800 (2 x 4GB) DDR3-1600
GPU: EVGA GTX 560 Ti
SSD: 64GB Crucial M4
HDD: 2 x 1TB WD Caviar Blacks 64MB cache in RAID0

I have the SATA drives set to RAID (not AHCI) in Bios, and I'm using Intel RST version 10.5.0.1026.

a b G Storage
June 28, 2011 2:25:17 AM

I'd try disconnecting the SSD and resetting the BIOS. Reconnect the SSD and re-enable caching. Let me know how this works out, I'm interested in this technology as well.
m
0
l
June 28, 2011 3:03:21 PM

I actually already tried that. The SSD is currently sitting on my desk. With it removed, I flashed the BIOS (I assume this is what you mean by resetting it). With the SSD drive not installed, the Intel RST screen that appears during boot does not show the SSD, nor does the user interface for RST within Windows 7. However, as soon as I put the SSD drive back in, the RST screen at bootup shows the SSD drive (shows status of "Disabled") and the RST user interface once again shows the SSD drive as being used for caching for a volume that it thinks is missing. I can't figure out how to make my system completely disregard all references to the SSD, so that when I put it back in, it considers it a new dive. Do I have to start from scratch and reset the CMOS, or do I maybe need to reinstall the Intel RST drivers from that boot screen (rather than the software version in Windows)? I can't figure this one out.
m
0
l
Related resources
June 29, 2011 1:27:10 PM

what about removing the Intel RST and control center software? If you do that after resetting the system in control-I with the intel bios.
m
0
l
June 29, 2011 5:47:27 PM


FIXED!

All I had to do was select "Set disks to non-RAID" from within the Intel RST bios (Option 4, I think). I could have sworn that I tried that before, but didn't see an option to modify anything other than my active RAID volume that had my OS on it. At any rate, that fixed the issue where the Intel RST bios listed the SSD drive as a disabled RAID0 volume. From there, I was able to boot up, start the Intel RST software, then re-enable Acceleration by selecting the SSD drive as an acceleration device. To make sure it worked, I did a reboot to ensure that 1) Intel RST bios correctly sees the SSD as a caching disk and is enabled (this works), and 2) that Windows 7 boots up normally (it does) as I have seen on the Intel forums where people had trouble booting the OS after enabling caching.

So, everything is working normally now. Thank you to those of you who replied with suggestions.
m
0
l
!