Sign in with
Sign up | Sign in
Your question

"IDE" installed XP drive system with AHCI SSD on Win64

Last response: in Storage
Share
June 28, 2011 3:12:22 PM

I got a ASUS P5Q Deluxe MB. My XP Harddisk(WD6400AACS-00G and the other one also) is installed on IDE emulation.
I found out that this far from the best config although i do get 90mb/sec(Crystal Mark read Seq.)

Me want's MORE.
So i got myself a redhot INTEL SSD320 160GB. :bounce: 
Now that im all fired up i plan to also goto Win7 64 on this SSD drive.
I will also install a new Harddisk a WD20EARS 2 TB for storage.
This one is a Advanced format drive to please Win7

Qestion1: After i disconnect my current HD's and change bios to AHCI sata and connect and install Win7 to the SSD, will i then be able to connect the sata HD's and read the data on my "old"
XP Harddisk(WD6400AACS-00G? It is partioned into C: and D: and a unused Linux part.

Im aware that the XP operating system will not work if i change to AHCI but will i be able to read the datafiles off it like myDocs.(yes they are backuped)

At the moment i got 2 HDdrives: XP Harddisk(WD6400AACS-00G) and another older harddrive WD2500JS-60MHB(250GB)
Qestion2:Will i be able to read/write to the WD2500JS-60MHB after i set bios to AHCI and install win7 on the SSD?
a c 375 G Storage
June 28, 2011 3:45:33 PM

You should be able to see all the drives fine as the OS will already have the necessary AHCI drivers installed. I'm not sure about the linux partition though.
June 28, 2011 4:07:15 PM

no, i think if you change the controller from ide to ahci you will need to reformat all the drives.
Related resources
a c 375 G Storage
June 28, 2011 4:11:09 PM

r3xx3r said:
no, i think if you change the controller from ide to ahci you will need to reformat all the drives.


He is doing a clean install of Win 7. As long as his bios is set to AHCI before he install windows, windows will have the necessary AHCI drivers installed to access all the drives. Switching from IDE to AHCI after the OS is installed takes a little more effort.
June 29, 2011 10:57:11 AM

This is slightly related to the topic at hand, so instead of making a new thread I thought I'd post here.

Can I have AHCI mode enabled with IDE hard drives?
a c 375 G Storage
June 29, 2011 11:54:56 AM

Hotobu said:
This is slightly related to the topic at hand, so instead of making a new thread I thought I'd post here.

Can I have AHCI mode enabled with IDE hard drives?


IDE channels in the bios only have enable/disable so this situation should never happen. If you are using an IDE to SATA adapter, then the adapter will handle the necessary commands.
June 30, 2011 1:24:04 AM

I have done it.
All i had to do was to Activate the partition on the SSD. Then i shut down XP Connected the SSD and Changed BIOS to AHCI. And win 7(54)installation was a breese.

However one problems remains with one of the old Harddisks.

J:/ is not accessable
Access denied


Why? How do i fix this? I tried RightClick->Properties
Here the drive show as empty and 0% used.

this is the old harddrive WD2500JS-60MHB(250GB) it does not support Native Command Quering.
It is healty according to CrystalDisk Info. Its is NTFS formated.

What is missing in the WD2500JS-60MHB(250GB) that stopps access to it?
It worked fine when i had XP and IDE SATA now that i have AHCI SATA with Win7 its inaccessable.

I tried to set permissions to the files and maps but it seemed it could not access to change them.
a c 375 G Storage
June 30, 2011 11:46:17 AM

Are you using the same user (account) name as you did in XP. I'm not sure it matters, but you should be able to take ownership of the drive.
June 30, 2011 12:55:12 PM

Thank you for fast responces and efforts so far. :hello: 

Its a new installation on the SSD and a new operating system(win7;64).
I was asked to make an account at the win7 istallation this accound has not been "seen" by the older drives. So no its not the same account as in XP.

The troubled drive did not have any special permissions, that i recall.

It's kind of wierd. When i left click on the drive i get "the location is not available"
When i go into properties/sequrity it says i need administator user with permission to wiev objects sequrity. properties
I click the continue button and my new account is there and in a listbox below
is the Permissions : Full control,Modify,Read&execute and all the others.

All allow checkboxes are ticked . But they are kind of greyish compared to
when i do the same on a drive that i dont have this problem with.
I wonder what significance this greying has since i can untick and tick them.
One exeption is the Special Permission but i assume(guessing) it is not relevant.

Im not so familiar with permissions in win XP or Win7 .

Since the 2 other HD's did not have anny major problems going from IDE to AHCI i assume that that isnt likely the issue. But this HD is the oldest and does NOT have the same support in the firmware like AAM and NCQ.

a c 375 G Storage
June 30, 2011 1:14:48 PM

Features such as AAM & NCQ shouldn't matter. I have a bunch of older WD drives (WD2500KS) that don't support NCQ that run fine using AHCI.

If you go into disk management, does the drive show up properly there? If so, is there an option to import foreign disk? (you may need to right click) If so, you can try that.

Also, try googling for "taking ownership of drives". There are plenty of examples of how to do this.
!