Sign in with
Sign up | Sign in
Your question

Apacer SSD slow 4k write speed

Last response: in Storage
Share
June 30, 2011 9:19:57 AM

When I built my new machine I went with a SSD as I figured it would quicker than a mechcanial one. My supplier only had Apacer SSD, so I picked up one of those. I must admit I didn't really know too much about the drive before I purchased and I certainly didn't know much about read/write speeds and the deal with smaller/larger files.

While the sequential read/write are in line with the advertised specs, the 4k write speed is very slow. They are about 1/2 the speed of my WD mechanical drive. Have I just picked up a repackaged older SSD? I know they had a lot of problem with writing small files.

Apacer Pro II AS202 64 GB

Spec on the box

Sustained read/write (MB/s) 210/110

Crystal Disk Mark 3.0.1

5 passes at 100MB

Read/Write (MB/s)

Seq 215.5 89.58
512k 191.2 53.94
4k 17.04 1.275
4k QD32 19.03 1.302


I don't know if this is pertinent to this thread, but the drive also has issues booting from a cold start. The OS resides on the SSD. It registers as a "?+serial number" in the bios after being turned off for a while. Holding the power button in for 20 seconds seems to reset the state of the drive and I can boot again. I tried swopping the power connector, position on the m/b, SATA cables, hard drive delay. For the first time this morning, I ripped out my WD My Book Essential external drive and the boot up seemed up quicker and without issues. Could my external drive be preventing the bios from reading the SSD?


June 30, 2011 5:29:46 PM

the drive was released back in january of this year, it is an entry level drive so it wont be very good, and it is from apacer, which i havent heard of before so i dont know if they are good or not, but i imagine they are not.
a b G Storage
July 1, 2011 7:30:53 PM

should check alignment with AS SSD or diskpart as well to be sure it's good.
Related resources
Can't find your answer ? Ask !
July 1, 2011 9:11:24 PM

thanks the drive is not aligned properly. I'll have a stab at aligning it tomo.
a c 353 G Storage
July 2, 2011 2:58:35 AM

Also AS SSD should show whar driver you are using, ie msahci or iastor. (Verify it is not showing ide)

Even the slow SSDs should be about 2x a HDD for small file random read/writes.
July 2, 2011 8:04:07 AM

thanks, it's using ahci but the alignment is 31.5k. It seems rather odd as I installed W7 as the OS on this while it was new. I thought W7 dealt with the alignment automatically?
July 2, 2011 1:50:10 PM

Aligning the drive seems to speed up the 4k write speed by about 50%, but it's still rather disappointing at 1.8 MB/s. I think even my new WD mechanical ext drive slightly outstrips that.
a b G Storage
July 2, 2011 1:55:19 PM

it does. are you sure you didn't restore a backup or use some other tool?

You have a few options here.

Use Paragon Alignment Tool(included in the HDD manager suite) to fix the current install.

Use Linux or another HDD partition management suite to create a new partition, move the OS partition and jockey things around.

Or simply secure erase(SE) the drive to clear the controller's map and reset it to factory fresh state and reinstall a fresh OS. If you don't SE it first then it would probably be good to allow the drive to idle at the login screen to allow the drives garbage collection to kick in and clean itself up. I always SE before fresh installs as it's guaranteed to give perfect results every time.

EDIT: just saw you have aligned the drive now. I would allow the drive to idle for at least 6-8 hours at the login screen(logoff) for garbage collection to kick in and clean itself up. If the drive has any utilities available you could use them as well. After being misaligned like that for so long.. you can be sure that the drive is VERY dirty by now. Be sure to never exceed about 75% of available capacity as well since it reduces stamina and leads to minimal recovery.

The other option would be to run a app called free space cleaner(AS Cleaner) with the #ff option checked which will write all 11's to the free space of the drive which will allow the controller to trim and return those blocks back to fresh states. May still need to allow some idle time immediately following the cleaning though.
July 4, 2011 8:35:48 AM

Thanks, I tried Secure Erase, but the drive doesn't support it for some or other reason. I reinstalled W7 again and used Free Space Cleaner and let it hang at the Windows logoff screen over-night. The drive's 4k write speed is now 3x faster without the SSD tweaks, so thanks for the help.
!