Sign in with
Sign up | Sign in
Your question
Closed

My Saphire HD4830 Doesn't Want to Overclock?

Last response: in Overclocking
Share
November 18, 2011 4:19:20 AM

Short version: My computer wonks out and crashes if I try to oc gpu by even 1MHz

Hi all, when I bought my 4830 it could handle most of the games out at the time, albeit with some lowering of the settings on occasion. Recently however it's been really strugling with some of the games coming out, even on lowest settings. I plan on upgrading in the future, but it's currently not in my budget. Figuring I'd make the best with what I've got, I tried my hand at overclocking my card to try and squeeze as many FPS out of it as possible. Some people have reported some very successfull overclocking of the card, however when I tried to bump up the core clock by just 5 MHz in AMD Overdrive the screen goes black and my computer locks up! Then when I restart my computer the screen flickers every time I move a window and usually locks up within a couple of minutes. I then have to restart the computer at least a couple more times before it finally returns back to normal.

I thought that perhaps it was the softwares fault. AMD Overdrive seems to have a bit of a bad rep, so I then decided to give GPUTool Community Technology Preview 1 a try. It said that the current clocks were changing when I'd move the slider and apply, and I ran Find Max for both the core and the memory clock. The core clock went up to 750 MHz before it crashed, and the memory stabilized at 920 with no artifacts. However when it was running the test i noticed that the fps in the little benchmark test it opens up stayed around the same even when I set the clocks to 720/920. I thought I'd try it in a game to see how it worked and the game crashed on launch. I changed the clocks to 590/900 (575/900 are default) and the game still crashed. It would only run at the stock clock speeds.

I then decided to give RivaTuner a go. RivaTuner seemed to raise the clocks without a hich. I opened up AMD Overdrive just to confirm the clocks actually changed, and it said they did. I then ran the HAWX benchmark at clock speeds and then at 699/910. The FPS would always be about the same no matter what the clock settings. In fact raising the memory clocked seemed to slightly drop the FPS even. Are the clocks saying their changing, when in reality they're not? Is my card nearing the end of it's life? Is there any way to fix this and be able to properly overclock it? I'm sure it's not overheating because the teps rarely get over 60C.

If I can ever get it to properly overclock it I'd like to do a BIOS mod to it as well as shown in this thread:
http://forums.extremeoverclocking.com/showthread.php?t=...
Would doing a BIOS mod to it now perhaps somehow help to aliviate my problem?
I'm rather desprate here, can anyone please help?!

Specs:
Saphire HD 4830
4800+ Core2Duo
2Gigs DDR
750GB WD Black Caviar 7200rpm
Asus A8N 32-SLI-Deluxe Mobo
Windows 7 Ultimate 64-bit
ATI Catalyst Version 11.10
Enermax EG701AX VE(W) SFMA 600W PSU

P.S. I apologize for my longwinded-ness, I tried to include all details I thought may be useful for solving my problem

EDIT: Added PSU to specs
a c 109 U Graphics card
a c 150 K Overclocking
November 18, 2011 4:22:25 AM

Use msi afterburner and gpu-z
Score
0
November 18, 2011 4:39:40 AM

I gave MSI Afterburner a try and if I attempt to overclock by even 1MHz the screen gets all flickery every time I move something around and the computer locks up when I try to start a game
Score
0
Related resources
a b U Graphics card
November 18, 2011 4:43:21 AM

How much vram is on the card?

Maybe something else is bottlenecking your computer...
Score
0
November 18, 2011 4:51:01 AM

It's 512mb DDR3 I believe. I can't imagine a bottleneck elsewhere causing such instability with as small of an overclock as 1Mhz. My PSU is 600W btw, forgot to put that on the specs, so shortage of power shouldn't be the issue either.
Score
0
November 18, 2011 7:01:20 PM

UPDATE: Tried the newer 11.11 drivers, exact same thing.

I looked up my PSU on newegg (here) and it not only appears to be a fairly old PSU (I'm not the one that installed it in the case, but I estimate the PSU to be about 5 yrs old), but it also seems somewhat prone to failing according to the reviews. Do you think the cause of my graphics card problems could potentially be my PSU is going bad?

EDIT: I've also tried overclocking it in Windows 8 and the same thing occurs. This (among other evidences) leads me to believe it is a hardware issue and not software.
Score
0
November 27, 2011 11:02:37 PM

Bump. Any help would be greatly appreciated
Score
0

Best solution

February 7, 2012 6:01:16 AM

If you're running dual monitors you'll need to disable your secondary monitor before you can overclock without crashing, it's a problem with sapphire radeon HD 4830 and 4850 cards, haven't found a fix yet from google, hope someone has some suggestions as I have the same card and the same symptoms. Just disable your secondary monitor/television and then try overclocking, should work no problems if you don't OC too much. I've also found that overclocking the memory at all on my sapphire HD 4830 results in artifacts so you may want to only OC the GPU, which you can OC to the max allowed by CCC Overdrive, just be sure to set your fan to 100% so you know for sure you aren't burning it up and be sure to watch your temps while under load for a while so you can get an idea of how hot things will get to be safe.
Share
February 8, 2012 3:07:15 AM

Wow, 3 months, but I must say I'm impressed bongpacks. I thank you for responding. I was in fact running dual monitors at the time. I figured the card was done for and failing. As of yesterday actually I've moved on to a 4870x2 and have been pretty happy with it so far, but anyone running into this problem I'm sure will be giving you many many thanks bong. I'll now feel a lot better selling my 4830 now I know it's not failing.

EDIT: Oh and welcome to the forums by the way! Great to have ya!
Score
0
February 8, 2012 3:07:58 AM

Best answer selected by PIZZA Man.
Score
0
February 8, 2012 3:16:13 AM

Thanks for the welcome, glad I could help! :) 
Score
0
!