Sign in with
Sign up | Sign in
Your question

RAM not running at full speed

Last response: in Motherboards
Share
February 27, 2010 5:32:52 AM

I have a Dell E510 Desktop with motherboard 0WG261 which has Chipset i945G/GZ.

I used PC Wizard and in the section of
Mainboard --> Chipset --> Northbridge Information -->RAM max. Support

Its showing DDR2 (667MHz). I checked my RAM combinations and found a bottleneck and I upgraded them and now all my 4 RAM slots are full with each containing 1GB memory capacity and supporting frequencies 200MHz, 266Mhz and 333Mhz. I even checked the latency timings of all the RAM chips and they all were the same.

When i completed my setup and again looked the running RAM frequency, i.e.
Mainboard --> Chipset --> Memory Information --> Frequency. it still says 266Mhz.

that means, memories are not functioning at 333Mhz.

Now the real problem is that the BIOS is updated and it doesn't provide user the settings to edit Memory frequencies.

Help me guys! Everything else is working perfectly

More about : ram running full speed

a c 435 V Motherboard
February 27, 2010 11:28:10 AM

Some boards will default to a lower speed when all ram slots are filled. If you've updated the bios, then there is nothing else you can do. That's a downside of oem boards: they have fewer bios adjustments. Don't risk your board by flashing again. It won't do any good. Also beware that cpuid sometimes shows a lower ram speed when using speedstep. You can check the dell bios and see if you can disable it. That's about it.
m
0
l
March 30, 2010 7:49:46 AM

o1die said:
Some boards will default to a lower speed when all ram slots are filled. If you've updated the bios, then there is nothing else you can do. That's a downside of oem boards: they have fewer bios adjustments. Don't risk your board by flashing again. It won't do any good. Also beware that cpuid sometimes shows a lower ram speed when using speedstep. You can check the dell bios and see if you can disable it. That's about it.




Thanks for your reply, I really appreciate it.

I checked my settings regarding the SpeedStep tech. from Intel on my BIOS. It was OFF. I checked the combination of 2 RAM slots or 4 RAM slots filled and the result were the same, they still all worked on 233Mhz.

With your similar response, i am convinced that there is nothing that could be done in consideration to my issue.
m
0
l
!