BIOS detects only some SATA ports

So here's the case, in BIOS; MAIN it says

SATA1: (my hard disk)
SATA2: (my other hard disk)
SATA3: (Another hard disk)
ESATA: (Empty)

On my motherboard however, it has 6 sata ports. Whenever I plug my DVD drive into SATA4, 5 or 6 my PC doesn't detect it, however if I connect it to SATA1, 2 or 3 it detects it. However, SATA1 to 3 are for my hard disks so is there anyway to get my BIOS to detect the other SATA ports?
8 answers Last reply
More about bios detects sata ports
  1. You may have SATA connections running through a secondary chip. Look for a setting such as Onboard SATA/IDE Device and make sure it is set to Enabled.

    For more specific help, we need to know your system specs. What motherboard do you have?
  2. ekoostik said:
    You may have SATA connections running through a secondary chip. Look for a setting such as Onboard SATA/IDE Device and make sure it is set to Enabled.

    For more specific help, we need to know your system specs. What motherboard do you have?


    Its M4N78 ASUS motherboard, as for my other specs, 4gb ram, geforce GTX 260, and the processor is AMD phenom (cant remember exactly which). My PC is running on vista sp1 32bit
  3. My Dell mobo allows me to shut off and turn on unused SATA ports, I once plugged in my DVD drive into an "off" port and it took me three days to figure out what I did wrong.
  4. Go into the BioS setup page.
  5. leaf876 said:
    Its M4N78 ASUS motherboard, as for my other specs, 4gb ram, geforce GTX 260, and the processor is AMD phenom (cant remember exactly which). My PC is running on vista sp1 32bit

    I found these screenshots of your BIOS menus: http://motherboards-reviews.com/ASUS/socket_AM3/M4N78-AM/ASUS_M4N78-AM_BIOS_screens.html

    It looks like you need to go to the Storage Configuration menu and make sure that "OnChip S-ATA Controller" is set to enabled as shown here: http://motherboards-reviews.com/ASUS/socket_AM3/M4N78-AM/images/ASUS_M4N78-AM_BIOS_Storage_Configuration.jpg
  6. Seems right, similar to my Dell menu, except when I don't turn off unused port my PC annoys me about it being empty unti lI shut it off.
  7. ekoostik said:
    I found these screenshots of your BIOS menus: http://motherboards-reviews.com/ASUS/socket_AM3/M4N78-AM/ASUS_M4N78-AM_BIOS_screens.html

    It looks like you need to go to the Storage Configuration menu and make sure that "OnChip S-ATA Controller" is set to enabled as shown here: http://motherboards-reviews.com/ASUS/socket_AM3/M4N78-AM/images/ASUS_M4N78-AM_BIOS_Storage_Configuration.jpg


    AWESOME! IT WORKED! Thank you very much! Appreciate it.
  8. You're welcome. Thanks for letting us know what did the trick.
Ask a new question

Read More

Motherboards BIOS Hard Drives SATA