Sign in with
Sign up | Sign in
Your question

Very high CPU usage when accessing a RAID-0 array after switching to W

Last response: in Storage
Share
July 6, 2011 11:35:58 AM

Hello everyone,
Recently I have switched to Windows 7 Ultimate SP 1 from XP Pro SP3 on my AMD 3200+/ASUS A8N-E (Nforce4 Ultra chipset) configuration that uses a software RAID-0 made by the onboard RAID BIOS consisting of two Samsung Spinpoint F3 500 GB drives, the stripe size is set at the default 64KB.

My problem is with how the new OS handles the RAID, which results in a very high CPU usage to the point where I cannot even listen to MP3 files or watch movies while any disk operation is underway (copying, defragging the other partitions,etc.)
While copying files the CPU usage is constantly above 60-70% peaking at 100% and several games stutter when accessing the hard drive.

This did not happen with XP SP3, I could literally play a demanding game, listen to mp3 files and play a movie at the same time, even while an OO defrag was running. CPU usage was below 10%. The CPU is overclocked from 2000 MHz to 2600Mhz (4200+ish), running at temperatures of 35 to 39 C (watercooling). The clock speed withstood a 13 hour Prime test. The memories pass all the Memtest86+ tests.

XP and Win7 are all 32-bit, I tried with no antivirus, updated all the drivers. The only solution I could find on the internet was to switch from SATA/IDE mode to AHCI in the BIOS, which will require enabling the drivers in Win7 and installing them beforehand if in XP (http://support.microsoft.com/kb/922976).
This is what I will be trying now as my backup finishes.However, I am not even sure my old BIOS (up to date thought) supports this mode.
Other threads about high CPU utilization on the Internet were solved by disabling hi-def audio services and gigabit network wake-up modes. My problem persists only when disk operations are going thought.

Should I switch back to XP? :(  I know my system is quite old but there is no reason it should not be able to play mp3 files :S
If anyone has any idea how to solve this, I would be very grateful.
Thank you for reading this!
July 6, 2011 11:39:55 AM

Everest Ultimate Disk Benchmark report:

m
0
l
July 7, 2011 8:37:44 PM

After several attempts to fix this problem and many others with the Nforce raid, I finally decided to disband it and reinstall my system on simple SATA drives.

Thanks to anyone who read this thread, I will most likely not check back for a solution thought.
m
0
l
a b G Storage
July 8, 2011 3:26:58 AM

This sounds like a driver bug to me, try seeing if there are updated drivers/firmware for your RAID controller.
m
0
l
!