Sign in with
Sign up | Sign in
Your question
Closed

Crucial M4 128GB SSD - master boot record frequently becoming corrupt

Last response: in Storage
Share
July 7, 2011 7:20:09 PM

I built my new system last week:

CPU: i7 2600K
RAM: Kingston HyperX Blu 1333mhz (16GB)
GPU: Gigabyte GTX 560 ti (SLI)
Mobo: Asrock z68 extreme 4
SSD: Crucial M4 128GB

OS: Windows 7 Ultimate x64

experiencing the following problem:

Computer restarts -> launches into startup repair -> startup repair fails -> cannot boot into operating system (stuck in an infinite startup repair loop)

Solution:

Enter command prompt in the recovery environment and use:

bootrec /fixmbr


= enables me to boot into my operating system again

My problem:


The "mbr" data is frequently becoming corrupt and stopping me from being able to boot into my OS until I rebuild it. In addition, all events that take place during the power cycle beforehand are lost next time I am able to boot into the OS. This means any programs installed/adjustments to firefox favourites or profile settings in applications are seemingly being reset to an older state.

Does this sound like an SSD issue? From extensive research I am yet to find any solid evidence on what can cause this problem. It has been suggested that the motherboard/RAM/PSU can also cause data corruption. I would like to narrow it down to either the motherboard or the SSD as I have already tested the RAM and PSU in a stable system. I can isolate between the SSD and mobo by installing Windows to another HDD and seeing if the problem still exists.

Sadly, I do not know how to replicate the problem. It has occured five times while I was not at the computer/computer was idle. This is frustrating because I have been using the computer for 90% of the time it has been on, but I am yet to actually see it restart-->go into startup repair. For this reason I am reluctant to test between the motherboard and SSD as it could take a long time to replicate the problem.

1) Do you think I have enough evidence to suggest the SSD is the culprit?

2) Has anyone else experienced similar issues before with regards to data loss/mbr corruption?

3) Anything else I should look into? Viruses/bad drivers/BIOS?

4) For reference, I have tried formatting/reinstalling windows to no avail and the disk I am using to install Windows 7 works fine on other machines
July 8, 2011 6:49:07 PM

To eliminate the Crucial M4 128GB SSD from the equation I have installed my OS on a spare 1TB HDD.

If I do not continue to experience the symptoms:

I can be sure that my Crucial M4 SSD arrived faulty

If I continue to experience the symptoms:

I will assume my motherboard is faulty
July 8, 2011 9:08:42 PM

Happened to me 3 times in 3 months, on my M4 64GB. I know its the SSD. I cant find a solution.
Related resources
July 8, 2011 11:42:32 PM

Quote:
Use the same port and cable. If it fails with the hard drive, replace the cable. If it doesn't fail it could still be the cable isn;t high enough quality for 6 Gb/s


I wanted to but I wasn't sure whether I could use the Intel 6gbps SATA controller and 6gbps SATA cable with the normal 1TB SATA II drive. Honestly if it turns out to be the cable or the motherboard controller I have not accounted for it. EDIT: Actually... I can try running my SSD OS installation off Intel SATA3 connector SATA3_0 instead of Intel SATA3 connector SATA3_1 and use a different SATAIII cable. Is this worth doing? If it survives a full day in this state then yes, I am probably looking at a dodgey SATA controller or cable.

I have had the 1TB SATA II HDD running all day (with a different cable/port), it has been idle for most of the day and the mbr/data corruption has not occurred. It would have more than likely happened by now if I were running the SSD. I'm feeling pretty confident I got a dud SSD.

chaosgs said:
Happened to me 3 times in 3 months, on my M4 64GB. I know its the SSD. I cant find a solution.


I have been searching all over the net for another case. Seemingly, noone else had experienced frequent mbr corruption on the crucial M4 ssd. May I ask you a few questions;

1) relative to the corrupt mbr did you experience any data loss on your SSD? (reverting to the state from a previous power cycle as if no data had been saved)

2) were the mbr corruptions resolved automatically? Mine are unable to be repaired without using the bootrec /fixmbr command.

3) Did the computer crash/restart and then fail to boot into OS or did the data get corrupted after a normal restart/shutdown?

Your answers will mean a lot to me. Also, I would recommend you go about getting your SSD replaced rather than trying to resolve the problem. I have looked everywhere to no avail. I only find "how to repair corrupt mbr" tutorials which are useless to me, there does not appear to be a definative solution to stopping frequent mbr corruption, it must be a deep hardware problem.
July 11, 2011 5:58:38 PM

I set up the return this morning and it is being picked up tomorrow. According to the support member it will take 3-5 working days which isn't too bad. I have noticed the Crucial M4 has an optional firmware update which I never tried. After reviewing the firmware spec, I don't think it addresses my problem any way.

I should get a replacement SSD in about a week unless the problem lies with the cable/mobo sata controller, extremely unlikely though.
July 11, 2011 9:50:31 PM

that sucks and I am sorry to hear about your experience, I just ordered a crucial m4 64 GB because of toms hw recommendation, do you think you have a lemon or do you think this problem is consistent?
July 12, 2011 8:45:04 AM

jjb8675309 said:
that sucks and I am sorry to hear about your experience, I just ordered a crucial m4 64 GB because of toms hw recommendation, do you think you have a lemon or do you think this problem is consistent?


I wouldn't worry about it at all :)  I searched far and wide for more cases of defective M4's/solutions and didn't find much. They are new so the web isn't going to be crawling with content with regards to them, but they are clearly reliable SSD's. I will report back whether the drive was defective or not, if it turns out to be fine then I will have to look into my motherboards SATA controller/cable although my other HDD's are operating fine so it is unlikely.
July 12, 2011 2:33:04 PM

yeah.... okay thanks for the reply
July 14, 2011 8:39:01 PM

UPDATE: the Crucial M4 128GB SSD drive has been confirmed faulty and I am getting a replacement.
July 14, 2011 9:30:20 PM

good, I just got my 64gb and have loaded my os and apps on it and I must say that it is lightning fast, however my steam games will go on a wd caviar black sata 6 gps 500gb hdd, there are just too many games that I want to install and I don't feel like dealing with work arounds
December 5, 2011 9:12:51 AM

I had and am having similar problems to you.

1. I bought the M225 which got corrupted, soon as the drive got to 80% full it dissapeard from bios and windows visibility in any and all prolonged read/writes.

2. Got that replaced by an M4 256GB, thank you Crucial.

3. Now finding after about a 3 or 4 days, the drive stops to boot but is being detected by bios after a lengthy IDE check. NON SYSTEM DISK.

4. Boot up with SATA Backup windows / ubuntu dual boot drive, I can read and write to the SSD but it's apparently not a bootable drive anymore! Ubuntu confirms it as healthy.

5. Windows Repair disk, repair run, says nothings wrong with it.


As before I tried:
1. Power down process (dumb as F**** this is if you ask me, you shouldn't release a product that needs to sort itself out with such techniques to the commercial sector)

2. Format and re-install of windows 7 x64 (same fault occured 4 days later)

3. Tried drive on different sata cables and ports, 6 and 3GB - same issues (done all this before with the M225).

4. Tried various different settings in bios, no joy. Last time it did this I Disable fast boot and it booted... No joy this time as it's already on that lol.


Conclusion
I am now forced to go back to my SATA, I cannot rely on SSD technology for work, it's just too unstable... It shall be formatted, I will do stress test and cram it to 100% full and see if it still remains visible to windows & bios and if not it had the same problem as my M225 SSD which they replaced with this... Did Crucial send me someone else's RMA'd drive? If they don't find anything wrong with this one, it's going to be one hell of an expensive glorified portable USB key!

SSD technology is unstable... Don't go there... Go raid 0? with two high speed SATAs, you will have a longer run at using your computer without having to resort to new installations of windows and working through backups etc.
February 13, 2012 1:44:30 PM

Hi every one,
I had similar problem with an 64GB Kingston.
It corrupts the MBR every shutdown.

I figured out it is happening every time the size of the file system becomes larger than 80%

So I keep it low, no warranty :( 
BB
February 28, 2012 10:10:27 PM

jjb8675309 said:
neweggs got a smoking deal on an ocz 120gb drive today, just sayin:

http://www.newegg.com/Special/ShellShocker.aspx?cm_sp=S...

I would have bought this if I didn't already have a crucial m4 64 gb which I have never had a single problem with



so i was the ssd ??? file corruption coz i been having same problem but i have a velocirapton wester digital and and every time I turn my pc I mark disk failure

need help do u think is my hard drive intel i 7 @ 3.2 ghz azuz x 58 mother b 24 gb ddr 3 G card envidia GTX 570
my email is
!