Sign-in / Sign-up
Your question

The File is write-protected. Remove the write-protection. Hwo do i do this ??

Tags:
  • Hard Drives
  • Computer
  • Write Protection
  • Storage
Last response: in Storage
Anonymous
a b G Storage
July 9, 2011 10:26:49 PM

Hi

Im trying to move a file from one computer to another but it is saying that the file is wirte-protected !!

How do i remove this !

More about : file write protected remove write protection hwo

July 9, 2011 11:23:19 PM

Hi, It depends on the type of file you are trying to move. However, usually I find that it's a .dll file from a program I'm deleting that I have this problem with.
If this is YOUR case ... I am presuming that you do have your folders set so you can see file extensions i.e. their last name so to speak. If not...,
A: open control panel
B: open Folder Options
C: Click on the View Tab
D: Scroll down till you find the line "Hide extensions for known file types"
E: UNCHECK this box.

If you can see extensions skip the previous section. Going on...

I get around the system by:
1. Change the .dll extension to something else like .bak
2. reboot the system
3. Move the file (or in my case delete the file) to it's new system.
4. Your case ... change the .bak extension back to it's original .dll extension. (or whatever it really is in YOUR case)
5. Reboot your other system with the newly installed file.
6. Test the program with the file. (Hopefully it did not need to be registered in the Registry.)
7. DONE.

Hope this helps.
--Archer42
a b G Storage
July 9, 2011 11:25:09 PM

Make sure that the file is not been accessed by a process or a program which is effectively locking the file. Also right click on the file and check the permissions on the Security Tab. Make sure that the permissions are set to full permissions so that you can access and modify the file.
Related resources
July 9, 2011 11:42:08 PM

One other thing... As may be obvious, I'm using Windows XP. You did not state which O/S you are using so, your mileage may be different may different.
July 9, 2011 11:47:01 PM

Wamphryi said:
Make sure that the file is not been accessed by a process or a program which is effectively locking the file. Also right click on the file and check the permissions on the Security Tab. Make sure that the permissions are set to full permissions so that you can access and modify the file.


You're absolutely correct. These are the first steps someone should take to try and move a "locked" file. However, I've frequently found when I've tried all this and I'm using Admin rights on my system - Windows just won't give up the file. That's when I resort to my system run-around.