Sign in with
Sign up | Sign in
Your question

How do I auto-disable the external speakers when the headphones are pl

Last response: in Systems
Share
September 13, 2009 1:50:18 PM

HARDWARE, COMPONENTS AND SOFTWARE:

Processor: AMD Phenom II X3 710
Revision: C2 Stepping
Speed: 2.6 Ghz
Socket AM2
Supported Voltage 1.5 v
External Clock 200 MHz
Max Speed 3700 MHz
Current Speed 2600 MHz
http://www.newegg.com/Product/Product.aspx?Item=N82E168...

Motherboard Manufacturer: ASUSTeK Computer INC.
Product Name: M3N72-D
Version: 1.XX
http://reviews.cnet.com/motherboards/asus-m3n72-d-mothe...

Power Supply: Antec Basiq BP500U 500W Continuous Power ATX12V Version 2.01 Active PFC Power Supply
http://www.newegg.com/Product/Product.aspx?Item=N82E168...

BIOS
Vendor: Phoenix Technologies, LTD
BIOS Version: ASUS M3N72-D ACPI BIOS Revision 0603
BIOS Release Date: 12/09/2008
BIOS ROM Size: 1024 KBytes

RAM: 4 GB (XP reports only 3.5 GB but I read that this misreporting is expected for 32 bit machines)
Socket Designation DIMM_A1
Current Speed 800 MHz
Memory Type DDR2

Front Media Panel: Silverstone FP-34
http://www.silverstonetek.com/products/p_contents.php?p...

Vantec SATA/IDE to USB 2.0 Adapter 2.5"/3.5"/5.25"
http://www.vantecusa.com/front/product/view_detail/266

Windows XP with Service Pack 3

****************************
HISTORY:

The hardware-components listed above were purchased individually and assembled by me in August of 2009 with the help and direct supervision of a friend who works in IT and builds several computers per month.

****************************

The Front Panel headphone jack on the Silverstone FP-34 is plugged into the AAFP jack on the back of the motherboard but the headphones did not play sound when plugged in. The motherboard's manual said to change the BIOS from HD AUDIO to AC97 to get this front-panel-headphone feature to work. (In BIOS Advanced Menu > Onboard Device Configuration> Front Panel Support Type > HD Audio-or-AC97.) Now the headphones play audio through the Silverstone FP-34 front panel jack---but the act of plugging in the headphones does not disable the external speakers.

So I got the headphones to work properly, but how do I auto-disable the external speakers when the headphones are plugged in?
a b B Homebuilt system
September 14, 2009 10:52:55 AM

That is a good question. It looks to me that you should be plugged into the AC97 plug on the mobo, since the audio that your supporting would be a simple AC97 and not the HD Audio, if I'm reading the Silverstone FP-34 ports right:

2 x USB A, 1 x USB Mini 5pin, 1 x 1394 6pin, 1 x 1394 4pin, 1 x audio (Azalia), 1 x MIC (Azalia)

This would explain you not having any sound at first, since you were plugged into the HD Audio pins and not the AC97 pins. Now I'm not 100% sure if you were plugged into the front panel that the external speakers would auto shut off. If you plug in your cable into the AC97 port on the mother and try it out, does it work correctly??
m
0
l
September 14, 2009 12:54:46 PM

You have to shut them off manually.
m
0
l
October 13, 2009 6:29:05 PM

I'm pretty sure that if you plugged in the HD audio plug, you should set the BIOS to HD audio, rather than AC'97. I gather from what I've read that the automatic disable of rear speakers is part of the HD specification, not AC'97. Since both your motherboard and front panel connections are HD compliant, I would double check that you actually plugged in the HD connector. Otherwise, I'm surprised that the front connections did not work while the BIOS was set to HD.

A better question would be: "Why does ASUS put the "FRONT PANEL" audio connector at the rearmost bottommost point of the motherboard?!?!"
m
0
l
Related resources
!