Sign in with
Sign up | Sign in
Your question

MSI 790FX-GD70 CPU Fan Not Turning On, case power buttong won't work

Last response: in Motherboards
Share
March 2, 2010 6:22:10 PM

I just got my MSI 790FX-GD70 this morning and I started installing it. (I'm using a stock clock Phenom II 965 BE) Stupidly, for some reason I forgot to put in the RAM (dumb, I know) before I started the computer. I plugged in all of my case cables (I have a Cosmos 1000). For some reason the power button wasn't working so I used the power button located on the motherboard. As soon as I turned on the computer one of the modules above the RAM slots caught on fire and burned out. The module was near a conductor labeled "SIM3". As soon as the module caught fire I turned off the computer via the PSU switch. I put in the RAM and tried again. The computer turned on but the CPU fan won't spin up. Sometimes it will give a feeble attempt to spin when I turn on the machine but to no avail. The CPU Fan power cable is plugged in. The computer will boot into Windows 7 but I most certainly do not want to leave it on without a CPU Fan. That burnt module is probably interrupting the power flow to the CPU Fan...

I then removed the new mobo and put in my previous mobo and previous RAM (Gigabyte MA785G-UD3H and 8GB DDR2 RAM) (which was working great just this morning) and tried to turn the computer on. Everything is plugged in but the power button isn't working, hence I cannot turn on the computer. The power button case cable is plugged in to the right spot. Why isn't this working? It was working just this morning.

Any ideas on either of my problems?

Thanks!
a c 111 V Motherboard
March 2, 2010 7:15:08 PM

Hmmm... this is new. First time for everything, I gues...

In my experience, the circuits will ignite if there is a ground problem. For example, if the three-pin connector is only connected to two pin, leaving the third exposed, the circuit would be incomplete but still have enough power to turn on. When this happens, the circuit tries to find a ground to close the loop on the circuit. Since the wire wasn't grounded, the circuit became overloaded, thus causing an "open circuit".

How this applies to your situation is that you may have had an open circuit in the board prior to installing. As for the power switch... are certain that the switch is the problem?

Pull the power switch wires off. Jump the two pins with a flathead screwdriver. If the board powers up, yes the switch is likely dead. If not, you may have a short.

If you have a short, try doing a breadboard build. This is when you pull the motherboard out, place it on a piece of cardboard (or any non-conductive surface), and then reconnect things one by one, starting with just CPU, PSU, and Power switch.

If this powers up the board, then you should hear a long beep, followed by several short beeps. This will indicate your board is attempting to POST, but cannot detect RAM (because its not installed).

From this point, add the RAM, one module at a time. If all modules work, then proceed to connect other hardware, one at a time, to rule out any faults with them.

If you get to the point where everything is connected and working while out of the case, then you have a short somewhere in the case, usually the brass standoffs (too many or too loose).
m
0
l
March 3, 2010 8:03:44 PM

Thanks for the suggestions, T_T!
I just caved and bought another mobo. I'm happy to say that this one did NOT catch on fire when I started it. I just did a bench startup with only the ATX, 8-pin, and CPU fan cables plugged in and it turned out without any smoke. I'll probably call Amazon tomorrow and return the other one.
I'm still trying to find a way to secure-erase my SSD. The BIOS program won't seem to boot...
And the power button still doesn't work but I'll fix that later. I rarely turn off my computer -- I just put it to sleep. And it can be woken up with the click of a mouse.
m
0
l
Related resources
!