Sign in with
Sign up | Sign in
Your question

Auto detect of DDR3 wrong

Last response: in Memory
Share
March 3, 2010 9:44:14 PM

The issue: I am getting random but frequent stutters and freezes on my new system. It just locks up for no reason. I came across a threas where it was mentioned that the auto-detect of the ram is often inaccurate and the Bios sets it wrong. I suspect this might be the case. I am VERY shy of going into the Bios and changing latencies, etc.. But I went in there an the numbers do not match up with the DDR3 specs I have. Here is my system:
Motherboard: Gigabyte P55-UD4P/
CPU: i5 750 2.66 /
PSU: Corsair 850
RAM: Corsair 2 x DDR3-1600 XMS3-12800C7-XM / (CMX4GX3M2A1600C7)
Timing: 7-8-7-20 2T
Voltage: 1.65
Command Rate (CR): 2T

This is what is presently set in my Bios:
Extreme Memory Profile (XMP) [Disabled]
System memory Multiplyer: [Auto]
Memory Frequency: 1333
Performance Enhancement: [Turbo]
Dram Timing selectable; [Auto]
Profile DDR Voltage: 1.5v
Profile QPI voltage: 1.1v
Channel Interleaving: 6 Auto
Rank Interleaving 4 Auto
Timing Settings: 9-9-9-24

This is the info. from CPU-Z:
DRAM Frequency: 666.2 Mhz
Timing settings: 9-9-9-24
Command Rate (CR) iT

So... my question is: what should I change in my Bios, and what should I leave alone! Really would apreciate some help in avoiding my system that is less than 1 week old.

More about : auto detect ddr3 wrong

March 3, 2010 9:49:42 PM

You should change your bios.
If you are going to pay extra for performance, no reason to not see it materialize :) 

Just make sure that you set ALL of the settings correctly to match the RAM (including Voltage!).

If you have any worries about stability, you can always run memtest to double check the stability of your system.
a b } Memory
March 3, 2010 9:50:39 PM

CPU-z reports it at half the actual speed so it is currently at 1333 like your BIOS says - to go any higher it must be set in the BIOS (DDR3 will default to 1333 speed on most MOBOs since that is the spec. any higher speeds are considered Overclocked and will need to be set using the various BIOS options
Related resources
March 3, 2010 9:51:56 PM

What concerns me is the difference in timing, command rate and voltage..they are significantly off....
a b } Memory
March 3, 2010 9:58:43 PM

This is what is presently set in my Bios:
Extreme Memory Profile (XMP) [Disabled]
System memory Multiplyer: [Auto] = change to Manual
Memory Frequency: 1333 = change to 1600
Performance Enhancement: [Turbo]
Dram Timing selectable; [Auto] = change to Manual
Profile DDR Voltage: 1.5v = change to 1.65v
Profile QPI voltage: 1.1v
Channel Interleaving: 6 Auto
Rank Interleaving 4 Auto
Timing Settings: 9-9-9-24 = change to 7-8-7-20
March 3, 2010 10:04:46 PM

enable the smp profile.

the bios will auto detect the memory at JEDEC standards. 1333mhz a JEDEC standard memory speed. anything else is considered "overclocked" and will not be auto-detected. it must be either set manually or set with the XMP
a b } Memory
March 3, 2010 10:11:26 PM

1. Set all BIOS values to "Default", save settings
2. Set DRAM timings to 7-8-7-20
3. Decide whether you are overclocking memory or overclocking entire system

A. Overclock memory

1. Set me multiplier to 12 and 12 x 1333 = 1600 and your done, CPU speed = 2.66 Ghz

B. Overclock system

1. Set BCLK to 160 and mem multiplier to 10, and 10 x 160 = 1600 mem speed, CPU speed now = 3.2 GHz

and if your CPU and your OC skills can manage.....usual OC'ers goal is

2. Set BCLK to 200 and mem multiplier to 8, and 8 x 200 = 1600 mem speed, CPU speed now = 4.0 GHz
March 4, 2010 10:07:06 AM

Well, took your advice pinapleX/JacknalorPE and made the adjustments you suggested. However, when it came to changing the mutliplyer, it doesn't allow me to go to manual and change it to anything I want: I am restricted to 6, 8 or 10. Went with 10. Was able to change the timing, Command rate and voltage. This is what CPU-Z is reporting:
DRAM Frequency: 533.0Mhz
FSB:D RAM: 2:8
Timing: 7-8-7-20
Command Rate: 2T

I'll see if it remains stable. if the original problem of the system stuttering or freezing up occurs again.. I will have to assume the source of the problem is not the ram and move on to other suspects.. (But where to begin??) Lol
a b } Memory
March 4, 2010 8:54:24 PM

Usual options if I recall correctly are 6,8,10, 12 and 14

5333.33 x 2 = 1066.67 so you at stock
March 4, 2010 8:56:53 PM

My Bios seems to only offer 6-8-10
!