Sign in with
Sign up | Sign in
Your question

Windows NT Disk administrator has corrupted my stripe set. (RAID 0)

Last response: in Storage
Share
July 14, 2011 12:12:52 AM

Hello,Windows NT Disk administrator has corrupted my stripe set. (RAID 0) I have an eight disk SCSI array with WinNT 4.0 workstation that has an IDE Extended primary partition with two more logical partions and the array. trouble started when I tried to add an internal SCSI drive to speed up disk transfer and tried to get DA to recognise it. DA returned the following errors:

"Disk Administrator encountered an unknown error while making the requested changes. Some of the requested actions may not have occurred."

And
"An error occured while updating disk configuration. Drive letter and fault tolerance information may be lost and / or some partitions may be inaccessible."

This happened to the system after I tried to commit the changes in DA. Now when DA is run the stripe set comes up as C:, even though the primary partition is still there as C: also.

Windows reports the stripe set to be 2GB, which is the size of the primary partition. The stripe set is supposed to be 540 GB. I have tried using software to reclaim the files but they all come back unuseable even though I think I used the correct stripe block size (64K). DA also only sees seven of the eight disks in the array.

I am wedded to NT because of the video programmes I am using.

I am at my wits end. I haven't written anything to the drive array. Help!
a b G Storage
July 14, 2011 12:25:02 AM

Its good you ahven't written anything yet. What I would do is get at least 1.5TB of good strage (even an external drive will work but will be slow). Take each of the 8 drives in the array and connect them to a regular SCSI port (non-RAID). I would label all of them first in their positions and ports etc.

I normally utilize R-Studio (r-tt.ccom) for recovery, image each of the 8 drives to the good storage. You will then need to receate the strip set in the correct order. A trick I found that can help is to look for BMP files in the file structure larger than the block size of the stripe. These are written out sequentially on disk and give you a visual representation of the stripes. When you have the stripe set in the correct order, you should be able to do a full scan of the array. Recover the files to the new good drive (thats why you need twice the total space).

If your drives on the old array are physically good, you can then recreate the array and migrate the data back. I HIGHLY recommend you doing backups in all situations, but an 8 disk RAID 0 array has 8 times the failure rate of a single disk.


Good luck!
m
0
l
a b G Storage
July 14, 2011 12:29:49 AM

Oh my goodness, running 8 drives in RAID0? I hope you had a good backup. This was destined to happen sooner or later, surprised it wasn't a lot sooner.
m
0
l
Related resources
a b G Storage
July 14, 2011 12:44:57 AM

Yea I would never put anything of value on a RAID 0 without a backup, especially 8 drives. I've successfully recovery stripes up to 6 disks before (12 in RAID 10 unlabeled making matching a total PITA) using the above method.
m
0
l
July 14, 2011 8:02:12 AM

Thanks tokencode, I'll try your *.bmp trick. I've got several *.pg file that are 2Meg and larger. Any suggestions for a WinHex type reader that will work in NT?
m
0
l
a b G Storage
July 14, 2011 9:27:47 AM

no, view them in a photo viewer, think of it as 64k puzzle pieces. I am also not sure if JPGs are squential or not, they utilize compression. I know BMPs work.
m
0
l
July 14, 2011 4:12:42 PM

OK, then, I don't have any *.bmp's . I wonder if simply reinstalling windows NT will restore the MBR. I guess its like reprinting a page out of an inkjet with paper you've used before, only this time the same image being printed is already on the paper. Sometimes your lucky, sometimes your not. I still await your recommendation for a WinHex type editor that will work in NT....
m
0
l
July 14, 2011 4:34:00 PM

Oh, I get it now...Use the photo viewer to see if the file comes out okay or not, and vary the block depth until it does. But I already did that. They always come out striped. I use a program called File Scavenger. Using the 64K block size, I can see most of the directory tree intact, with a few unknown folders so something is still wrong. I have also run the block size gamut from 2K to 2Meg; the 64K block size is the only block size where I can see anything. The program has stipulated that the offset is 63. When I view the *.jpg's I can only see 1/6 of the picture full colour, the rest is stripes of yellow, blue and green, i.e. top of image full colour, the next one sixth green, the next one sixth yellow, etc. I have R-Studio as well but I can only use it over the network as the program needs a more current library set from NT . The program has a data blocks per parity group setting as well that I am now experimenting with, but I'm pretty far advanced in the permutations for this setting and it hasn't made a difference so far, I think because RAID 0 has now parity. I'm just looking under every stone. Any more suggestions?
m
0
l
July 14, 2011 8:18:16 PM

After four days of frustration, I finall found out what I was doing wrong. Because of the addition of the new internal SCSI, the drive ID's shifted down by 1. So I included the new SCSI in the chain while it was being scanned and left out the last real drive in the chain. So that's why the files seemed fubar. all is right now, I just need to know how to get the SCSI drive (internal) to be recognized by NT to so I can do the transfer, and I'm set. Thanks to all who chimed in!
m
0
l
!