Sign in with
Sign up | Sign in
Your question

Sapphire 4850 x2 3rd and 4th monitor

Last response: in Graphics & Displays
Share
October 2, 2009 1:26:15 PM

Okay, I have a Sapphire 4850 x2 and the 1st and 2nd monitor work fine, but I am struggling to get the 3rd and 4th monitor to work. It was working fine the last week with all 4 monitors, but last night after playing a game, shut down the computer, and booted it up - i cant figure out why my 3rd and 4th monitor arent lighting up.

They are showing like there is no signal (yellow light). All monitors work fine.


I had problems getting the 3rd and 4th one running in vista, but when I went to windows 7 worked fine without drivers installed. Now a few weeks later, not working.

I dont care to install the drivers yet as I dont think it is the issue since it was working earlier, but it almost seems as if the monitors arent being detected.

Any ideas or advice?

Thanks

======
Running
Saphire 4850 x2 (2gig) no overclocking or anything like that
Windows 7 64 bit
12 Gigs ram 1033
850 Watt Cosair Power Supply
Core i7 2.66
Asus pt6 Deluxe 2
October 2, 2009 2:48:18 PM

Okay i found the solution incase anyone needs it:

You need to DOWNGRADE the ATI software (for me i had to download it since i didnt have it originally) and get the

ati drivers to 9-5_vista64_win7_64_dd_ccc_wdm_enu

NOT THE 9.7xxx whatever. So get that one.

After that you got to CROSSFIRE Tab at the bottom and DISABLE it. I guess with crossfire on this card you can only run 2 monitors.

Somehow vista / windows 7 only picked up my 2 monitors with this enabled and I guess its default is enabled. So to do 3 or 4 monitors DISABLE the cross fire and it should pick it up no problems.

Now you can have your 3 or 4 monitors.

m
0
l
!