Marking a drive as non-hotswap device

I am using HotSwap!.exe Version 5.0.0.0 to dismount my external esata drive, this works very well, however in the menu for the drives to disconnect also appears one of my internal drives.

The author, Kazuyuki Nakayama, mention this on his website:

"HotSwap! cannot distinguish the drive whether internal or external from the information available from Windows. If you don't want the drive to appear in the drive listing menu, you can do so by marking the drive as non-hotswap device."

but does not say how to do that, and this is my question:

How do I mark my internal drive non-hotswhap?

System is Asus P5B Deluxe, Jmicron JBM363 controller for external drives
ICH8R for internal drives

Thank you.
5 answers Last reply
More about marking drive hotswap device
  1. I've never used a program called hot swap, but if your drive controller is set to IDE mode, all drives will lose their hotswap capabilities.
  2. All my drives are set to IDE on both controllers, I try using AHCI on the Jmicron and still it does not work.
  3. I'm not sure how that hotswap program works then. Hot swap must be enabled for both the drive and the controller for hotswap to work. Most sata drives have the hot swap capability, but can only be accessed via AHCI, not by IDE.
  4. If this is Windows 7 there's a registry setting that you can use to tell the OS whether or not the drive is swappable - it's probable that Hotswap will honour the same setting.

    You can download a word document that describes how to make the registry change from this Microsoft Web Page. Look for the phrase "TreatAsInternalPort" in the document.
  5. Problem solved!

    Thank you all.

    I was able to contact the author, it is quite very simple and built in the software.

    To set an internal drive as non-swap:
    Hold down the [Ctrl] key the icon in the tray and a menu comes up where
    we can choose which drive to mark as non hot-swap.
Ask a new question

Read More

Hard Drives Devices Storage