Sign-in / Sign-up
Your question

Bad Memory or Bad Motherboard?

Tags:
  • Memory
  • DDR2
  • Patriot
Last response: in Memory
March 7, 2010 2:23:13 AM

I bought a Gigabyte EP43-DS3L last summer and originally put in 2x2GB Memory sticks. I used matched Patriot DDR2 1066, 5-5-5-15 (PDCG248500ELKR2) at the default speeds/BIOS configs in Dual Channel mode.

Everything worked just fine. Then I decided I needed 8GB, so I tried to track down another 2 sticks of the same memory. I found the Patriot Viper PV224G8500ELDB at Fry's, which is also DDR2 1066 5-5-5-15. It has a different packaging/heatshield, but I figured it wouldn't be a problem, since it's another Patriot matched set running in another channel, with exactly the same timing & specs.

Because of clearances with my CPU heat sink, I couldn't fit the new memory in slot 4 (the Viper memory has heat sink fins).
So I put the ORIGINAL memory in slots 2 and 4, the NEW memory in slots 1 and 3. The mobo recognized 8GB, but then immediately boot-looped when starting Windows. I suspected bad memory or issues with the (slightly) different memory sticks in each channel, so started troubleshooting.

So I went back to where I started. I took out the NEW memory and put the ORIGINAL memory back in slots 1,3. The machine booted fine. [phew...]
Then I checked the NEW memory in slots 1,3. Again, the machine boots fine with 4GB of the new memory [Curious... both sets of memory worked fine in slots 1,3]

Then, I put the ORIGINAL memory in slots 2,4, with 1,3 empty. The machine boot loops. :fou: 

Basically, any time I have somtthing in channel slots 2,4, it's unstable, even though that same memory works fine in channel slots 1,3.

To troubleshoot a bit more, I ran memtest86+

The original 2 sticks of memory in dual channel mode: [2GB in Slot DDR2_1, 2GB in Slot DDR2_3] Memtest passes 100%

Then I took one stick of memory that passed memtest in dual channel mode and moved it from slot to slot, isolating one 2GB stick in single channel mode.
Slot 1 [2GB in DDR2_1]. Memtest passes 100%
Slot 2 [2GB in DDR2_2] Memtest fails immediately. Within a short time, memtest terminates with an exception.
Slot 3 [2GB in DDR2_3] Memtest passes 100%
Slot 4 [2GB in DDR2_4] Memtest fails, but not as quickly as in slot DDR2_3. after 50% of the tests, there were a handful of errors.

It seems to be an issue with the 2nd and 4th memory slots. Motherboard issue? I have the latest BIOS... running at default BIOS default timing (5-5-5-15, 1.8V).

The two slots I originally populated w/ 4GB work fine. The second pair of slots (2,4) seems to be hosed. Anyone seen this before? What a bummer of a hidden defect.

More about : bad memory bad motherboard

March 7, 2010 9:09:52 PM

I think defect if RAM runs fine on any other slot. Is the mobo still under warrenty?
m
0
l
a c 115 } Memory
March 8, 2010 3:09:52 AM

It sounds like the motherboard:

1) Put the old set in Slots 1,3 and run Memtest for several hours.

2) Remove and try this with the NEW set.

Do they both pass? Then your RAM is fine.

If RAM then fails when using 8GB the problem lies with the Motherboard.

Note:
You can't just use any slot for RAM. Read your motherboard manual. It's likely that for two sticks only Slots 1 and 3 would work. You would EXPECT to get a boot failure if using 2 and 4 only.

If you use one stick only then it's likely only one slot will be reliable. Again, read your manual.
m
0
l
Related resources
a b } Memory
March 8, 2010 3:38:31 AM

I think that the motherboard is fine, mixing different brands of memory particularly when you have four sticks is a bad idea.
m
0
l
March 8, 2010 6:45:30 PM

I have 2 Samsung OEMs on slot 1, 3, Avant on 2 and Kinston on 4.
If slot 2 and 4 don't work for any reason it should be explained in manual. But it isn't. So RMA.
m
0
l
March 8, 2010 7:31:27 PM

Sounds like slots 2 and/or 4 are bad on the motherboard. I've seen that before..one or two slots are bad, but the others work fine.
m
0
l
March 8, 2010 8:18:28 PM

Manual says 1,3 or 2,4 are both valid dual channel memory configurations. Anything else is a valid single channel configuration, so it's looking like an RMA situation with 2, 4 not working. It's a Gigabyte motherboard, I've put in the request & I'll report back what they say.
m
0
l
March 9, 2010 12:52:38 AM

Well, good luck, we had a post yesterday at the forum about one person going through three techs and a week before the board was RMA'd, if I can recall it had something to do with a graphics card running at x8 PCI-e lanes with usb3 and other SATA ports disabled on a Gagabyte P55 board.
m
0
l