Sign in with
Sign up | Sign in
Your question

Seagate IDE hard drive not detected

Last response: in Storage
Share
July 18, 2011 2:55:28 PM

Hi there,

I wonder if anyone can give me a little advice on the direction I need to take to see if I can fix this problem.

Friends Old Dell Dimension T500 had a 2nd slave 400GB Seagate 7200.8 Model ST3400832A hard drive logically partitioned into 4 equal 100Gb drives.

Was working fine for years then he rang me to say he turned PC on one day and said it would not boot - he was getting "invalid Diskette in A, insert valid disc" or something to that effect.
So I talk him through removing the cables for the floppy drive thinking that it was a problem with this and he reboots and know the PC boots fine. However he mentioned the 2nd drive is now missing when he tries to browse to it. (it seems he unplugged the ribbon cable from the 2nd hard drive as well.

So I got a hold of it and did some testing:

- tried different jumper settings, checked bios etc - bios is not detecting 2nd drive
- moved it to another PC as a slave - not detected either
- used different cables, set it up as primary on its own in another PC - not detected at all by bios
- downloaded seatools and booted that from cd - does not detect the drive
- tried it in an external USB caddy - PC detects there is a USB drive connected but cannot see a drive to browse

The drive seems to be mechanically sound - it spins up and sounds fine.

I have done some research and read about the so called Seagate BSY state - the fix being making a serial cable up and consoling onto the drive and running aload of commands to unflag this busy state but this only appears to affect 7200.11 SATA drives as far as I can see from the many posts out there. It also involves buying parts and soldering stuff and doesnt sound trivial

I have also read that maybe replacing the PCB board might help - but again this involves buying additional parts etc.

I have an arsenal of bootable ISOs which I will try later to see if I can see the drive with any of them (Ubuntu, Knopping, Ultimate Boot CD etc)..

However I would be interested if anyone here has any suggestions on anything else that I could try that might allow recovery of the data? :) 

Thanks in advance
July 18, 2011 3:31:47 PM

No, run commands by serial cable that is only way to fix this issues for the home user.
July 18, 2011 8:13:58 PM

Quote:
No, run commands by serial cable that is only way to fix this issues for the home user.


So in other words the drive is in BSY state and I need to follow the instructions on the like of this page?

http://www.msfn.org/board/topic/128807-the-solution-for...

Any page I have found is for SATA drives not IDE and also no mention of my serial number on any of the Seagate sites confirmed as having this firmware BYS flag issue.
Also I dont believe there is any way to confirm for sure if a drive is in a BSY state without going to all the trouble of making up this cable etc

!