No display with ATI Radeon 4670 help needed

Hi, today i built my computer.

IT consists of

450W PSU
4GB RAM
1 Disk drive
120GB Hard drive
ATI Radeon 4670 ICeq edition GPU
Phenom dual core 3 Ghz processor
M4N78-AM Asus Micro ATX motherboard

Here is the problem:


Everything seems to be turning on ok

I am using a dell monitor, however i am currently getting no display image at all when i press the on button.

The fan on the graphics card is working and im getting no bad sounds from the computer.
I have tried using the onboard graphics and im getting the same issue, no display so it cant be the graphics card itself.

I'm out of ideas here, is there something wrong with using a Dell monitor on an Asus motherboard?

i've tried 2 different Dell monitors with no help at all.

It can't be the PSU hasn't got enough power because the onboard graphics wont even give me a display picture.

Please help me solve this issue.
6 answers Last reply
More about display radeon 4670 needed
  1. i can hear it booting up.. i just can't see it happening.
    Although nothing is installed yet since i can't see anything
  2. It still could be a PSU issue. What brand is it? I would try an out of the box, starting with just one stick of memory installed (what brand is it?).
  3. http://www.ebuyer.com/product/136491

    came with that

    not good but its all i need it for.

    surely it would be able to support the onboard graphics anyway, ive taken my card out and tried using onboard but same issue occurs.
  4. really have no idea here, please help :(
  5. Did you try running it with one stick of memory?
  6. I would still be concerned about a PSU that cost only £29.99 including the case.
Ask a new question

Read More

Radeon Graphics Displays