Sign in with
Sign up | Sign in
Your question

Can't play dvd's - AutoPlay isn't available anymore

Last response: in Storage
Share
July 25, 2011 2:52:56 AM

For some unknown reason, I am having trouble playing dvd's on my computer. Before my problems started, I had zero troubles playing a disc. I would pop in the disc, and be able to play/activate the movie one of several ways. For instance, as soon as the disc went in, a pop-up screen would say autoplay - and it would offer a few different ways to play the dvd. Or the other main way, I would click once on the dvd drive just to highlight it, then I would go up to one of the toolbars and click the button "AutoPlay", which would open up a drop-down list and I would select what player I wanted to use.
Here's a screen-cap, showing the AutoPlay button as missing:




Well, none of that is working now. Now when I insert a disc, Windows doesn't give me anyway to play the movie. There's no more pop-ups, and the AutoPlay button is just not available. The only buttons that toolbar offers me -
Organize
Eject
Burn to disc
Properties
System Properties
etc...

Where the word "Eject" appears, is where the AutoPlay button always used to be. I also tried right clicking on the dvd drive to bring up the Context Menu, even that doesn't help - because I used to be able to right click and choose the option "Open With", but now thats gone too.

I know the dvd drive works, because I can still play dvd's if I go into Windows Media Player and play the movie thru that backdoor way.

I don't know exactly what caused this problem, but I have a few general ideas. Over the past 5 days I been adjusting my RAM timing & voltage settings. I also just did a successfull Update of my BIOS, and installed the most current version of the BIOS - and that flashing went well with no problems.

I checked my dvd Drives drivers, and they are all up to date. I believe this might be a Registry problem but have no idea where to start.



Here are my computer specifications:

CPU: Intel Core i7-920 2.66 GHz 8M L3 Cache LGA1366

HDD: WD 750GB SATA-II 3.0Gb/s 16MB Cache 7200RPM HDD

HDD2: Hitachi 2TB Serial ATA Hard Drive - 7200RPM, 64MB, SATA-6G

MOTHERBOARD: EVGA X58 3X SLI LE (141-BL-E757-TR)

RAM: G.SKILL Ripjaws Series 12GB (3 x 4GB) DDR3 1600 (PC3 12800) Desktop Memory Model F3-12800CL9T-12GBRL

GPU: NVIDIA GeForce GTS 250 1GB 16X PCI Express

PSU: 1000 Watts Power Supply (Xion SuperNova AXP-10000R14HE)

CASE: Thermaltake Spedo Full Tower Case

CASE FAN: Maximum Enemax 120MM Case Cooling Fans
*(500-1,200 RPM White Color with White LED Twister Bearing 8-14 dBA)
**Asetek LCLC 240 Liquid Cooling system w/ 240MM Radiator and Dual Fans

OS: Microsoft Windows 7 Home Premium (64-bit Edition)
July 25, 2011 3:24:56 AM




I forgot to mention that I've already done all of that. That's one of the first things I tried - going into Control Panel and opening the AutoPlay section.

I've got the "Use AutoPlay for all media and devices" box selected with a check mark and for all of the other options, I have set "Ask me everytime"

So, that's not a fix for my problem, thanks though.
m
0
l
!