Sign in with
Sign up | Sign in
Your question

Help pls! Powercolor HD4670

Last response: in Graphics & Displays
Share
October 7, 2009 5:50:43 PM

Hello, i just bought today a new graphic card, Powercolor HD 4670 1GB DDR3, i have before a Radeon 9600pro 126Mb.


My motherboard is a Arock 775V88+.

I uninstaled the drivers and removed my old radeon and connected the powercolor. When i start my computer the monitor does not respond and instead of boot i listen to 5 or 6 bips in sequence, and can't boot my pc.
I currently connect again the radeon to come here ask for help, what's going wrong here, anyone pls?

More about : pls powercolor hd4670

October 7, 2009 5:53:59 PM

Just like to add graphic cards are AGP and not pci-express
October 7, 2009 6:14:04 PM

brelok said:
Hello, i just bought today a new graphic card, Powercolor HD 4670 1GB DDR3, i have before a Radeon 9600pro 126Mb.


My motherboard is a Arock 775V88+.

I uninstaled the drivers and removed my old radeon and connected the powercolor. When i start my computer the monitor does not respond and instead of boot i listen to 5 or 6 bips in sequence, and can't boot my pc.
I currently connect again the radeon to come here ask for help, what's going wrong here, anyone pls?


Beep code :
http://www.bioscentral.com/beepcodes/amibeep.htm

Might help you. Might be a defect Video card, not inserted ok in the AGP port...
Related resources
October 8, 2009 12:09:49 AM

About the BIPS i get in begining i will descrive the best i can:

One long beep that can also be 2 short beeps with 1/4 second difference, a sequence of 8 short beeps with half a second between them, then after 1 second another short beep.
October 8, 2009 11:31:09 AM

brelok said:
About the BIPS i get in begining i will descrive the best i can:

One long beep that can also be 2 short beeps with 1/4 second difference, a sequence of 8 short beeps with half a second between them, then after 1 second another short beep.


Display memory read/write error The system video adapter is missing or defective

As it is working with another video card... I can only assume that the one beeping is defective. Bring it back to the store, its still under warenty I hope ;) 
!