Sign in with
Sign up | Sign in
Your question
Closed

AMD C-60; Catalyst Drivers Will Not Install

Last response: in Windows 7
Share
a b $ Windows 7
October 4, 2011 8:44:25 PM

Hey all,

A few days back I picked up an AMD C-60 powered netbook, an ASUS 1015BX to be exact.
As the stock HD is not terribly large, and Windows 7 Starter is quite terrible, the first thing I did was stick 4GB RAM into it, swap the HD and install Windows 7 Home Premium 64-Bit.

Now, the issue I am having is that the video drivers will not install properly.
When attempting to install the AMD official driver packages the 'Vision Engine Control Center' is installed but it only lists information on the CPU.
The driver listed on ASUS' support site (x86 only, like most of their drivers for this netbook :fou:  ) does install CCC but it can not be opened.

With all attempted driver installations the Device Manager lists the GPU as a 'Standard VGA Display Adapter'.
Additionally, I was sure to update Windows to SP1 before installing any drivers (as required with 11.9).

So far I have tried reinstalling Windows 64-Bit, then Windows 32-Bit and trying driver versions 11.9-11.5 along with the ASUS supplied driver on the 32-Bit install.
At no time has the driver been accepted, although I am sure the hardware is working as the drivers on the original instillation where.

So, does anyone have any ideas on how I could solve this?
With the AMD C and E series being so popular now, and me not being the only one with This Issue, I am sure someone here has encountered and solved this issue.
Maybe it would be possible to take the driver straight out of the stock instillation (I have not yet formatted the disk)?

Thanks in advance,
outlw
a b $ Windows 7
October 4, 2011 8:53:38 PM

As a further note, I have also attempted to use the AMD Driver Downloader utility.
It gives me the following error: '2|We where unable to find your product or OS' :/ 
Score
0
Related resources
a b $ Windows 7
October 4, 2011 9:20:29 PM

Well, I feel stupid for not trying the mobile driver package in the first place [:bohleyk:7]
Unfortunately though, it does not work either.
I get this for an error:

Quote:
AMD Catalyst Mobility kann aufgrund von
inkompatibler Hardware/Software auf Ihrem
Computer nicht heruntergeladen werden.

Ihr Computer enthält keinen passenden
Grafikadapter


Roughly translated, the util can not find any compatible hardware and there are no compatible graphics cards installed.
Score
0
a b \ Driver
a c 329 À AMD
a c 395 $ Windows 7
October 4, 2011 9:21:46 PM

Have you uninstalled all the old drivers?That should be the right driver package!
Score
0
a b \ Driver
a c 329 À AMD
a c 395 $ Windows 7
October 4, 2011 9:23:37 PM

Will it install thru the device manager?
Score
0
a b $ Windows 7
October 4, 2011 9:28:48 PM

Chainzsaw said:
Have you tried using this?

http://support.amd.com/us/gpudownload/Pages/index.aspx

Try the Auto detect in the drop down menu.

Under step 1 select notebook graphics. I notice it only lists the c40 and c50 but the auto might find it.

Yeah, that links to the AMD Driver Downloader utility.
Tried it and it could not detect any comparable hardware.
SR-71 Blackbird said:
Have you uninstalled all the old drivers?That should be the right driver package!

Yes, all drivers where fully uninstalled.
Between instillation attempts I run the Catalyst Uninstaller which supposedly removes everything AMD from the system (driverwise).

AFAIK, the C-60 with its 6290 should be supported by the standard packages.
As such, the initial instillation after windows update should have worked in the first place :/ 
Score
0
a b $ Windows 7
October 4, 2011 9:35:30 PM

SR-71 Blackbird said:
Will it install thru the device manager?

Tried that earlier and again just now for the hell of it.
According to Windows:

Quote:
The best driver software for your device is already installed

Windows has determined the driver software for your device is up to date.

Standard VGA Graphics Adapter
Score
0
a b $ Windows 7
October 4, 2011 9:46:20 PM

The next best thing to do would be to contact ASUS directly and ask them if they actually have a driver for that computer / OS.
Score
0
a b $ Windows 7
October 4, 2011 9:50:26 PM

Yeah, they have a driver listed on their x86 support page, unfortunately it does not work either :fou: 

I will give it another day, maybe someone will have a thought or two here.
After that, the ASUS and AMD support pages are my next stops.
Hopefully it is not a hardware defect; I kinda broke the warranty sticker installing the new HD :( 
Score
0
a b $ Windows 7
October 5, 2011 7:34:31 AM

Bumping for the thoughts of the other half of the world :) 
Score
0
a b $ Windows 7
October 5, 2011 1:03:15 PM

How can you break the warranty stick by changing the HDD?

HDD is user serviceable component and doesn't have a sticker. Stickers only on heat pipes in contact with the gpu and cpu so that if you remove heat pipe to access them, it will break.
Score
0
a b $ Windows 7
October 5, 2011 1:27:38 PM

It was the warranty sticker I broke, not a stick :p 

ASUS netbooks are not really designed to have their hard drives swapped.
Unfortunately, durring the teardown, you do have to break a warranty sticker to get inside the enclosure :( 

Well, I guess embedded videos do not want to work for me either....
http://youtu.be/Qrc328tA_BY
Score
0
a b $ Windows 7
October 5, 2011 1:30:30 PM

Oh, ok. So there is a sticker on netbooks. Thanks, that gives me more knowledge on netbooks.
Score
0
October 6, 2011 8:01:14 AM

Hello Everybody,

I ordered an ACER 522 with the same C-60 APU a couple of days ago. It is going to be delivered tomorrow, so I started to collect things I want to install on it - first of all the 4GB RAM and an SSD along with the Win7 Home Premium 64bit... Just like You, I tried to download 64bit drivers, as well, but - just like You I could not find them. Than I had an idea: Acer ships the same base hardware with their 722 Win7 Home Premium 64bit, so I checked if there is any available 64bit driver downloads for the 722. AND YES. There is.

My suggestion is in advance: take a chance on the Acer Aspire One 722 dowload site and download this:

http://global-download.acer.com/GDFiles/Driver/VGA/VGA_...

The downloaded file name is: VGA_AMD_8.861.0.0_W7x86W7x64_A.zip

This means - in my oppinion - that it has no special relation to Acer products in general, just for the AMD C-60...

Possibly working. I have to try it tomorrow anyway... :) 
Score
0
a b $ Windows 7
October 6, 2011 8:19:09 AM

Welcome to the forums!

Thanks for your recommendation.
Unfortunately I already tried that specific driver package, it was posted in another Ontario driver issue Thread, and it also did not function :( 

My advice to you is to hold off on reinstalling your OS until it can be confirmed that the drivers can be properly installed.
I plan to open support tickets with ASUS and AMD after work and will post back the responses here.
Score
0
a b \ Driver
a c 329 À AMD
a c 395 $ Windows 7
October 6, 2011 11:46:30 AM

Keep us informed!
Score
0
October 6, 2011 9:12:39 PM

OK. :hello: 

...But: I know myself. :whistle:  My first step is going to be taking the original hard drive out, put an OCZ Vertex 2 in and starting to play with the new OS - and than we'll see. Possibly it will end up in tears and anger and putting the hard drive back, but what can a hardware junkie do in such situation... :pt1cable: 

But Thank You for Your reply, anyway, and yes: keep us informed.

:hello: 
Score
0
a b $ Windows 7
October 7, 2011 8:12:37 PM

Well, no response yet from ASUS or AMD's tech support.

I did however successfully clone the windows partition from the original drive to then new drive.
As such, I now have factory Windows 7 Starter installed and the GPU drivers are working.

Still no idea why the drivers are not working after reinstalling windows; hopefully I can get a working driver soon :??: 
Score
0
October 7, 2011 9:50:25 PM

Hello again,

Well... Yes. Same results. I installed 32 & 64 bit versions of Win7 Home Premium, tried many ways to install drivers but the result was the same: the video processing unit was not recognized. Now I'm using the original HDD with 4 GB of RAM (of course 2GB seen by Win7 Starter).

It seems we have to admit that actually the C-60 is not fully supported at the moment...

Now I write to Acer if they had any information...

Please, keep us updated...

If I got any news I post it asap... :hello: 
Score
0
October 9, 2011 8:17:39 AM

Problem solved - it seems... :) 

Yesterday I installed on my ACER Aspire One 522 Windows 7 Home Premium 64Bit with Service Pack 1 integrated. Then I installed the VGA Driver from the ACER Aspire One 722 driver site:

http://us.acer.com/ac/en/US/content/drivers

The driver is: VGA_AMD_8.861.0.0_W7x86W7x64_A

Download link: http://global-download.acer.com/GDFiles/Driver/VGA/VGA_...

After reboot the graphics processing unit was working without any problem. Now I'm having correct display resolution, video playback works fine, so everything is on its place.

The driver I mentioned above seemed to be promising earlier, too, because the ACER 722 comes with 64Bit Home Premium from the factory. Probably the missing part was the OS Service Pack...

Anyway: for me it's working perfectly.

I hope You can get closer to the solution, as well.

Good luck!

:hello: 
Score
0
a b $ Windows 7
October 9, 2011 10:26:40 AM

Thanks for the update, I am glad you got it working!

As everything is working since I cloned the factory drive, I think I am going to wait for ASUS/AMD support to reply before reinstalling again.
I will post back once I hear from them!
Score
0
a b $ Windows 7
October 10, 2011 7:48:24 PM

AMD has responded...

Quote:
Response and Service Request History:

Thank you for contacting AMD Global Customer Care. I understand you were trying to install drivers for your C-60 APU. The C-60 is directly integrated onto your motherboard by your system manufacturer. AMD has no specifications regarding how the chip was implemented onto the board. For this reason, AMD does not provide any drivers for any of the C-Series APUs. All drivers for this series will be provided by your system manufacturer. Any number of additional modifications may have been made to the APU itself by the system manufacturer with the implementation of this unit. For this reason, your system manufacturer will provide proprietary drivers specifically for your APU.

If you have any further questions or concerns, please feel free to contact us again at AMD Global Customer Care.

In order to update this service request, please respond, leaving the service request reference intact.

Best regards,

[Removed]

AMD Global Customer Care


So, there are no official AMD drivers for their Ontario APU's :( 

Still waiting for ASUS' response...
Score
0

Best solution

October 10, 2011 9:03:07 PM

Hmmm... That doesn't sound good. :pfff: 

Ok. I made an attempt at the ASUS site. I followed the same way of thinking and checked the 1215BX since this is the bigger brother of Your 1015BX. Similar situation to ACER: the bigger screen gets more RAM and 64Bit OS, namely Win7 Home Premium. On the 1215BX driver download site I have found 2 VGA drivers:

- Graphics Driver For Asus Brazos (WHQL) V8.871 - 161.68 (MBytes) This is the newer one.
- Graphics Driver for WIN 7( V8.792.0.0) - 243.58 (MBytes)

Have You met these drivers before?

Surprisingly there was no VGA driver on the 1015BX download section at all. :ouch:  Strange.

:hello: 
Share
a b $ Windows 7
October 10, 2011 11:21:10 PM

Yes, there are hardly any 64-Bit drivers listed for this netbook :-/

Good idea with using the 1215BX drivers, I will have to give them a try if ASUS support can not help me :) 
Score
0
October 11, 2011 2:18:02 PM

I have an Eee Pc 1015BX with C-60 (Radeon 6290) too and sucessfully installed VGA drivers with Direct3D support even for Windows XP 32 by modifying the .inf file manually. I haven't tried Windows 7 64 yet but I'm sure it will work the same way.
(Now I have XP drivers for all devices of the 1015BX C-60, although ASUS, shame on them, doesn't offer any on their site)

How-to:
Download the Catalyst driver pack and start it then abort it. It will unpack itself to C:\ATI\support\<package_name>
The .inf file can be found at C:\ATI\support\<package_name>\packages\drivers\display\...
Change "DEV_9805" (Radeon HD 6200 series) to "DEV_9807" (Radeon 6290 of the C-60 APU) in the file.
Now you can install the driver via control panel->system->device manager.
Reboot when done.

(CCC - Catalyst Control Center may not be installed with 11-9 Catalyst package -> install manually from "c:\ati\support\<package>\apps\ccc\core-static")
Score
0
a b $ Windows 7
October 11, 2011 2:26:33 PM

Welcome to the forums!

Thanks for the tip, I will defiantly give it a try if ASUS support fails me :) 
I just wish they had working drivers listed in the first place...
Score
0
October 11, 2011 3:11:51 PM

In order to find drivers for the other devices you need to identify your hardware. In the device manager you can see the PCI "VEN" and "DEV" IDs. For some device drivers "SUBSYS" is also important.
I googled for them and got the device names and also found Windows 7 64 bit drivers.


This is what i found out:


AMD Chipset
AMD AHCI Controller (SATA drivers: "http://sites.amd.com/us/game/downloads/Pages/downloads...." not available for Windows XP)
1002:4390

SM-Bus
(included with Catalyst AMD south bridge drivers)
1002:4385

Graphic adapter
Radeon 6290, C-60 APU
(no official graphic driver from AMD/ATI available for C-60 APU)
1002:9807:84E41043

Audio
Realtek ALC269 (driver package "http://dlsvr04.asus.com/pub/ASUS/EeePC/1015B/6373_PG322..." seems fine)
10EC:0269
ATI HDMI Audio (bundled with AMD Catalyst Display Driver)
1002:aa01


Network adapter
Atheros 8152/8158 (Atheros AR8131)
1969:2062 (VEN_1969&DEV_2062&SUBSYS_84681043)
driver: win7-l1c-1.0.0.36-whql.zip

Wireless network adapter:
Azurewave AW-NE785H / Atheros AR9285 Wireless Network Adapter
168c:002b (PCI\VEN_168C&DEV_002B&SUBSYS_10891A3B)
driver: win7-9.2.0.113-whql.zip

TouchPad
Elantech TouchPad (detected as PS/2 device)
(package listed under Win7-32 on ASUS page for 1015BX supports 32&64 bit XP,Vista,7)
driver: ETD8_0_5_3_ps2drv_WHQL.zip

Azurewave Realtek PC Camera (UVC compatible)
13d3:5711
640x480
Image is noisy and FPS is about 5-10 if light is bad (the cam seems to adjust the exposure time automatically)
FPS increases with brighter lighting conditions to 20-30
(I recommend to increase sharpness in the device settings)
driver: realtek_pc_camera_drivers_v6_1_7600_0077_whql.7z (http://files.hlama.net/drivers_update/drv_digital_camer...) -> not really needed, Windows internal drivers work also

Keyboard filter driver
(used for the special FN keys)
Score
0
a b $ Windows 7
October 12, 2011 12:34:49 PM

And ASUS has responded -_-
Quote:
Dear Mr. [outlw],

please do a Systemrecovery, we does not do Support for OS installation which done by your own.

For Recovery please press F9 at the Eeepc Logo, this only works if the Partition still exist, if not you only can send the unit to our Service for reiinstall the OS.

Bitte fügen Sie einer Antwort immer den gesamten Schriftverkehr bei!

Mit freundlichen Grüßen / Best regards

:heink:  Really?
If reinstalling your OS is not supported, why even have a driver support page for this netbook (let alone drivers for other OS')?
I am disappointed in you ASUS :pfff: 

Well, I guess I will try the above suggestions tonight...
Score
0
October 12, 2011 1:10:48 PM

:o  Ohhh!

How kind is that... :D  Don't worry: I bet the 1215BX drivers will work with WIN7 Home Premium SP1. If they were not, get a hammer, give the ASUS a nice treatment, throw it away and by an ACER... :lol:  For the Acer I already know the solution... :sol: 

Let us know about the result...

:hello: 
Score
0
a b $ Windows 7
October 13, 2011 10:31:53 PM

Well, what do you know.
The latest 1215B GPU Drivers actually worked!
Score
0
October 14, 2011 8:13:02 AM

;) 

Oh, Yes!

Now, it's time to throw the hammer away, get a bottle of champagne instead, and enjoy the life... :sol: 

Probably, we should post this info somewhere, where it's more available. I think many other guys-girls could find it useful...

Have fun with the netbook!

Best regards,

Krisztian
Score
0
October 15, 2011 4:35:27 PM

i have the same problem, unfortunately the 1215b drivers didnt work at all for me :( 
Score
0
October 15, 2011 4:46:36 PM

Hello,

So You have an ASUS 1015B with C-60 and HD6290 and You want to upgrade to 64Bit Windows 7?

For us the 64Bit Windows 7 Home Premium SERVICE PACK 1 and the 1215B 64Bit VGA Driver combo was the solution.

There must be something to do with the OS Service Pack. Before I tried to install the proper drivers on 64Bit Win7 Home Premium but that OS did not have the SP1 integrated, and the driver did not work.

Later on, I installed the OS from another disc with SP1 integrated, then tried the 64Bit VGA driver and it is now perfect. Everything works just fine.

It must be O.K... :hello: 
Score
0
October 15, 2011 5:40:36 PM

let me check if the sp1 is already installed, thx for the advice.
Score
0
October 16, 2011 12:01:02 AM

after hours of updating windows, unfortunately the 6290 is still recognized as "standart vga-adapter". I downloaded the ASUS_VGA_V8_792_0 file from the 1215b support and have windows sp1 installed. The OS is Windows 7 Professional x64 btw. Maybe tomorrow i´ll have more luck , gn8 everybody and kudos to everyone who got theirs working, i´ll get there eventually :) 
Score
0
October 16, 2011 6:28:18 AM

I'm afraid You'll need to install HOME PREMIUM 64Bit - WIN7 Professional won't work. Unfortunatelly I don't know why, but these drivers are sticked to this OS. As You could read in the ASUS "support" answer this C-50 or C-60 APU seems to be very sensitive to the factory hardware and software enviroment. Our idea was to recreate this enviroment with WIN7 Home Premium 64Bit and the driver that outlw6669 used for ASUS 1015B...

In my oppinion things should be working the way outlw6669 installed them...

Good luck!

:hello: 
Score
0
a b $ Windows 7
October 16, 2011 10:23:24 AM

ASUS has also updated their 1015BX Windows 7 32-Bit driver page with new GPU drivers.
As most of their drivers are 32-Bit only, and this netbook tops out at 4GB RAM anyways, I would recommend installing Win 7 Pro x32.
As with the above, make sure you have SP1 installed before trying the drivers (or just create a USB installer with a trial version of Windows 7 that includes the SP1 updates).
Score
0
a b $ Windows 7
October 20, 2011 9:39:29 PM

Not yet here.
Since I finally got the drivers working in the first place, I have pretty much left it be.
The next package I plan to try is 11.11, when released.
If that works I will leave further feedback.
Score
0
a b $ Windows 7
November 3, 2011 7:58:56 AM

Best answer selected by outlw6669.
Score
0
a b \ Driver
a b $ Windows 7
November 3, 2011 8:16:35 AM

This topic has been closed by Nikorr.
Score
0
!