GA-EP45-DQ6 Realtek Teaming Utility now for Windows 7

Realtek Teaming Utility exist for Windows 7.
here http://www.megaupload.com/?d=URF2MJWW

i found here http://www.computerforums.org/showthread.php?p=987223, this link provided by gigabyte support


i have 4 NIC Rt8111, build in to GA-EP45-DQ6

using utility create Team

it support:
General Switch Mode
Etherchannel
LACP 802.3ad

i try every one, finnally Realtek Teaming Utility create new local area connection with gray color, it disable. I try to enable it, but it still grey.

on other side(cisco 2950 switch) i trying:

interface Port-channel1
no ip address
flowcontrol send off
spanning-tree portfast


interface FastEthernet0/9
no ip address
channel-group 1 mode on
spanning-tree portfast

interface FastEthernet0/10
no ip address
shutdown
channel-group 1 mode on
spanning-tree portfast

interface FastEthernet0/11
no ip address
shutdown
channel-group 1 mode on
spanning-tree portfast

interface FastEthernet0/12
no ip address
shutdown
channel-group 1 mode on
spanning-tree portfast

but connection icon still grey
and
sh int port-channel 1
shows no bytes sent or received.


anyone can help?
thanks.
8 answers Last reply
More about ep45 realtek teaming utility windows
  1. Link aggregation ('teaming') seems to be supported for some Cisco 2950s; however, beyond that, it becomes complex... There are several kinds of aggregation; there are several kinds of 2950s with at least three kinds of firmware; there are a lot of 'known' problems with RealTek teaming and various switches - to research further I will at least need the actual part number of your particular 2950 (like: "2950G 24EI DC"), as well as the firmware 'set' installed ("Standard Image", "Enhanced Image"?)... If I am not clear (English not primary language?), please post back, and I will explain differently, or attempt to 'adjust' for your language (if it is one I have experience with :??: )
  2. i dont this problem on cisco side.

    cause new teaming connection displayed grey.
    maybe it not enables cause of driver, maybe it will be enable only when link will work.

    Here my switch, it support etherchannel, LACP and PAgP
    i try all of them


    Cisco Internetwork Operating System Software
    IOS (tm) C2950 Software (C2950-I6Q4L2-M), Version 12.1(22)EA13, RELEASE SOFTWARE (fc2)
    Technical Support: http://www.cisco.com/techsupport
    Copyright (c) 1986-2009 by cisco Systems, Inc.
    Compiled Fri 27-Feb-09 22:20 by amvarma
    Image text-base: 0x80010000, data-base: 0x80570000

    ROM: Bootstrap program is C2950 boot loader

    Switch uptime is 15 hours, 27 minutes
    System returned to ROM by power-on
    System image file is "flash:/c2950-i6q4l2-mz.121-22.EA13.bin"

    cisco WS-C2950G-48-EI (RC32300) processor (revision K0) with 20957K bytes of memory.
    Processor board ID FHK0725Z0ST
    Last reset from system-reset
    Running Enhanced Image
    48 FastEthernet/IEEE 802.3 interface(s)
    2 Gigabit Ethernet/IEEE 802.3 interface(s)

    32K bytes of flash-simulated non-volatile configuration memory.
    Base ethernet MAC Address: 00:0D:29:6A:0F:80
    Motherboard assembly number: 73-7409-12
    Power supply part number: 34-0965-01
    Motherboard serial number: FOC072425DS
    Power supply serial number: DAB07226XT2
    Model revision number: K0
    Motherboard revision number: A0
    Model number: WS-C2950G-48-EI
    System serial number: FHK0725Z0ST
    Configuration register is 0xF
  3. That's the info I need to start digging - may take me a while - info is not that easy to get... I doubt it's actually the switch itself - but likely an incompatibility - have to make sure it can do static aggregation, and find out how to configure for that... I'm pretty sure the RealTek ports/drivers can not do either type of dynamic aggregation.
  4. just one question, if aggregation not setup on switch, can i enable team connection?
    or it will be enabled automatically only after aggregation link will be established?
  5. For most switches, (don't know yet about your Cicsco) link aggregation must be enabled in firmware, and configured, as there are several aggregation standards...
  6. no, i am not asking about cisco switch, i have CCIE lab and aggregation work between cisco switches....
    it work between cisco switch and Sun X1034A Quad NIC(linux only, no win drivers)

    what happiness with teamed "Local Area Connection" icon if motherboard connected to simple switch, without aggregation support?
    my "Local Area Connection" icon is gray, and i think is computer side problems.

    i found here http://forums.anandtech.com/showthread.php?t=193933
    AFAICR you had no problem under XP but teaming never worked for you under Vista64
    i never use vista at all, i bought this mobo 1 year ago and install Win 7 beta, than RC, only week ago final build(after RC start rebooting every 15 minutes).
    i year ago teaming utility was available only for XP and both vista, and it not working proberly under 7.
    interesting, this utility was available only on motherboard CD, it not available on Gigabyte or Realtek web-site.

    now i found it for Win7, but think it not working properly.

    I heard Intel Quad card works very good, but it support gigabit(cisco 2950 does not) and cost around $70.
  7. Hi! I'm new and know nothing of anything that you guys posted here. ;) I just want to share and maybe can help... I have Gigabyte GA-EP45-EXTREME and currently running on Windows 7 x64, I can't find the realtek utility on gigabyte's suport website but i did try the CD supplied by gigabyte. At first I can't install the utility then I tried compatibility mode to vista sp2 then it installed but disabled my LAN and it re-enabled it again, after the setup finishes i check and look at my modem/router (Thomson TG585 v7) the once before two (2) LAN's connected on ports 1 and 2, now shows only 1 but i'm still physically connected to ports 1 and 2 but on the interface it shows only 1 port is used.

    I just finished setting up my Mobo just a few minutes ago and now it's working properly. (I hope) ;)

    I hope this helps. Goodluck!
  8. Port aggregation is not supported on 'consumer' grade routers; simple reason: insufficient ports! Think of it - if you could get an 'aggregate' link on your four port router, it would use up two - which would leave only two for anything else supporting aggregation to link to... Be pretty much no longer a router - would become a 'null' cable between only two points. Aggregation, implemented through a switch, gives you an 'extensible' 2Gbit link - mostly only useful for servers. If you DL the latest (7.017)driver from RealTek:
    http://www.realtek.com.tw/DOWNLOADS/downloadsView.aspx?Langid=1&PNid=13&PFid=5&Level=5&Conn=4&DownTypeID=3&GetDown=false
    it unzips a directory called "UTILIZE_DUAL_MAC_GUIDE" with some crudely translated, but apt uses for a twin port on a consumer board...
Ask a new question

Read More

Gigabyte Windows 7 Realtek IP Motherboards