Sign in with
Sign up | Sign in
Your question

BIOS won't recognize SSD when hard drive is connected

Last response: in Storage
Share
July 29, 2011 1:52:57 AM

Hi, everyone. I recently bought a Crucial M4 64GB SSD, with the intention of using it as my OS Drive on a previously built system. I disconnected the HD from my Mobo (ASUS M4a89GTD PRO USB3) and hooked up the SSD. BIOS recognizes it in this state. I then installed windows, and experienced no problems.

The odd thing occurs whenever I connect the HD back up to the mobo. BIOS doesn't recognize the SSD at all. I can shut down, disconnect the HD, and then BIOS recognizes it again. It's driving me absolutely nuts. I've tried moving the SSD connection to different SATA ports, as well as the HD. I have no idea what's causing this.

I am running the SSD and the HDD off the same modular SATA power cable. That wouldn't cause an issue, would it?

EDIT: One more thing I forgot to mention...when I let the HD boot up windows when the SSD is still attached, Windows 7 does recognize the SSD.
July 30, 2011 12:59:37 AM

Nobody has any insight? This problem is driving me crazy. Please help!
a c 104 G Storage
July 30, 2011 3:12:52 PM

Hi Greg,

Give us as much info as possible regarding your BIOS setup. Are you running either HDD or the SSD in AHCI SATA mode, or XHD, or IDE mode? Are the disks set up as Basic drives or Dynamic drives? Also how are you switching back and forth to the boot drive?

Another very helpful thing to do is with just the SSD, and both SSD and HDD connected, go to Disk Management, and post images of what Disk Management looks like, especially the lower graphical area where the DriveStatus and VolumeStatus are shown. Can use PhotoBucket or ImageShack to do that.

That will give everyone a better idea of what's going on, and how to best correct it.

Related resources
July 30, 2011 3:51:32 PM

Thanks for the reply, John.

I'm running the SSD in AHCI mode, and the HDD in IDE. As for the disks being set up as Basic or Dynamic drives, I honestly don't know. I'll look into that and get back to you.

As for switching back and forth between the boot drive, that's my main problem. I actually removed the CMOS battery on the motherboard, and now all drives show up under connected devices in BIOS. However, when going to set boot priority, the SSD drive is still not available. My only options are the DVD drive, the hard drive, and removable device. Yet, when I disconnect the SATA cable from the hard drive (when PC is shut off...no hot swapping), then the SSD option is available under boot priority.

I think I didn't explain this well enough in my original post, but when both devices are connected to the motherboard, the PC boots up windows from the hard drive. After a time of being in the Windows environment, the OS recognizes the SSD as a new disk drive. Obviously, my goal is to set the SSD at the top of the boot priority, and eventually remove Windows from the hard drive.

I will also try to get those Disk Management images posted within the next day or so. Thanks so much again for your help.
a b G Storage
July 30, 2011 4:20:37 PM

The boot priority divides up the devices into categories (optical drives, fixed drives, and removable drives). You are choosing which category is booted, rather than which device.

What you have to do is choose which device within the hard disk category is the boot device for that category. How that works will depend on your motherboard's BIOS. On one BIOS I have used, you highlight the category, then press a key to cycle through the possible devices in that category. On another BIOS you had to highlight the category, then press a key to bring up a list of devices in that category, then choose the device from that list. I can't tell you how it works on your motherboard - look closely at the options. I downloaded the manual for your motherboard, and it doesn't say - that's really annoying!
a c 104 G Storage
July 30, 2011 5:39:26 PM

Hi Greg,

Just for clarification, is your older HDD an IDE drive connected to the IDE port on the MB, and the SSD connected to SATA_1 ?

If so it's been my experience when you choose AHCI for the SSD, then it doesn't show up on the Integrated Peripheral page (or similar) of the BIOS. Usually the AHCI ports are shown very briefly just after the splash screen, when is says AHCI controller enabled. If both drives are SATA, then you should be using SATA_1 and SATA_2 on the MB, and the IDE controller on the Main BIOS page should be disabled (at least for now). If both are SATA, neither drive on the Integrated Peripherals BIOS page show up, but they do just after the spash screen where it shows which port each is connected to. Sometimes, clicking on 'pause' just then will pause the console screen to see or write down.

I agree with Compulsive, you may be overlooking setting the [Hard Drive] correctly. When you go to the [Boot] page of the BIOS, there is a setting for 1st Boot Prioriry. That should be Hard Drive. Click on the "Hard Drive" and you may get a submenu, where you set which "hard drive, SSD or HHD is first to boot. If so, set it to SSD, and that may solve the problem. It's not obvious from the manual. That one usually you use the up/down arrows to move them.

Also you can tell if your drives are Basic or Dynamic on the Disk Management page in windows, in the lower graphical area it will say under the DriveStatus column.

See if that gives you the info you need to get you going.
July 31, 2011 8:46:45 PM

Here's a screenshot from Disk Management


As for the boot priority options, my BIOS is different. It actually lists the devices by specific name. For instance My HDD is identified as SAMSUNG F3, and DVD drive is identified as ASUS. Removeable device is the only generic term to select from.

I had the SSD drive connected to SATA1, but tried moving it to SATA2 to see if it would help. The HDD is connected to SATA5, because in my BIOS I had to set SATA1-SATA4 to AHCI (as far as I can tell I can't set them individually). I have to put the HDD and DVD on SATA5 and SATA6, because they're not 6GB/sec devices.
a c 104 G Storage
July 31, 2011 10:25:01 PM

greg2709 said:
Here's a screenshot from Disk Management http://img836.imageshack.us/img836/3591/captureccy.png


As for the boot priority options, my BIOS is different. It actually lists the devices by specific name. For instance My HDD is identified as SAMSUNG F3, and DVD drive is identified as ASUS. Removeable device is the only generic term to select from.

I had the SSD drive connected to SATA1, but tried moving it to SATA2 to see if it would help. The HDD is connected to SATA5, because in my BIOS I had to set SATA1-SATA4 to AHCI (as far as I can tell I can't set them individually). I have to put the HDD and DVD on SATA5 and SATA6, because they're not 6GB/sec devices.


Interesting, Greg,

I would try placing the SSD on SATA-1, the HDD on SATA_2, and the DVD on SATA_3 to see if that works. I forget if your SATA drives start at SATA_0 or SATA_1, but place the SSD on the first SATA_? port on the MB.

I think what is happening is the BIOS is recognizing the IDE drives first, that's why the 465 GB HDD is DISK 0 and the 'system' drive and drive C., then the SSD as Disk 1, and drive F. When you installed your OS on the SSD, did you have the HDD plugged into the MB at that time?

It is confusing, but connecting your HDD and DVD on the AHCI ports doesn't change one bit how the data is stored or read from these drives, only the controller used. Place these devices just after the SSD, and hopefully the will be recognized in order, Port 0, Port 1, Port2 on the AHCI controller. As they come up on the console screen just after the Splash screen, hit the pause button and see if they are in proper order.

With that change, post again Disk Management screen again for us to see if they are recognized in sequential order.
July 31, 2011 10:25:58 PM

Well, I finally figured it out...or more accurately you guys figured it out for me. Sure enough, underneath the boot priority option, there was a hard disk option where I could set the primary hard drive. So simple, yet it gave me fits.

Thanks for your help everyone!
a c 104 G Storage
July 31, 2011 10:32:40 PM

greg2709 said:
Well, I finally figured it out...or more accurately you guys figured it out for me. Sure enough, underneath the boot priority option, there was a hard disk option where I could set the primary hard drive. So simple, yet it gave me fits.

Thanks for your help everyone!



There you go!!! Each BIOS is a little different in their setup, and that strategic page wasn't listed in the manual.
So, now when you see this question come up again, you will know better than anyone exactly how to correct the problem!
!